Smart SDR iOS 1.0.8 Low Audio on iPhone 7

  • 1
  • Question
  • Updated 2 years ago
  • Answered
I'm using Smart SDR iOS 1.0.8 with a 6500 on an iPhone 7 Plus.  If I listen to the audio through the iPhone, the volume is low with all volume controls set to max (phone & software).  The audio seems to be the same as a phone call not on speaker.  Am I missing a control to put the iPhone audio on its speaker?  I looked in Settings>>SSDR and didn't see anything there or elsewhere.  No issues if I switch the audio to the speakers on the Flex--this works as expected.
Photo of W9WLX-Chuck

W9WLX-Chuck

  • 35 Posts
  • 9 Reply Likes

Posted 2 years ago

  • 1
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3646 Posts
  • 1478 Reply Likes
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3646 Posts
  • 1478 Reply Likes
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3646 Posts
  • 1478 Reply Likes
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3646 Posts
  • 1478 Reply Likes
Settings --> Defaultto Speaker
Photo of W9WLX-Chuck

W9WLX-Chuck

  • 35 Posts
  • 9 Reply Likes
Thanks for the detailed screen shots!  It all checks out, this is the way I have it set.  The audio is coming out of the iPhone, but as if it is a non-speaker phone, phone call.  The audio was on the iPhone speaker on my iPhone 5, but since upgrading to the iPhone 7 plus, I only get "phone call" audio.
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3646 Posts
  • 1478 Reply Likes
Can you toggle speaker on the third screen
Photo of W9WLX-Chuck

W9WLX-Chuck

  • 35 Posts
  • 9 Reply Likes
Yes, I tied toggeling with the option on the third screen.
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3646 Posts
  • 1478 Reply Likes

I don't have an iPhone 7 so I can't duplicate it.. but it works on my 6+ and various iPad's


So I guess we will need Marcus to come up with suggestions..

Photo of W9WLX-Chuck

W9WLX-Chuck

  • 35 Posts
  • 9 Reply Likes
OK, this was my experience too.  Worked as expected on the iPhone 5, not fully compatible on iPhone 7 Plus.
Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 150 Posts
  • 40 Reply Likes
Hi Chuck, sorry I was on the Electronica Fare in Munich last week and not able to respond sooner.

(Thanks Howard for your fantastic response to Chuck)

The App is indeed fully compatible to the iPhone 7 plus (and 7) so I am wondering what the problem could be here.

I personally have a couple devices, including the 7 and 7 plus (and 6 plus and older or course) which all behave the same in this respect.

Chuck, can you please try the following:

- Start the SmartSdr App
- Go to settings and set "Default to Speaker" to on
- Set "Allow Stereo" off
- Close the App (which will save these settings)

Now, restart your phone completely.

- Start the App again.
- Connect to your FlexRadio
- Ensure that sound is diverted to your iPhone (Left Audio Menu -> "Device Audio" set to "On" and the top Speaker Icon enabled)
- Now go to Settings inside the App
- The "Default to Speaker" setting should still be on.

Now, please toggle this Setting to Off and On again and you should note a real difference between On and Off.

When Off, indeed, only the top ear speaker will be used, when On, also the bottom Speaker will be used which should result in an improved audio quality for the App.

But please note: As the iPhone 7 (and Plus) now have Stereo Speakers and since the Top and bottom Speakers are physically different, Apple tried to adjust the physical difference of both speaker via Software which results in a lower Audio gain compared with the older Phones but you can increase the gain by using the recently added Sliders "Speaker volume adjust". However, when comparing both Phones (the 6 and 7) side by side, the 6 (and older) devices with Mono speakers simply sound better than the new Stereo 7 speakers - Of course, for Music in Stereo, this is the other way round.

vy 73,
Marcus, DL8MRE
Photo of W9WLX-Chuck

W9WLX-Chuck

  • 35 Posts
  • 9 Reply Likes

Thanks Marcus.  Rebooting the phone corrected the problem.  I now have good audio out of both sides of the phone.  Toggling the "Default to Speaker" turns all audio on/off.  Toggling the "Allow Stereo" switches the audio from what I had before to the desired audio.  The desired audio is when the "Allow Stereo" is set to off.

-73, Chuck, W9WLX

Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2283 Posts
  • 925 Reply Likes
I have had some inconsistency with audio routing in the iPhone 7 plus. Echolink has had that issue as well. I believe it has to do with the elimination of the analog headphone jack so that some apps get "confused" as to where to go. iPad and my iPhone 6 plus don't have that issue. 
(Edited)