Smart SDR for ios connect problem

  • 1
  • Question
  • Updated 1 week ago
  • Answered

Using Flex 6500, PC with W10, SSDR latest version, iPad model A1458 (4th generation) 2012.

+ wifi network.  Downloaded and purchased app and demo version works ok, Cannot get app to connect to flex 6500.   radio works fine with SSDR.  ipad connected and working normally on Wi-Fi link with BT hub router. Have tried search and specific ip address.  Any thoughts and ideas welcome but please keep simple as not an IT guru.    When looking for specific ip address for 6500 is this the ip address that shows under 'settings', 'radio setup', 'radio' tab? or the one which shows on pop up after connecting 6500 to ssdr?

Malcolm G3PDH

Photo of Mal G3PDH

Mal G3PDH

  • 43 Posts
  • 2 Reply Likes

Posted 2 years ago

  • 1
Photo of Mal G3PDH

Mal G3PDH

  • 43 Posts
  • 2 Reply Likes
should have also mentioned that iPad using v9.3.4
Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 129 Posts
  • 37 Reply Likes
Hello Malcolm,

In general you don't have to deal with IP Addresses or anything else. The Settings for "Scan instead of discovery" and "Fixed IP" and the IP Address field in the settings are only for special situations where a regular and automatic discovery can not be used or is not working.

As in your case, you just seem to have your Radio connected to your local home network and your Wireless Router is connected to the same network, you can and should use the automatic discovery option.

So can you please double check if "Scan instead of discovery" as well as "Fixed IP" have both been switched off in the Settings of the App.

Next, if you tap on the "Panadapter" tap at the bottom, just tap in the center of the screen and see what happens. You should at least see the "Demo" device but after a while (1-2 seconds) also your FlexRadio device.

If this is not the case, I would recommend, just in case, to completely switch off and on your FlexRadio and your iPad and try again.

Please let us know if this has helped.

vy 73,
Marcus, DL8MRE
Photo of Mal G3PDH

Mal G3PDH

  • 43 Posts
  • 2 Reply Likes
Marcus, thanks for your quick response.  I have tried switching off both  scan and Fixed IP off but still no connection.  Also switching off the iPad and Flex.  I always see the demo 6700 ok but it just continues with searching.  Also tried connecting by tapping both 'CON' and the centre of screen.  When I switch on scan instead of fixed and try to connect the search window shows the 6700 demo and then says 'done' but no 6500 shows up.    The IP address in setting is currently as the default at 192.168.1.1.   Is there anything I need to do in the settings for Networks, homegroups etc on the PC or on the ipad?
Photo of Mal G3PDH

Mal G3PDH

  • 43 Posts
  • 2 Reply Likes
Marcus,  a further thought,  I should probably have mentioned earlier,  my PC is also connected to the hub via wifi so could that make a difference?
Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 129 Posts
  • 37 Reply Likes
Hi again Mal,

no, it should not matter if your PC is using WiFI as well.

For some reason, your iPad can't see your Radio on the network.

Can you please try the following:

- Start SmartSDR for Windows. Don't connect to your device but just click on the Device on the left hand side. Now, on the right hand side, the tab "Radio" should be selected. Here, please note the IP Address (for instance 192.168.1.22)

- Start your iPad. Go to Settings (the gear Icon). Tap on Wi-Fi then tap on the right hand (i) on the line below the green Wi-Fi switch. Please also note the IP Address here (for instance 192.168.1.28).

For both IP Addresses (iPad and Windows), it is important that the first three numbers are identical, like in the example before: 192.168.1

Is that the case on your network?

vy 73,
Marcus, DL8MRE
Photo of Mal G3PDH

Mal G3PDH

  • 43 Posts
  • 2 Reply Likes
Thanks Marcus, the result of your recommended test is that the radio IP is 169.254.9.130 and the IP addr shown on the iPad wifi is 192.168.64. Router and DNS also show 192.168.1.254.
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 970 Posts
  • 200 Reply Likes

Mal, do you have an Ethernet cable going directly from your PC to the radio by chance? If so, can you plug both the PC and radio into your router? Or at least connect the radio to the router.

Also remove power from the PC for 30 seconds then power it back up.


Dave wo2x

(Edited)
Photo of Mal G3PDH

Mal G3PDH

  • 43 Posts
  • 2 Reply Likes
Dave, yes, I have a direct ethernet cable from radio to PC but unfortunately cannot easily plug into Router as it is in another part of the house. Hence why I am using wi fi for connecting pc.
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 963 Posts
  • 200 Reply Likes

That is why it is not working. Then the only other thing you might be able to do is bridge the two connections in your PC. Or use a WiFi bridge device and put a small hub at your PC/radio end.

Here's a guide for doing the bridge in Windows 10. http://www.windowscentral.com/how-set-and-manage-network-bridge-connection-windows-10

73

Dave wo2x

Photo of Peter K1PGV

Peter K1PGV, Elmer

  • 540 Posts
  • 310 Reply Likes
Addresses that start with 169.254.x.y are the result of not being able to get a DHCP address. You'll see this if you put a cable directly between your radio and your PC. The PC can talk to the radio, but the radio isn't on your overall networK (it just has a private connection to your PC).

Does that make any sense? Does it help at all?

Peter
K1PGV
Photo of Mal G3PDH

Mal G3PDH

  • 43 Posts
  • 2 Reply Likes
Ok, thanks guys for your responses and I understand the gist of the problem. I will investigate ways of how to reconfigure the hardware, however I think this will be a task for the winter as I am busy over the next 2 months.
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 970 Posts
  • 200 Reply Likes

try the Windows bridging method I sent a link to. Shouldn't take more then 15 minutes or so to set up.


Dave wo2x

Photo of Mal G3PDH

Mal G3PDH

  • 43 Posts
  • 2 Reply Likes
Ok Dave, will study that in detail too as would obviously be the simplest method if I can achieve it.
Best 73. Mal G3PDH
Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 129 Posts
  • 37 Reply Likes
Hi again Mal,

I just woke up and see that other HAMs already have been helpful so also thanks also to you dear OMs!

Yes, indeed, the problem is that your iPad is NOT connected to your WiFi network correctly.

I think bridging or a cable will not help as the source of the Problem is the WiFi connection between your iPhone and your wireless router.

I suggest to try to fix this before winter if you are using your iPad often at home as chances are that it uses up your data rate of your provider even when being at home.

As from here, it's very difficult to identify what part of the configuration went wrong I would suggest to start setting up your WiFi connection from your router and your iPad from scratch by considering the following points:

- Check for a Firmware update for your router first
- Give your WiFi network a new name (often this is called SSID which is the name which will appear on the iPad when looking for available WiFi networks)
- Use WPA2 for encryption and use a new good (at least 12 Character mixed number, small/capitals) password
- Check if DHCP is enabled on your router (this setting has nothing to do with WiFi and may be found somewhere else in the settings)

Then, after you are able to connect again from your iPad, perform the IP Address check as mentioned before. If you have identical first parts of the IP address I assume you will also be able to connect to your FlexRadio - and might have solved other issues on your iPad as well.

Please keep us updated.

vy 73,
Marcus, DL8MRE
Photo of Rick Stealey

Rick Stealey

  • 3 Posts
  • 0 Reply Likes
Now that you guys have solved this problem, how about a simple one - mine !  I installed the app, and want to run the demo before purchasing but nothing happens when I tap the "Tap here to connect."  In SETTINGS I have "Show demo device."  
I have deleted and reinstalled the app, and done a hard shutdown of the ipad, but same results.  It is an ipad air, with latest ios upgrade.  
Must be something simple........ but what?
Tnx
Rick   K2XT
Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 129 Posts
  • 37 Reply Likes
Hi Rick, just in case: Can you double check that scan instead of discovery and fixed IP has been switched off. And one question: What do you see when you "tap to connect". Do you see a small centered window with the Title "Discovering..." and below, just a white/empty content ?
vy 73,
Marcus, DL8MRE
(Edited)
Photo of Rick Stealey

Rick Stealey

  • 3 Posts
  • 0 Reply Likes
They are turned off, "Show demo device" is ON.
When I hit "CON" or "Tap here to connect" the app is completely unresponsive.  Nothing at all happens.
But it switches instantly to TOOLS, and SETTINGS, so the app is running at least.

Thanks for helping

Rick  K2XT
Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 129 Posts
  • 37 Reply Likes
Thanks Rick, so when you tap (e.g.) on "CON" it switches to Tools AND Settings ? But Tools and Settings are two different screens.
Photo of Rick Stealey

Rick Stealey

  • 3 Posts
  • 0 Reply Likes
No, sorry I wasn't clear.
If I hit CON, nothing happens.  
Or if I hit "Tap here to connect" nothing happens.
But if I hit either TOOLS or SETTINGS at the bottom it goes right into those menus.
Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 129 Posts
  • 37 Reply Likes
It turns out that the reason for the not functioning Demo Mode was that Rick answered the Question that pops up after the first start which asks for Microphone Access with no. Once he changed this back in the iPad Security settings, the Demo Mode worked again.

Thanks to George, K2WO!

vy 73,
Marcus, DL8MRE
Photo of Don Richardson

Don Richardson

  • 14 Posts
  • 1 Reply Like
Hi Flex Remote Users,
I have an iOS issue with getting my iOS device to connect to my remote radio.  In my case it is only iOS, as my Maestro and PC Software connect through SmartLink just fine.  I have been working this issue with Flex Support, but am not getting anywhere and thought you folks might be able to help.

I have a NetGear R7500v2 router at the remote end, and am trying to connect my iOS device to it.  I am setup properly with port forwarding on the remote end, but am now adding the ports manually.  I tried the uPnP setup but this never picked up the port forwarding so I turned this off.

When I start the SmartSDR application on my iPad, I have configured to use SmartLink to connect to my radio.  In the Pan Adapter screen I touch the Connect and I get a dialog that shows the remote radio and that it is available and not currently in use. I select my radio and am returned to the screen that says that I am not connected.

If I do the same, but this time select the little "i" to the right of my radio to get the info about the radio, is shows normal stuff but the TCP & UDP ports show as -1.  

After trying to connect, and being returned to the "Not Connected" screen, I leave it there for a long time and of course it never connects.

Keep in mind that the Maestro works fine in this configuration, as well as the PC version of the software both using SmartLink.  So, I can only assume that the iOS application is the one that is having problems.

Any help is much appreciated trying to solve this issue.  As it is right now, I have spent $49 to have a application that tells me if the radio is on-line or not.  This is getting a bit frustrating.

Regards, and thanks!!!

Don - KB1YWL
Photo of Brian VK3MI

Brian VK3MI

  • 4 Posts
  • 1 Reply Like
Hi Don - same problem here with mu iPhone. Did you manage to resolve the problem? Thanks, Brian VK3MI
Photo of Don Richardson

Don Richardson

  • 14 Posts
  • 1 Reply Like
Hi Brian,
So sorry that I did not reply earlier.  Day job has me very busy.

Anyway, yes I was able to fix my issue and it really had to do with the radio picking up and setting the port forwarding info.  I originally tried to do the Auto Port forwarding in my router, but ended up manually adding the port forward information.

Assuming you leave your manual port forward settings as described in the documentation for TCP 4994 and UDP 4992, and you are on the same network as the radio is on (I have a VPN connection to that network):

- Start SmartSDR for Windows
- On the Connection screen, (single) klick on your Radio
- Klick on SmartLink Setup
- Klick on the (V) Icon left to "Network Settings"
- Is your setting here set to Automatic ? That would be wrong.
- Klick on "Manual Port Forwarding"
- Enter 4994 in the first TCP Port field
- Enter 4993 in the second UDP Port field
- Klick on Save
- Klick on Test

This should result in a green Status for the radio.

The above was received from Marcus, the SmartSDR for iOS developer, and it worked for me.  

NOTE: If you try to do this configuration remotely, chances are that SmartSDR doesn't allow you to make these changes from your remote location or if it let's you, you may loose the ability to connect to your Radio.  This is why it is very important to be on the same network as your radio when making the above changes.

Hope this helps.  Please let us know if you are able to get this working.

73,
Don
Photo of Brian VK3MI

Brian VK3MI

  • 4 Posts
  • 1 Reply Like
Thanks Don and no problem about the delay. I eventually traced my problem to the traffic being blocked by the mobile connection that connected the radio network to the internet. Switching to ADSL solved the problem. 73, Brian VK3MI
Photo of John - K3MA

John - K3MA

  • 238 Posts
  • 63 Reply Likes
I am having exactly the same problem as Don - KB1YWL.
I have two Flex radios in two different locations with two different internet providers.
Both radios show up in Smartlink and I have no issues connecting and using with them with both the PC version and Maestro of SmartSDR over Smartlink. 

However, on the iPad version I can connect and use one but the other one never opens the user interface and hence cannot be used.  Looking at the info and the Smartlink connect window the only difference I see is one is has (UPnP) at the end of the first line and the other has (HP).

Any hints on how to make the one with (HP) work correctly with the iPad app?

This conversation is no longer open for comments or replies.