SDR no longer "finds" my 6700 on my mac running parallels 10 and windows 10

  • 1
  • Question
  • Updated 3 years ago
  • (Edited)
After installing Parallels 10 / Windows 10 on my new Mac Mini, I used the typical default settings and everything ran great for SSB.  When I tried to configure fldigi for digital modes, DAX showed streaming data, but no repeated portaudio errors resulted.  I was told by tech at FLEX that I should reinstall SDR, reboot windows.  I did this, but it after doing so, my SDR ware did not find my 6700.  
I currently am communicating to my router wirelessly, with the 6700 connected to my Mac mini via the ethernet cable.  However, there now appears to be no way to run my 6700. 
I am thinking of either;
1) Reinstalling Parallels 10/ Windows 10 and also reinstalling OSX .
2) Scrapping the whole MAC adventure, and buying a PC dedicated to the Ham Shack.  I am a MAC user , but I want to eventually be able to operate my station remotely.  I have Maestro on preorder.
3) OSX Recovery and uninstall parallel / windows 10 and after Reinstall / Recovery of OSX, I utilize Boot Camp instead of Parallels

I would like to keep my MAC , as I have grown used to MACLOGGER DX, but it seems most ham software is PC.

I need some help and there seems to be a lot of knowledge on the boards.  Be it known, I am not the most sophisticated with software/computers, but I am not a novice either, so bare with me.  

Thanks!
KJ8KJ  Keith
Photo of kjave63@yahoo.com

kjave63@yahoo.com

  • 69 Posts
  • 8 Reply Likes
  • frustrated and agitated

Posted 3 years ago

  • 1
Photo of Steve W6SDM

Steve W6SDM

  • 623 Posts
  • 280 Reply Likes
Nothing wrong with the Mac at all, but your life would be a whole lot easier with a PC.  Desktops are cheap these days.  Having a machine dedicated to your radio solves a lot of conflicts and makes it much easier to separate radio problems from problems caused by other software.

I like Linux Mint 17 - it's a nice, clean operating system without all the Windows bloat.  Sadly, I can't run my Flex under Linux and having Windows share a box with Linux is a big compromise, so I have separate PCs.  I even have another separate PC for the Windows projects I have like APRS iGate, digipeater, etc.

You won't regret having a PC dedicated to your Flex.  It's not absolutely essential, but it will work much better.
Photo of Sergey, R5AU

Sergey, R5AU

  • 847 Posts
  • 112 Reply Likes
Hi Keith, I am running on my MAC 5K with Parallels and Win10 without issues. To win I split 8Gb RAM and 4 cores of CPU. Some time after switching workspaces I need to restart DAX due to the buffer corrupted, but this not a big issue. You should:
- check resources
- check latency
- switch off all power management for USB and Ethernet on you Win
- check type of network on you Parallels ( I am using Bridge)
- check routing table on Win

I hope it helps
Photo of Lawrence Kellar KB5ZZB

Lawrence Kellar KB5ZZB

  • 200 Posts
  • 31 Reply Likes
You might want to check you virtual network adapter. Make sure it's in bridge mode "gets its own ip from router" not nat mode. I'm a VMWARE user but think the settings are similar
Photo of kjave63@yahoo.com

kjave63@yahoo.com

  • 69 Posts
  • 8 Reply Likes
I think my problem started after I changed my parallels 10 settings when I tried to get bridging between the VM and MAC and also file sharing as well.  Since I connect the 6700 directly to the MAC and the MAC to router via WiFi, I thought that this would work since Parallel 10 states that it automatically shares files between the VM and MAC, but it doesn't.  So I changed settings to manually allow all file sharing and then changed the network settings from Ethernet to Wifi, but since then I cannot find any ethernet or wifi signals or addresses.

If someone has OSX and Parallels 10/Windows 10 combo, some screen shots would be GREAT, for this beginner!  I know I am asking for a lot.

Keith KJ8KJ
Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1590 Posts
  • 555 Reply Likes
The Parallels Virtual NIC bridges the connector you choose. Try connecting the Flex to your router directly if you want Internet on the VM. Then bridge the wifi adapter to the VM.

If you want to use he Mac hardware NIC, you can bridge that to the VM. No internet, but Windows should do a link-local connection to your Flex.

I am using a similar installation (Mac Pro, Win 10, Parallels) very happily with a Time Capsule acting as a network extender (router elsewhere in the house). Everything plugs into the Time Capsule - and has assigned IP addresses. Having dedicated addresses for devices does help a lot while troubleshooting. I don't use the wifi in my Mac.
Photo of kjave63@yahoo.com

kjave63@yahoo.com

  • 69 Posts
  • 8 Reply Likes
While I will have direct ethernet connectivity in my NEW ham shack I am building in my new house for next year, I am physically too far from my router/time capsule to physically connect to them from the radio.  Therefore I have to use wifi for now.  Thanks for the info though, as that is the way I will install once my new home is done!
Photo of Joe, KQ1Q

Joe, KQ1Q

  • 79 Posts
  • 19 Reply Likes
On my iMac running Parallels Desktop 10, SmartSDR could not initially find the radio. All I then did was select Device->Network->Default Adapter (Bridged), and it showed up. My iMac and 6300 are directly connected via ethernet to the router.

My MacBook Pro connects via WiFi, is also running Parallels Desktop 10, and also connects to the 6300 just fine. I also have the Parallels default network adapter set to bridged on the laptop.
Photo of kjave63@yahoo.com

kjave63@yahoo.com

  • 69 Posts
  • 8 Reply Likes
So since I have my radio directly connected to the mac, mac connect via wifi to the router, would I still set the Parallels desktop setting for Default Adapter (Bridged)?
Photo of Joe, KQ1Q

Joe, KQ1Q

  • 79 Posts
  • 19 Reply Likes
To review, your Mac has two discrete network interface devices:

(1) WiFi
(2) Ethernet

You want both of them simultaneously connected and functional from Windows apps running in the Parallels Desktop 10 VM.

This causes a problem whereby (in the default config) Parallels can either be bridged to one network or the other but not both simultaneously. The behavior is if you bridge to one network, you have internet connectivity via WiFi, but SSDR cannot see the radio. If you bridge to the other network (ethernet), then SSDR can see the radio but you have no WiFi internet connectivity.

For some reason Parallels does not automatically enumerate and present both networks, which is the root problem.

The solution is manually add the 2nd network using the Parallels configuration, then set the ethernet network to the Flex as bridged. Steps:

(1) Shut down Windows vm 
(2) In OS X, click on the Parallels icon in the menu bar, select Configure. Verify no yellow warning banner at the top saying vm must be shut down before making changes -- it should already be down.
(3) In the Parallels configuration panel, click the add (+) button at bottom left, and select Network
(4) This creates Network 2. Under NIC Type, I selected Intel Pro/1000 MT, type: Shared Network. Network 1 should be your WiFi network -- you can double check that.
(5) Start the Windows vm.
(6) Back in OS X, click the Parallels icon in the menu bar, select Devices.
(7) For Network 2 ( the one you just added), I selected Bridged Network->Thunderbolt Ethernet. The names may vary depending on type of Mac and NIC, but you want Network 1 to be your WiFi network where you get internet access, and Network 2 to be the ethernet network that is directly connected to your Flex. In my testing, Network 1 (WiFi) does not require bridging, but Network 2 (ethernet to Flex) must be bridged.

If the above does not work, shut down and restart the vm. If that doesn't work, restart both Flex and OS X and try to connect. If that doesn't work, post your current situation.