Having issues with SDR-Bridge

  • 1
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
I just read posts from a couple of years ago about SDR-Bridge and sadly today I am experiencing many of the same issues with SDR-Bridge.  With my new 6300 and SmartSDR updates over the past couple of years, I was hoping things had improved. Any Flex 6000 users using CW-Skimmer successfully without SDR-Bridge?  With SDR-Bridge and Windows 10 I get very flakey performance. Sometimes it is close to working but the displayed signal in CWS is significantly off from the slice frequency.  Sometimes the desired frequency cannot be attained.  Example:  To test things I turned the slice to WWV on  10 Mhz.  The CWS frequency display won't go there, it moves to 10949 .  Another example. Right now I am looking at a very strong signal nicely displayed on CW Skimmer on 7023. However in my Panapter there are no signals at all from 7020 to 7025.   Another issue IQ1 displays a stream range of frequency, whereas IQ2  simply shows one frequency in the stream column  and in IQ2 the frequency displayed in CWS does not change if I click somewhere else in the SmartSDR screen./waterfall. I also just tried WWV on 5 Mhz and when my slice from Panadater B  is there, CWK does not display anything in its waterfall despite a strong WWV signal.  Even more odd, i just discovered that signal from Panadapter A IQ2  are actually being displayed in  IQ1 panadapter B despite having the DAX channels correctly set.    
Quite frustrating trying to get CW Skimmer to flow correctly.
Andy K3UK
Photo of Andrew O'Brien

Andrew O'Brien

  • 379 Posts
  • 43 Reply Likes

Posted 2 years ago

  • 1
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2252 Posts
  • 874 Reply Likes
Hi Andy,


I have had issues and it is a bit finicky but I figured out how to get it to work consistently.


First you have to make sure the DAX I/Q on the (panadapter) matches the DAX on SDR-bridge. You also need to make sure the slice matches for that DAX IQ. Finally you have to ensure the telnet port in skimmer is set correctly (7310 for IQ1, 7320 for IQ2 etc).


Once that is done you should be in business. If you see nothing in the waterfall or the band seems incorrect you may want to try changing the band in SmartSDR to another band and changing back. That nearly always works for me. I routinely have 4 skimmers running at once.
(Edited)
Photo of Bob G   W1GLV

Bob G W1GLV

  • 646 Posts
  • 107 Reply Likes
Been using SDR-Bridge, Ver 1.5, and have no issues whatsoever with the software.
Photo of Andrew O'Brien

Andrew O'Brien

  • 379 Posts
  • 43 Reply Likes
I bet it is the Telnet ports causing the problems, I did not pay attention to that.  I'll give it a try. 
Photo of Andrew O'Brien

Andrew O'Brien

  • 379 Posts
  • 43 Reply Likes
The Telnet ports are correct.  Still kinda flakey, will post a video capture.
Photo of Andrew O'Brien

Andrew O'Brien

  • 379 Posts
  • 43 Reply Likes
I have one Panadapater being fed correctly to CWS.  Thanks Ria.  Working my skims from Europe with CWX is like catching fish in a barrel .  One IQ stream will be fine for a day or tow until my brain gets used to the Flex bells and whistles. 
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2252 Posts
  • 874 Reply Likes
Andy, it is almost TOO easy now. :)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9129 Posts
  • 3453 Reply Likes
Are you using the latest version of CWSkimmer?
Photo of Ed - W2RF

Ed - W2RF

  • 232 Posts
  • 68 Reply Likes
SDR-Bridge does not have any readily reproducible bugs that I know of. There are a few quirks due to the complexity of getting several apps to work together, but those are well known and have easy workarounds.

I have had a report of a rare frequency difference between a signal in the Skimmer waterfall and SmartSDR, but have not been able to reproduce it here. (It was fixed by a clean install.) If you have information that might help to reproduce it, or any other concern in general, please post a support request on the SDR-Bridge web-site at http://www.qrv.com/contact.html

Thanks and happy Skimming!

73 Ed W2RF
(Edited)
Photo of NM1W

NM1W

  • 133 Posts
  • 24 Reply Likes
I've been using SDR-Bridge daily with no issue; I typically run 1-4 cw skimmers.. I will say  I needed to  read NN4ZZ's article several times since I kept having issues, but once I got things sorted its been great... 
Two issues I've run into:  1) cw skimmer crashes on startup with a kernel error; I just task kill it and restart it in sdrbridge.  2) its on the wrong freq. This 2nd issue usually only shows on startup, and I fix it by doing a band change to another band and then back again. Its not something I see happen all the time so I've not found a recipe to reproduce it.
-jim NM1W
Photo of Andrew O'Brien

Andrew O'Brien

  • 379 Posts
  • 43 Reply Likes
I read NN4ZZ's article several times. I think the issues are related to Windows 10.  I managed to get most aspect of SDR-Bridge and CWS working (although as NN4ZZ points out.. iSDR-Bridge does many unpredictable things).  On my fairly fast desktop with lots of RAM, CWS pauses for a few seconds every minute or so if  run in conjunction with the SDR-Bridge. Eventually the pauses cause decode to stop. CWS does NOT pause/;lag if I run CWS without SDR-Bridge.  However, last night I installed SmartSDR, SDR-Bridge,and CWS on a 10 year old laptop with less CPU and RAM capability than my desktop, all behaved perfectly.  My laptop has Windows 7. 
Andy K3UK
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9129 Posts
  • 3453 Reply Likes
Andy & Jim - since this is an issue that seems to be localized to a specific PC configuration and not something systemic and it concerns third-party software, primarily CWSkimmer, I think it is best to work directly with Alex and Ed privately.

Ed is a good guy.  I have known him for years and we have collaborated on software projects together (SDR-Bridge being one of them).  If there is truly a defect and root cause can be identified, he'll fix it.  Alex is an excellent programmer too.  I know he is not spending much time on CWS these days, but he has always been responsive to me when I have discovered skimmer issues.

So at this point, since there really isn't much more that the Community can offer and the issues are with non-FlexRadio products, I am inclined to close this topic.

This conversation is no longer open for comments or replies.