S meter with version 2.3.7

  • 2
  • Problem
  • Updated 4 months ago
  • Solved
  • (Edited)
After installing Version 2.3.7 in my 6600M, the S Meter and pan display is out of calibration.  
Ex:  a -62dbm on the pan display shows an S9+10db on the bar graph.

The bar graph never indicates below S6 without an antenna connected. 

I performed multiple cold boots as well as a factory reset boot with no change.  

One of the impressive features of the Flex is their superb accurate display. 

 Finally, I had to  downgrade to Version 2.2.8 which returned calibration to normal.  

I was wondering if anyone else has experienced this problem.  

73,  Paul
Photo of Paul,  KB3ML

Paul, KB3ML

  • 16 Posts
  • 6 Reply Likes

Posted 5 months ago

  • 2
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3478 Reply Likes
Official Response
This defect #6448, which only effects the FLEX-6600 and FLEX-6600M will be fixed in the next release of SmartSDR.
(Edited)
Photo of Steve - N5AC

Steve - N5AC, VP Engineering / CTO

  • 1031 Posts
  • 1002 Reply Likes
Official Response
Howdy -- here's the deal here: the S-meter is off by several dB in v2.3.7 for only the FLEX-6600 and FLEX-6600M.  We discovered the issue shortly after release and plan to issue an update soon to fix this.  It is only an offset, meaning the s-meter and panadapter will read higher than they actually are (I believe the amount is around 7dB), but it is only an offset in the amplitude and does not affect performance in any way.

Please remember that you cannot compare noise read on the S-meter in the slice receiver and the panadapter noise floor because of the different bandwidths of receivers used in the slice receiver (filter) and the FFT bin bandwidth (unless they are the same based on a zoom level).