S meter still not correct on FLEX6600M with Version 2.3.9

  • 1
  • Problem
  • Updated 2 months ago
  • Solved
  • (Edited)
On Version 2.3.9 the S Meter and Pre-Amp is NOT working correctly.
On the 6600M to see what I am saying, terminate the Antenna and go to the Attinuator and Pre-AMP settings and what I am seeing here is that -8 gives me a S4, 0 gives me S3, +8 gives me a S2, +16 gives me a S1, +24 gives me S1, +30 gives me S1. 
So where it is the most important on the lower bands to NOT run the Pre-Amp the S Meter reads 2 to 3 S unites higher then it is supposed to.
Test where run on 40Meters.

My FLEX 6700 when doing this exact same test with the Pre-Amp settings up or down all settings read S1 like it is supposed to.

I have done a hard reset of course and find this the same either Direct connect or through SmartLink connection's.

Thanks
Bret
WX7Y
Photo of WX7Y

WX7Y

  • 536 Posts
  • 98 Reply Likes

Posted 2 months ago

  • 1
Photo of Steve - N5AC

Steve - N5AC, VP Engineering / CTO

  • 1030 Posts
  • 999 Reply Likes
Official Response
Most radios don't adjust for the gain in the preamp when you turn it on.  As a result, the gain makes the noise floor RISE.  This is actually not what is happening in the radio.  A preamp should lower the noise floor.  All FlexRadio transceivers account for this and so the noise floor will generally go down, like it actually does, when you enable the preamp.  

However, there are two things that will stop the noise floor from going down: 1) atmospheric noise or 2) you've reached the limit on how low the noise floor can go given the noise figure of the radio and the cascade noise figure of the preamplifier with the receiver.