QSOrder Recording for S02R Configuration in N1MM

  • 1
  • Question
  • Updated 2 years ago
Does anybody have experience in setting up QSOrder (QSO recording software) and running S02R with N1MM on the Flex6000 series?

I've set up individual directories for each DAX channel I want to record, DAX1 and DAX2. DAX1 is for slice A, DAX2 is for slice B

I launch QSOrder in each directory (two instances) and use the -C (continuous recording option) and it records the audio from each DAX. This works great. When I enter in a log into the N1MM entry window for slice A, it records that QSO as expected.

What is not expected is when I enter in a QSO into the N1MM entry window for slice B, it tries to record that QSO on DAX1, not on DAX2.

Troubleshooting items I've completed.
1) entered in an additional UDP port on the N1MM .ini file and pointed the QSOrder listening on DAX2 to that UDP port (12061) to catch that broadcast. No luck.
2) Used the switch in QSOrder for the station number, but then found out that was only for networking within N1MM.
3) Manually switched the TX to slice B, thinking it was tied to what slice TX was selected, but that was not it either.

This might be more of an N1MM configuration question but decided to ask as I know some users do use QSOrder for recording on the Flex.
Photo of Kyle Krieg

Kyle Krieg

  • 26 Posts
  • 2 Reply Likes

Posted 2 years ago

  • 1
Photo of Chris Tate  - N6WM

Chris Tate - N6WM, Elmer

  • 820 Posts
  • 221 Reply Likes
Kyle I am personally interested in this did you get any offline responses?  It does sound like an N1MM issue but could be one of those two-way some of both type issues as well.

LMK.

Chris/N6WM
Photo of Kyle Krieg

Kyle Krieg

  • 26 Posts
  • 2 Reply Likes
Hey Chris - No response yet.

I contacted the developer of QSOrder and we are throwing around some ideas on how to make this work, but I doubt we are going to find something without some interaction from Flex or N1MM.

I also put this up on the N1MM website with no responses yet.

As I see it, there is two ways of fixing this.

1) Have a "mixer" created in the DAX control panel which mixes "X" number of DAX channels down to a separate stereo DAX channel mix for QSOrder to record (including your mic channel). I saw Steve Hicks at W9DXCC and mentioned this to him as an idea. Not sure if this is on the Flex developers "to do list".

2) Have N1MM create a separate UDP broadcast packet per VFO entry window to spawn off the correct QSOrder process to record the QSO audio.

If I find a solution, I will be sure to post.

Do you have this same issue that your trying to solve?
Photo of Kyle Krieg

Kyle Krieg

  • 26 Posts
  • 2 Reply Likes
Chris,

I got the developer of QSOrder to write some code and include the radio number within the program. It works like a charm now.

You have run X instances of QSOrder (one for each dax channel you want to record) but when you have a QSO on DAX2, it records it and the audio from DAX1 is ignored. Opposite behavior when trying to record on DAX1, audio from DAX2 is ignored.

I had some trouble running it as my computer upgraded and I had to re-load the C++ 2015 redistribute 32bit (my machine is a 64 bit) for the program to run. Not sure why that happened.

I can email you a link for download if your interested in testing. Shoot me an email from my qrz page and I send you a link.

Kyle

Notes from the developer below :

added -r --radio-nr option.

Run two instances
qsorder.exe -r 1 -P 12060 -i
qsorder.exe -r 2 -P 12061 -i

configure N1MM to broadcast on both 12061 and 12060

Brodcast Data tab in the config/ Contact 127.0.0.1:12060 127.0.0.1:12061