Profile Import/Export Dialog Does Not Resize (

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
I have a 6300 running SSDR on Windows 10 (running under Parallels 10).  
Attempting to export specific profiles out to the desktop for safe keeping, I found that the dialog type is not resizable.  It is fixed in size. This makes selecting specific Global and Transmit profiles difficult and specific Microphone profiles impossible. 

See the below screenshot:

Photo of Jay -- N0FB

Jay -- N0FB, Elmer

  • 534 Posts
  • 210 Reply Likes

Posted 2 years ago

  • 1
Photo of Jay -- N0FB

Jay -- N0FB, Elmer

  • 534 Posts
  • 210 Reply Likes
Working with Tim, this issue is resolved.  Here is the text of the support ticket:

  • Tim EllisonToday at 14:28


    Your SSDR.settings file is not corrupted.

    The Import/Export screen has a fixed set of dimensions that are dynamically determined and rendered based on screen resolution and the monitor DPI scaling. If it is displaying incorrectly and there are no issues with the SSDR.settings file, then it will have to do with how .NET is enumerating your display environment.

    Since you are running in a virtual environment, I can only suspect that the SmartSDR window size is somehow contributing to this behavior. You can try making the SmartSDR window larger and if the import/export dialog box changes size, then this is the issue. Let me know if that action makes any difference.

    Tim Ellison, W4TME
    Customer Experience Manager

    FlexRadio SystemsTM
    4616 W Howard Ln Suite 1-150
    Austin, TX 78728
    Phone: 512-535-4713

  • Jay Burgherr (N0FB)Today at 17:23

    The information provided was the secret sauce. I was running Parallels in "Coherence Mode" which makes the Windows applications appear as if they are running in the Mac Environment natively. To Windows, this mode behaves as if the monitor resolution is "0x0", thus the causing issue based on how the dialog is currently programmed. The work around is to:

    1.) Take Parallels out of Coherence Mode 
    2.) Make the Windows Environment Full Screen 
    3.) Open SmartSDR 
    4.) Import or export the file as needed within SmartSDR (dialog is now resizable) 
    5.) Exit Windows from Full Screen Mode 
    6.) Put Parallels back into Coherence Mode (if the user wishes) 

    Thanks Tim for the information and assistance!

This conversation is no longer open for comments or replies.