Problems with CAT while setting up N1MM+

  • 1
  • Question
  • Updated 12 months ago
Latest N1MM+ V1.0.6585.0 and SmartSDR CAT V2.0.17 and Radio V2.0.17  
CAT starts with default COM ports - observation.
With an ADD or EDIT type -  Port Type = Serial  and Serial Port = FlexVSP
Client COM: shows a range of COM155 to COM 256, with CAT COM defaults to 255

I set C to COM167 and CAT COM to 177
also C 168 to 178
and  W 169 to 179

N1MM+ set to 167 for Radio Flex6700
 168 for digital
 169 for CW Winkeyer

When N1MM+ is started SmartSDR CAT panel shows a) Radio Connected with each port connected to N1MM+

BUT: N1MM pops up that it cannot connect to the Flex.  No amount of parm changes will connect the two.

Suggestions?
Photo of Stan - VA7NF

Stan - VA7NF

  • 411 Posts
  • 90 Reply Likes

Posted 12 months ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9130 Posts
  • 3454 Reply Likes
Did you clear the in use ports as instructed in the Release Notes?
Photo of Stan - VA7NF

Stan - VA7NF

  • 411 Posts
  • 90 Reply Likes
Went back and inspected the notes.
If you are referring to "Shut down all third-party programs utilizing virtual com ports" the answer is yes.  Also went into windows management and deleted all defined COM ports; did not look for hidden ports.  Also re-installed twice.

What should I see when defining a COM port for N1MM+?  As stated above, I assigned one end to FlexVSP port 155+ and the other end at +10.  CAT indicates both the radio and N1MM is connected but N1MM doesn't recognize the connection - Gives the "not connected" pop-up.
This used to permit much lower port numbers (like 6-10) but not now.

 Com port characteristics (e.g. 8N1 and speed are not available)
Edit:  These settings are available if "Existing" is selected but there are no port choices, when FlexVSP is selected there are ports listed but no speed choices.  N1MM expects speed data to be placed in the "Set" panel.
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9130 Posts
  • 3454 Reply Likes
In the What's New in SmartSDR v2.0.17 section, where it lists the new FlexVSP driver, it instructs you to use this procedure to remove the "in use or "reserved" com ports.

https://helpdesk.flexradio.com/hc/en-us/articles/115000504463-Removing-In-Use-Com-Ports-for-Availabl...

If you manually deleted Flex com ports using Device Manager, then you probably have a mess.  You should always remove Flex com ports using the CAT application.  You should remove the Cat ports with the same application you created them with (SmartSDR CAT) since this removes the port and any associated registry entries.

What I would do at this point is the following:

1.) Open SmartSDR CAT and list the of ports you need for your third party apps.
2.) Delete all of the ports using the CAT application
3.) When done, place your mouse cursor over the REMOVE button in CAT and right click.  Select the option "Reset FlexVSP Ports"
4.) Close CAT
5.) remove the In Use ports using the HelpDesk article above.
6.) If you want to remove ghosted com ports now, do so.  Make sure you do not remove the drivers when removing ports.
7.) reboot the PC
8.) Open CAT  Now you a clean slate.  Add your CAT ports for your applications

You do not need to set the port parameters, the FlexVSP driver will dynamically accommodate any port connected to and set the parity, data and stop bits automatically.  Let CAT select the low port number.  Do not worry or set the high port number, as this is only used by CAT and not the third-party applications.  This is covered in detail in the SmartSDR CAT User's Guide.
(Edited)