Power Genius PO level not showing in Smart SDR GUI

  • 1
  • Problem
  • Updated 2 weeks ago
6600M v 3.19 The power out meter for the Power Genius just moves a very little on the Smart SDR window.  I had major help today from Dave WO2X and he suggested that I put this on the forum.  The power out looks correct on the Power Genius XL Utility and on my external meters but not on Smart SDR or on the front of the 6600M.  Any suggestions?  Comments?
Thanks, 
Jeff N3VE
Photo of Jeffrey Kerber, N3VE

Jeffrey Kerber, N3VE

  • 131 Posts
  • 20 Reply Likes

Posted 2 months ago

  • 1
Photo of Dan Quigley, N7HQ

Dan Quigley, N7HQ

  • 8 Posts
  • 1 Reply Like
When you say moves very little are you talking about peak readings on an SSB signal or if you are keydown CW/TUNE there is little meter deflection? 

73,
Dan, N7HQ 
Photo of Jeffrey Kerber, N3VE

Jeffrey Kerber, N3VE

  • 131 Posts
  • 20 Reply Likes
Dan, this is on SSB, very little deflection on SSDR but the power genius utility shows accurate power reading.  CW shows correctly.
Jeff
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1351 Posts
  • 289 Reply Likes
Hi Dan

I was helping Jeff.

Actually the utility isn’t quite showing accurate PEP readings. He was set for 1 KW out and utility would show just over 500 watts. The SmartSDR for Windows GUI and Maestro both showed just under 100 watts on the PG XL meter in both SSDR and Maestro.

He could not do a steady tune due to major RFI he is causing in the shack (that’s a story for another day).

Radio ver 3.0.19
Amp 3.12

73
Dave De Coons wo2x
Photo of Jeffrey Kerber, N3VE

Jeffrey Kerber, N3VE

  • 131 Posts
  • 20 Reply Likes
Dave, I plugged in a key and in cw mode the SSDR GUI worked fine.
Jeff
Photo of Dan Quigley, N7HQ

Dan Quigley, N7HQ

  • 8 Posts
  • 1 Reply Like
RRR - understood.  What does the PGXL front panel show?

There is a task in the firmware queue to review how we generate meter deflection data in general, I'll add this thread to that work item. 

Sure appreciate the details in these reports!

73,
Dan

Photo of Roger Thompson AD5T

Roger Thompson AD5T

  • 10 Posts
  • 0 Reply Likes
During the VHF contest I was confused when I didn't get any 6m ssb output power readings in the SmartSDR PGXL window while seeing proper levels in both the amp utility and the amp front panel.  I just tested twice on cw and twice on ssb this evening.  For cw, all three indicators did show proper amp power level, but there was no amp power output reading in the SmartSDR PGXL window in ssb.  So, as for now, I've not seen any amp ssb power readings directly in SmartSDR's PGXL window during the contest or in tests.

73, Roger AD5T
Photo of Ray - K6LJ

Ray - K6LJ

  • 76 Posts
  • 24 Reply Likes

Please talk with Tim by submitting a ticket he is familiar with this issue
Photo of Burch - K4QXX

Burch - K4QXX

  • 512 Posts
  • 120 Reply Likes
I've had this happen twice now with my new PGXL.  When it happens, I shutdown SSDR and power off the 6700 and remove the power from the 6700.  When I boot everything back up, the power meter works again in SSDR.  The meter always works on the amp and the utility software.
Photo of Ray - K6LJ

Ray - K6LJ

  • 76 Posts
  • 24 Reply Likes
Hi Burch there is a newer version of firmware for the PG-XL 3.2.4 that is in test. Ask Tim about it. He told me that as soon as it is tested it will be released. I have not had to reboot everything just reload the firmware to the PG-XL.
Photo of Burch - K4QXX

Burch - K4QXX

  • 512 Posts
  • 120 Reply Likes
Ray, did this fix the issue with the PO not showing is SSDR?  It has only happened to me twice and hasn't happening lately, although I haven't used the amp much lately.