Popping/crackling audio

  • 1
  • Question
  • Updated 1 month ago
  • (Edited)
My Flex 5000a has started having audio popping/crackling problems. I thought it was just received audio, and thought it was my speakers, swapped speakers still there. It Tried some CW and can hear it in Mon as well, with Drive at 0. It does it using CWX as well.  Did some testing, and others can hear it in my SSB audio as well. Running KE9NS 2.8.0.149. One other thing I saw a few months ago, is if I MUTE Speakers only, I would lose my speakers when I unmuted. Had to hit something to get them back, but can't recall what. I thing it was hitting MUT several time. Any ideas how to determine if it is PC or in the radio.
Photo of Les Hooe

Les Hooe

  • 3 Posts
  • 0 Reply Likes

Posted 1 month ago

  • 1
Photo of Mike

Mike

  • 9 Posts
  • 1 Reply Like
Sounds like computer interrupt commands. Do a search on interrupts. Can't remember the details. Have you changed hardware or added a new software program that runs in the background?

Mike / W8DN
Photo of Les Hooe

Les Hooe

  • 3 Posts
  • 0 Reply Likes
Thanks for the reply Mike,
Just before I got your reply, I found the Flex Troubleshooting guide, and it had this: 
Trouble Condition or Error: Garbled, raspy or choppy transmit audio on CW and SSB. Possible Causes and Resolutions:
1.) Operating Mode in the FLEX-5000 device driver Control Panel is set too aggressively. Use Safe Mode 1 or Safe Mode 2.
2.) The sampling rate and buffer size in the FLEX-5000 device driver Control Panel is not the same as the PowerSDR Audio setup.
3.) Audio buffer is too small for the sampling rate.
4.) Loose Firewire connection.
5.) Old version of firmware is loaded. Upgrade to the latest firmware version.
6.) RF getting into the FLEX-5000 or PC via the Firewire cable. Add additional ferrite beads of use a different Firewire cable with additional shielding.

And sure enough, I had changed CPU's in the computer, and thought I'll try to improve latency a bit. One of the things I did, was to change the operating mode from Safe Mode 1 to Normal, and had not changed it back. Changed back to Safe Mode 1, and all sounds correct now So your were right on target. Thanks, Les K7LES
Photo of Dudley - WA5QPZ

Dudley - WA5QPZ, Elmer

  • 261 Posts
  • 42 Reply Likes
Les, 

Using Safe mode 1 or 2 is adding some additional delay to the FW controller,   to allow a larger DPC delays in your system..  Nothing wrong in that , but if you were trying to run some fast exchange mode,  the added delay could be a problem ..   If you go to    helpdesk.flexradio.com  and do a search there for   "DPC"   there are several articles about DPC and why they are important concerning FireWire speeds..    

https://helpdesk.flexradio.com/hc/en-us/articles/202118398-What-are-DPCs-and-why-do-they-matter-

Also the DPC Latency Checker  
https://helpdesk.flexradio.com/hc/en-us/articles/202118698-Using-LatencyMon-to-collect-DPC-Latency-D...

You may need to  change drivers,  or FW controller to help ..  But if you are not concerned about CW timing or some quick exchange mode like ALE ,  then Safe Mode 1 or 2 , is not a bad option...

73,
Dudley