Loss of CAT in all applications after installing V2.0?

  • 1
  • Question
  • Updated 11 months ago
  • (Edited)
After installing V2.0 and getting SmartLink setup and running, I was feeling pretty good about this update.  This morning, I sat down, fired it all up and when I opened WSJT-X, it will not communicate with the radio.  Pop up says "Hamlib error: Communication timed out while opening connection to rig".  I've checked and rechecked the CAT settings for the radio and in the application with no improvement.  I tried Fldigi and I have the same issue going on.  <EDIT> Please add Winlink Express with the same issue.  The SmartSDR upgrade is the only change made since this all worked two days ago.  Windows 10, WSJT-X v1.8.0-rc1 r7847; Fldigi 4.0.6.; Winlink Express 1.5.6.1.

Anyone else see and solve this riddle yet?
Photo of Craig McVeay

Craig McVeay

  • 21 Posts
  • 1 Reply Like

Posted 11 months ago

  • 1
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1060 Posts
  • 214 Reply Likes
Craig,

Try this. Open SmartSDR CAT and add a TCP CAT port 5004.



Nest in WSJT-X Settings/Radio set ip up as per the following




Try that and see if it works better. Make sure you select Data/Pkt and also Fake It. 
The IP is 127.0.0.1:5004

Dave wo2x
Photo of Craig McVeay

Craig McVeay

  • 21 Posts
  • 1 Reply Like
Thank you Dave.  One down, a few more to go.  Gotta take off for work now though.  I assume a similar change in other applications will have the same effect?

Craig
N0CSM
Photo of Dan -- KC4GO

Dan -- KC4GO

  • 337 Posts
  • 68 Reply Likes
Thanks Dave 
73's Dan
Photo of Robert White

Robert White

  • 3 Posts
  • 0 Reply Likes
Did you cold boot the radio? Unplug 12v supply as described in the release notes? Fixed the problem for me.
Photo of Jay Spaulding

Jay Spaulding

  • 57 Posts
  • 3 Reply Likes
I have been using mine with no problem. But Im using Log4om as my log book and I am also using Omni-rig to control the radio on the FLdigi and WSJT. And when I log on those programs it puts in in my log automaticly then it goes to QRZ and then upload to Lotw. and there are others. 

Good luck
Jay
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9043 Posts
  • 3434 Reply Likes
Did you remove the "in use" ports after upgrading to SmartSDR v2.0.17 as instructed to do in the Release Notes?  If not, that can cause problems creating ports.