K9DUR Voice Keyer not keying Smart SDR

  • 1
  • Problem
  • Updated 1 year ago
  • Solved
I set up K9DUR voice keyer for my 6700 but it will only key the radio if VOX is enabled. This means I must click VOX before and after each message is activated.

Running 1.9.7.169

K9DUR Hardware configuration COM4
Soundcard DAX Audio TX

Has anyone been able to get PTT to function?

73 Pat
Photo of Pat

Pat

  • 153 Posts
  • 46 Reply Likes

Posted 1 year ago

  • 1
Photo of WX7Y

WX7Y

  • 497 Posts
  • 93 Reply Likes
You want to bring up SmartSDR Cat and create a PTT port should look like this 

Then it should work once you set the PTT port in Voice keyer, look at the screen shots below

Make sure to set your "DAX TX Stream" ports IN DAX as well  and Voice Keyer programs.

73's
Bret
WX7Y














(Edited)
Photo of Pat

Pat

  • 153 Posts
  • 46 Reply Likes
I set it up as you've indicated but it will not key the radio unless I have VOX enabled.  What am I missing?
Photo of Pat

Pat

  • 153 Posts
  • 46 Reply Likes
I just got it working now. I had to shut down the keyer a few times and restart and now it's working.

Thanks for the help . I really appreciate it

73 Pat
Photo of WX7Y

WX7Y

  • 497 Posts
  • 93 Reply Likes
Glad you got it working, 

A  couple of caveats,

1:Sometimes at least with older versions of DAX it would have noise kind of like RF in the audio, when this happens I have had to shut down DAX and restart it. 

2:If your configuration in CAT for the PTT COM port changes and you bring up VoiceKeyer with the wrong PTT COM port in CAT then it will erase the configuration in the VoiceKeyer program and you'll have to reconfigure it. 

3:ALWAYS test it before you need it to make sure other software hasn't changed any of your CAT or DAX settings for you or the COM port isn't used by any other logging or other software programs.

73's

Bret
WX7Y
 
Photo of Pat

Pat

  • 153 Posts
  • 46 Reply Likes
There is a severe limitation with this keyer. The hardware selection for PTT port is for a specific port assigned to a specific slice . Given that the 6700 can have 8 slices. This can be a problem if you're working more than one band

Example:

Working a 20 meter DX simplex with slice A. You have port 7 for slice A selected

You also have slice B and C open on 40 meters to monitor and work  DX split.  You switch to 40 , tune up and designate slice C as TX .Now you need to change the keyer hardware configuration and select a PTT port configured for slice C before you can use the keyer. If you don't do this  the keyer will transmit on the wrong slice on the wrong band. This could cause all kinds of problems including transmitting on the wrong band when your amp is tuned to a different band.

Are there any keyers out there that will key on whatever slice is currently the TX slice without having to go through the mentioned steps?
Photo of Pat

Pat

  • 153 Posts
  • 46 Reply Likes
OK. Just realized that I had to disable the Auto Switch TX Slice on the PTT port. Now it's working great.

Once again thanks for all the help

73 Pat

This conversation is no longer open for comments or replies.