IQ stream busy - again...

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Hi All,

I have three different computers I have run SmartSDR on and on each I've at one point in time accessed an IQ stream.

I reported a while back that IQ stream 1 was busy.  Got a little help from someone that suggested making sure my default playback device was not set to IQ stream.  Checked that.  I didn't have a lot of time so I moved on and used another stream.  IQ stream 1 kept reporting busy.

Yesterday and today I decided to go for a clean install on my development system due to several years of loading various stuff.  So I started with a fresh SSD, installed Win10 (I have to use it and support it for work) and went through the process to reload the things I use the most.

I loaded SmartSDR 1.6.x last.  I also loaded CW skimmer and SDR bridge.  

I went to configure CWSkimmer and found I could not use ANY of my IQ streams.  ALL reported busy when I tried to access and use them.  They all say in use by another computer.   But NO OTHER COMPUTER was actively doing anything.

It seems that IQ streams once accessed by a remote computer are tied up even if that remote computer is not really using them.

So just now I was on my newly reloaded dev computer trying to run CW skimmer.  No luck because ALL FOUR IQ STREAMS are busy.

I remembered last night that I have been running on my SurfaceBook.  The surface book was running but not running SmartSDR or anything that should have accessed IQ streams.  When I had been using with with CW skimmer I had to use IQ stream 4 since 1, 2, and 3 were busy.

So just now I shutdown the surface book completely.  I restarted on my dev computer SmartCAT and DAX.  Now I can use IQ stream 4 on this computer.

I have no idea where to go to release streams 1, 2 and 3.

Anyway to me this seems like a bug somehow that a remote computer can hold on to a stream even when it is not actually running any software that should use that stream.

I'm not sure if this analysis is correct but I'm baffled.  I did do a factory reset, and went and shutdown every other computer I'd ever run and perhaps used an IQ stream on.

Now I can use all four channels, sort of...  Any thoughts on what is going on?
Photo of Mark - WS7M

Mark - WS7M

  • 1001 Posts
  • 356 Reply Likes

Posted 3 years ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3471 Reply Likes
Official Response
This isn't a bug.  The situation is really straightforward once you realize that the DAX client is the software using the DAX channel resource.

In the radio there are only 4 or 2 DAXIQ resources based on the radio model.  If you install SmartSDR on multiple PCs, the DAX client installs and autostarts when you boot the multiple PCs.  

So if you enable a DAXIQ stream on a PC and do not disable it before you shut it down, when you boot that PC again and DAX starts, it will request a DAXIQ stream from the radio and if available will take ownership of it.  So while you think the PC isn't doing anything, it actually has allocated a DAXIQ resource. And if you reboot the radio, when it boots back up, the active DAX clients will automatically reconnect to the radio and reestablish their DAXIQ connection.

So if you start DAX and there are no more available DAXIQ streams available, the request to connect to one will be rejected because they are all taken.

To resolve this, you can (a) make sure you disable the DAXIQ channel when you stop using DAXIQ on the PC, (b) either not install DAX on all the other PCs by opting out of it on the SmartSDR for Windows installer or (c) go into the Startup folder and delete the DAX shortcut to prevent it from auto starting when the PC boots up.