iOS SmartSDR V2.0 smartlink issues

  • 1
  • Question
  • Updated 2 years ago
  • Answered
Hi Marcus,

Have started using Smartlink with the iOS SmartSDR app and observed a small problem.

If you mute audio using the audio symbol at the top of the display (Next to PTT) then lock the device (iphone 6S) when unlocking the device the app shows no connection and you then have to force disconnect before you can reconnect.

A work around is to mute the Audio using the slice audio controls, when everything works ok.

Another question when setting the Display parameters to optimise my audio quality I have to set the waterfall display speed quite low to  around 20 to prevent audio breakup. The FPS has little affect and can be set quite high. Is this actual data rate or processor load. The reason I ask is surely the waterfall is just a visual representation of the panadapter display and would not require additional data.

Also what does the "Low bandwidth Connection" option do selecting it does not seem to help.

Generally the app is a pleasure to use with smartlink 

Thanks
Photo of Andy M5ZAP

Andy M5ZAP

  • 179 Posts
  • 36 Reply Likes

Posted 2 years ago

  • 1
Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 151 Posts
  • 40 Reply Likes
Hi Andy,

many thanks for your post.

What's happening when the device gets locked is, that the App is being closed by iOS but SmartLink doesn't recognize yet such hard-disconnects. The same may happen when you would just switch off a Windows PC running SmartSDR for Windows. In this case, the Radio still assumes you are connected as the App had no chance to say goodbye to SmartLink. I think there are some watchdog timers in SmartLink so after some while of no traffic SmartLink may assume that the connection got lost but I am not sure if these timers are already in place as we discussed this briefly some time ago.

Would it be a solution for you to disable the "Disconnect on close" setting inside the App ? This way, the App stays connected until you use the "Disc" button.

Both Waterfall and FPS are using up Bandwidth as well as CPU load. Both have to be set to a low value for older / slower iPhones/iPads and reducing both will reduce the amount of traffic. The bandwidth for the Panadapter and the Waterfall are quite huge and much higher than the audio traffic. It usually doesn't matter if some packets get lost of either of these (Panadapter, Waterfall and even Audio) but if the total bandwidth is limited and since there is no way to prioritize the audio data, too much Waterfall and Panadapter traffic will damage the audio quality.

So you need to experiment a bit with these settings to find the best solution. You may also want to have a look to the NET Menu on the left hand side. This menu - depending on the setting - will also reduce the amount of bandwidth requirement in a slight different way. It will, for instance, reduce the number of horizontal pixels for the Waterfall which also results in less traffic.

Finally regarding your question about the "Low bandwith connection". This is a new setting for the Radio and not the Client which is also available in SmartSDR for Windows. The advantage of this setting is, that the Radio will be forced to use low bandwidth settings (e.g. to use only one Panadapter and Slice,  sets FPS to 5 and Waterfall Rate to 60) right at the time of the connection. This way, you can connect to a Radio even in very low bandwidth situations where you otherwise would not even be able to connect to the Radio to lower these settings manually.

This button only applies when connecting to the Radio and not while already connected.

I hope this information helps.

73,
Marcus, DL8MRE
Photo of Andy M5ZAP

Andy M5ZAP

  • 179 Posts
  • 36 Reply Likes

Hi Marcus,

Thanks for the comprehensive reply.

I do not have the disconnect on close set, The problem only occurs when I lock the device with the audio muted (mute next to PTT, If I leave the audio on or mute in the slice controls then lock the device the app resumes still connected.

Yes I fine tune the performance as you described and thanks for the explanation. Could you save some bandwidth requirement by reconstructing a Pseudo waterfall from the panadapter signal data?

Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 151 Posts
  • 40 Reply Likes
Ah, ok, got you regarding the mute button. I will look into that.

I discussed the option to generate the waterfall from the panadapter with Steve some time ago and for some reason, which I can't remember right now, we came to the conclusion that this is not possible or not really useful at the end. I barely remember that at least one issue was, that you never know the exact time for the panafall data whereas the waterfall data has a time-stamp. But I will will think again about it.

73,
Marcus, DL8MRE 
Photo of rob

rob

  • 7 Posts
  • 1 Reply Like

Good Morning All,

I'm also have trouble getting 2.0 and Smartlink up and running.  I have been following the threads to see if I have missed something in my setup.  

The issue I’m having is when I tried connecting remotely last night from the camp ground (Modem & Router) I would start to see the PTT button show up and before the rest of the of the screen i.e. slice and panadaptor would show up the screen would go back to the connect screen.

Today from work also on WIFI, when I hit connect is says connecting then times out with search error and finally a message that says Smartlink Connect, No Response from Smartlink Server.

 

Home setup:

Router ASUS 2400

On the home computer at the configured for Smartlink screen:


On my IPhone 7:

IP Address          73.4.105.116

PORT -1

Smartlink Yes

TCP PORT -1

UDP PORT -1

PORT FORWARD no

Hole Punch Yes.

Any help would be very much appreciated.

Thanks
Rob
Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 151 Posts
  • 40 Reply Likes
Hi Rob,

the issue here seems to be that you are neither using UPnP nor manual port forwarding.

I think that's all well documented and there are even a few Videos available but here is what I would suggest:

You can try to use Automatic first. However, this would only work if your Router is capable of doing UPnP. Some routers require this feature to be enabled. So if 'Automatic' still doesn't work, check your router.

If for some reason UPnP doesn't work or can not be used, try 'Manual Port Forward'. But in that case, you need to enter two port numbers instead of -1 (e.g. 4994 in the first field and 4993 in the second). But then, it is important that you need to forward these two ports in your router for your Radio. Please note, the first port (4994 in the example) is a TCP port and the second a UDP port. The procedure how to forward these ports in your router for your radio is different from router to router. Some routers use different names for 'port forwarding' so you you may want to consult your manual or Google for this. This is, why 'Automatic' (and have UPnP enabled in your router) would be the best solution for you - if it works.

In any case, the 'Test' has to result in a green state. In your case, it is red.

If it's not green, it's not worth to try to connect from SmartSDR (iOS or Windows) as it will not work unless the status is green.

Please let us know if you get this fixed or have more questions.

73,
Marcus, DL8MRE
Photo of rob

rob

  • 7 Posts
  • 1 Reply Like
I was able to enable UPnP on the router and everything is working fine.  

Thank you very much