I am trying to get SmartLink set up for my 6400.

  • 1
  • Question
  • Updated 5 months ago
 I am running Windows 7 and have an Asus RT-N12B1 router.  Under the Nerwork Settings on the SmartSDR main panel, there are two choices: Automatic and Manual Port Forwarding. Clicking Automatic and then Test FAILS.  
The RT-N12B1 Add a Service accepts
      Description:
      IP Address:
      External port number:
      Internal port number:
      and a choice of either TCP or UDP

Description and IP Address - no problem.  
Which type of port should I choose (TCP | UDP) and how do I determine the port numbers????
Photo of Bill

Bill

  • 3 Posts
  • 0 Reply Likes

Posted 5 months ago

  • 1
Photo of Chris Knight

Chris Knight

  • 14 Posts
  • 1 Reply Like
You need to choose any TCP port and any UDP port...the examples given in the SmartLink Quick Setup Guide is TCP 4994 and UDP 4993.  That's what I used.  Whatever you choose to use, when you select the Manual Port Forwarding option you put this info into the software.  

Below is a copy/past from the QSG in case I haven't described it clearly:

My router doesn’t support UPnP. How can I setup my radio to reliably connect to remote clients?
For a reliable connection without UPnP, you will need to use Manual Port Forwarding. To use Manual Port Forwarding, you will need to pick one TCP port number (e.g. 4994) and one UDP port number (e.g. 4993) for SmartLink to use. Referring to Register the Radio starting on page 7 go to the Network Settings screen. Select Manual Port Forwarding then enter the port numbers you have chosen in the TCP and UDP Port fields. Click the Save button. The remainder of this procedure is done to the configuration settings of your router. Details for setting up port forwarding on a wide variety of routers is beyond the scope of this document, but this document, https://helpdesk.flexradio.com/hc/en-us/articles/115003365503-What-is-Port-Forwarding-and-How-do-you..., should provide a good starting point. In addition to port forwarding, your radio should be assigned a Static DHCP address by the router to avoid occasional breaks in the SmartLink connection caused by changes to the radio’s IP address.
Photo of JohnSweeney

JohnSweeney

  • 52 Posts
  • 2 Reply Likes
Here is what worked for me:

Forward TCP external 21000 to internal 4994
Forward UDP external 22000 to internal 4993
Good luck!
K9EL
Photo of Danny K5CG

Danny K5CG

  • 304 Posts
  • 44 Reply Likes
For Automatic mode to work your router needs to support UPnP. Depending on your router model that may be a vulnerability or not.

Manual port forwarding is the most secure way to do it, and to keep it stable, it's best that your Flex has a static IP address (set locally or in the DHCP server of your router). Then the rules never have to change.
Photo of NX6D Dave

NX6D Dave

  • 303 Posts
  • 91 Reply Likes
Check your router to find out if it supports UPnP, but has the option turned off.  If so, you can turn it on and try the Automatic configuration.


If not, then configure your router manually as you have started to do.  If you have one radio (not two or more) on the LAN, then a simple way to configure the router by hand is to forward the port numbers that the radio is using to the outside of the router.  Using your information from above, you would input the IP address the radio is using, and ports 4994 and 4993 and then repeat the port numbers for the external ports.  External 4994 would be a TCP port mapped to radio port 4994, external 4993 would be a UDP port mapped to radio port 4993.

Ports 1-1024 are traditionally considered reserved numbers that you should avoid.  Beyond that, you can pick any port numbers.  I'm suggesting using the numbers used by the radio for simplicity.  Another frequently used approach is to add a constant, such as 10000, so you have ports 14994 and 14993.

Note that internally, the ports the radio uses are fixed, 4994 TCP, 4993 UDP.

Once the router is configured, then use the SmartLink registration function in SmartSDR or Maestro to tell the SmartLink server what the external forwarded port numbers are.  After that, you should be on the air.

On the subject of UPnP, it's a controversial feature.  Some believe it is intrinsically dangerous to use, potentially opening your LAN to hacking.  Others are fine with it.  Some users will leave UPnP off and configure port forwarding manually for this reason.  The choice is yours.