Help with DDUTIL to connect 6700 to OMPOWER amp.

  • 1
  • Question
  • Updated 5 years ago
  • Answered
Hi.
Maybe this is more of a DDUTIL v3 question, ...
I wish to use DDUTIL to control an OMPOWER amp with a 6700.
Set up:
-Windows 8.1: So far everything works fine.
-Flex 6700: correctly recognized by DDUTIL v3)
-OMPOWER: Connected with serial cable from Amp ́s transceiver RS232 to PC COM1
I have set the amp ́s auto mode to "Kenwood 9800N1" mode and played with DDUTIL Setup options with no luck so far.
What should I do or try?
Thanks in advance.
73
Santos, EA4AK
Photo of Santos Rodriguez

Santos Rodriguez

  • 27 Posts
  • 1 Reply Like

Posted 6 years ago

  • 1
Photo of Ed baker

Ed baker

  • 114 Posts
  • 8 Reply Likes
hello
Have used DDUTIL . Have used VSPE (Got them to work However occasional drop outs)

NOW use Commander 10.4.8 (No Drop Outs)

Setup. Config General SDR 6500
Continuous Interrogation

Flex CAT 1.2.0.0 Program running . Whatever port it says I use as CAT communications. In my case it is COM 4
COMMANDER CONFIG. PORTS
Primary CAT Serial port COM 4 (Set your baud rate as needed.
Secondary CAT Serial port COM 5 (This is the port I have the OM attached to my computer.
CAT protocol Kenwood.

It works great . No drop outs . OM follows it everywhere.
Additional benefit is frequency / Band memories. So I can go everywhere and the Flex responds. Both in frequency and mode.

Hope this helps .
You should also get an e mail on VSPE hookup . from fellow ham shortly .
Photo of Santos Rodriguez

Santos Rodriguez

  • 27 Posts
  • 1 Reply Like
Thanks Ed.
Cant ́t make it work with Commander (using 10.5.0) as you suggest.
Is good to know it worked for you.
I must be doing something else wrong.

One question:
The OM has two serial connectors in the back (Radio / PC). Which one were you using?

Thanks.
73
Photo of Greg

Greg

  • 656 Posts
  • 63 Reply Likes
Santos,

Try one of the repeater ports in DDUtil set to the native COM1 port where your amp is connected. I use a repeater port to push freq info to my StationMaster for antenna and Quadra control and it works fine. I think the repeater ports are on the OTHER tab.

73 and GL
Greg
AB7R
Photo of Santos Rodriguez

Santos Rodriguez

  • 27 Posts
  • 1 Reply Like
Hi all.
Problem solved, and I feel a bit stupid.
The issue was with my serial cable. For some reason it worked ok with my Kenwood 480/OM amp but not with this new set up. Maybe my "old" cable lacks some pin conections. Really the last thing I could figure out.
So, cable changed: all OK.

Summary:
-Serial cable from OM amp TCVR serial connector to PC serial connector (or USB-to-serial adaptor).

- Option "1": DXLabs Commander "Secondary Cat Serial port" set to Kenwood mode and appropiate COM port number of PC, and baud/stopbits as set in the amp. Perfect. OM amp follows Commander. No problem.

- Opción "2": DDUtil (tryied with v3) "Repeater" (1 or 2) enabled with appropiate Port number and Data speed and in "Normal" mode. OM amp recognizes a "Kenwood" and follows DDUtil. Perfect. OM amp follows DDUtil. No problem.

Sorry for bothering the group. I really was convinced I was missing something with DDUtil. When I tried Commander with no luck (Thanks David and Ed !) I realized something else should be wrong.

:)

Thanks
73
Photo of WBB

WBB

  • 36 Posts
  • 4 Reply Likes

Hello,

I have OM2500 AMP and would like to interface to Felx 6500; I forwarded your solution above to Array Solutions (US provider of OM2500). 

Array Solutions does not know what specific cable to use to interface to Flex.  Can u better define this cable ??


Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1369 Posts
  • 293 Reply Likes

I had helped Santos and Ed with his issue back several months ago. I had one of two 2500A's in the country before Array was the dealer.

Should be a null modem DB-9 female to female cable from the computer serial port to Transceiver connector on OM Power amp. Null modem has pins 2 & 3 crossed. Pin 2 to 3, 3 to 2 and 5 to 5. Only three wires needed.

Set the OM to Kenwood and 19200 baud rate.

Use repeater 2 in DDUtil v3 and set it to normal, 19200, and select the com port on the PC the amp is connected to. Once you have DDUtil talking to SmartSDR it should show the radio frequency in the title bar of DDUtil. Put the amp in auto mode and the amp should follow the radio when you band change.

Feel free to contact me off list at wo2x@arrl.net or reply here so others may benefit.


73

Dave, wo2x


(Edited)
Photo of WBB

WBB

  • 36 Posts
  • 4 Reply Likes

Thank you for replying... just what I was looking for; I will report back when I give it a go.

Regards,

WBB, AK5WB

Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1369 Posts
  • 293 Reply Likes

Let us know how it works!


Dave


Photo of WBB

WBB

  • 36 Posts
  • 4 Reply Likes

Negative so far on hooking up OM, now trying to hook up SteppIR first; so far, not good; see my earlier post today about SteppIR.

Thanks


Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1369 Posts
  • 293 Reply Likes

Hmm. Double check Device Manager for correct com ports.

You might also be suffering from phantom com ports. Uninstall SmartSDR Cat and DDUtil then do the following procedure located here http://theitbros.com/how-to-delete-com-ports-in-use/

One note, when you open the command prompt window, right click the icon and select run as administrator. Then follow the procedure to delete unused com ports. Once deleted, reboot and reinstall SmartSDR Cat and DDUtil.

Feel free to email me directly at wo2x@arrl.net and I can give you my number if you need further assistance.

73

Dave wo2x