Got my Maestro today - mixed blessing

  • 1
  • Problem
  • Updated 4 years ago
  • Acknowledged
What a day.  An 8 month wait and my Maestro finally shows up.  Up to now I've had many happy hours with my Flex-6700 running SSDR v1.5.1. 

I followed the instructions on the plastic protective cover on the Maestro screen, powering it with the AC supply.  I didn't need to turn it on because as soon as I plugged the AC power supply in, the Maestro came on by itself, it found my WiFi and after I entered my network password it  successfully logged on to my network.  The Maestro screen then stated I needed a software update, so I did that.  So far so good!  The Maestro linked to my Flex-6700 and I was tuning around the bands, activating 2nd slice, mode changing, bandwidth changes, etc, all worked fine. 

Next I plugged in the Flex supplied hand held Maestro mic (into Mic1 jack) but noticed the PTT button on the handheld mic didn't work.  Later I tried to turn the Maestro off but noticed the on/off button didn't work either (holding off button 5-10 seconds). 

Thinking the problem might be a result of a conflict with my older SSDR version being on my PC I deinstalled v1.5.1, and then installed the latest version of SSDR, v1.7.30.160.  Restarting my Flex-6700 the SSDR software screen popped up saying I needed to load a software downgrade.  (About now I'm thinking... am I having fun yet?)  There were no other options available so I loaded an older version of the software; v1.7.30.78 loaded.  I started SSDR on my PC next (Maestro is not powered up).  SSDR started but I had no spectrum display or waterfall (audio and tuning worked fine).  Not much in the way of success.

So... I turn everything back off and start over, this time starting the Maestro.  The Maestro started saying I needed a software upgrade... (go figure) so I did that.  The Maestro eventually started and its spectrum and waterfall was working fine, but still no PTT on the hand mic, and the on/off button (holding 5 seconds) still doesn't work.

Not sure where to go from here.  No SSDR working on my PC, and no fully operational Maestro either.  Quite frustrating. 
Photo of KF4HR


  • 935 Posts
  • 307 Reply Likes
  • like turning on my ICOM 7800.

Posted 4 years ago

  • 1
Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1703 Posts
  • 639 Reply Likes
When you change software versions, the Windows shortcuts are not automatically updated. That's a frequent cause of the "upgrade/downgrade" messages. While you don't "need" to uninstall the old version, it might be a good thing to do so to avoid that kind of problem.

Not sure about the PTT issue, though. Sorry! Good luck....
Photo of K0UNX


  • 107 Posts
  • 30 Reply Likes
Go to MENU, TRANSMIT, and in the top pane on the right side make sure "TX Inhibit" is DISABLED. That will keep the transmitter from keying.

I had trouble with the POWER button on top too.  I read SOMEWHERE that you have to press the RIGHT SIDE of that button for five seconds or so.  So I tried that and it worked for me.  I haven't turned my Maestro off for a week though, so my experience level on this is "just one try." 

Littleton, Co.
Photo of Brian Morgan VK7RR/4

Brian Morgan VK7RR/4

  • 93 Posts
  • 28 Reply Likes
Have you tried  engaging  PTT via the Mox function on the Maestro screen or by grounding pin 7 on the Mic-1 plug on the back of the Maestro,  in case you have a defective mic. cord?
Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 199 Reply Likes

The learning pains can be frustrating, but hold on for a few seconds and you'll get it online.  Personally, I don't even use SSDR much any more.  :)

First make sure you have 1.7.30 installed on your PC.  That is the version you want to use.

The Icon has the version number on it.  Unlike other software, you can have multiple versions of SSDR on your computer at any time.  You can have the last 5 versions on your Maestro as well.

It is key that the the Maestro and the Radio have the correct versions of course.  

Try this:

Start SSDR on your PC ... v1.7.30 (look carefully at the Icon).  If the radio requires an upgrade to come online, go ahead and do it.  

Now that SSDR is running normally on V1.7.30, shutdown SSDR and leave the radio on.

Power up the Maestro by holding down the button on the top left for about 20 seconds (or until you see it come alive) (there is no left or right - it is a single button).

When you get to the version menu after you connect to the network, pick 1.7.30.  It will come online.  

That should do it.  

Mike va3mw
Photo of KF4HR


  • 936 Posts
  • 307 Reply Likes
Mike - My desktop icon does indicate v1.7.30.  SSDR recognizes my Flex (indicating Client Software V1.7.30.160), SSDR starts, everything works normally (tuning, audio, etc) except I get no spectrum or waterfall display.

Brian - Last night I was able to get my Maestro's PTT function working by connecting a foot switch to the back of the Maestro.  Perhaps I do have a defective hand mic. 

Hummm... It seems I have a new problem this morning.  Now my Maestro won't even turn on.  I guess I'll be on the phone with Flex today.

Photo of Phill Beistel

Phill Beistel

  • 34 Posts
  • 4 Reply Likes
My Maestro arrived Monday and worked great out of the box, I ordered the coil cord replacement (RJ45) for my FHM-1 had mic. I could NOT key the transmitter with the PTT on the mic plugged in to the MIC-1 socket.  I spoke with Dudley (FRS Tech) and he believes the cord is bad. I just tried replacing the mic coil cord with a standard RJ45 - RJ45 short patch cable and it works just fine. Dudley is right, the cord is bad. If this sounds like your PTT problem you might want to open a ticket with FRS.
I have always found that un-installing old versions of SSDR before installing a new version is the cleanest process.  After embracing that process, I've had no problems with SSDR installs on my PC.
Good Luck,
Phill (WB3DHF)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9480 Posts
  • 3667 Reply Likes
Official Response
I have converted this topic to a support HelpDesk ticket ( for expedited issue resolution.  If anyone else is experiencing an issue similar to this one, please submit a HelpDesk support ticket for issue resolution.