DAC Audio not working / DAX messed up

  • 2
  • Problem
  • Updated 2 months ago

Trying to interface to WSJT-X but not getting DAX audio thru to it.  I have three other systems where my setup works fine, but this one on WIndows 10 is not.  I have tried it with my 6300, 6600 and 6700.  I have my slice setup, I have DAX channel set to 2, on the DAX panel it indicates that it is receiving data on DAX channel 2 and I can see the level indicator moving there as the RX signals go up and down.

At WSJT-X (version 1.9.1) I get no audio when I select the "DAX Audio RX 2 ( FlexRadio Systems DAX Audio)" as its input device.  (note this is what I do with my other three installs that works).  When I go into my windows 10 audio control panel I see the Flex devices on the recording tab, and none of them show any audio level indication.  On my other installs that work I see the level indication when it is getting streamed audio  I also see duplicate of these same items saying "not plugged in" underneath.   The ones saying not plugged in shows a microphone icon or a box icon, the one that shows active has an icon that looks like a red and white RCA audio cable.

I tried a complete SmartSDR removal including VSP, all drivers.  I went thru the devices and removed all of them all flex radio folders and everything else I found on the complete removal description page.

I re-installed.  This reinstall for some reason did not install the VSP drivers which I had to do separately.  My results have been the same after the re-install.

On a lark I selected  "DAX Audio RX 2 ( FlexRadio Systems DAX IQ)" as the input device for WSJT-X and suddenly it was receiving and decoding.  Now isn't that supposed to be the IQ stream not the audio stream?  This was puzzling to me as I had all IQ streams off on the DAX control panel.  And I didn't think DAX IQ data would be interpreted as intelligible audio.

Out of curiosity I went to DAX control panel and tried enabling IQ streams.  When I select IQ 1 it goes from saying "Off" to "No Panadapter".  When I tried it for 2, 3 or 4 it gave a DAX driver Error saying an error occurred while trying to open a DAX sound device and suggests the driver may not be properly installed, that another application has exclusive use of a Reserved DAS sound device, or the DAX sound device may have been manually disabled (I did not disable any).  Once I get the error I can not turn it back off.  I subsequently found that if I turn the radio off I am able to turn off those IQ streams on the DAX control panel.  The radio I was testing with at the time was my 6600.


Photo of Andrea

Andrea

  • 6 Posts
  • 0 Reply Likes

Posted 2 months ago

  • 2
Photo of Al K0VM

Al K0VM, Elmer

  • 582 Posts
  • 94 Reply Likes
Andrea,
  Yes windows10  has scrambled your DAX channels..  Usually by applying Stream names to IQ drivers.
Go the windows device manager and expand the 'Audio inputs and outputs' line..  The DAX channels  should look like this.



See
https://community.flexradio.com/flexradio/topics/dac-audio-not-working-dax-messed-up?utm_source=noti...

AL, K0VM
Photo of Andrea

Andrea

  • 6 Posts
  • 0 Reply Likes
Thanks Al, it didn't quite look like that...it all seemed to be there tho, just order different.  Greg's post below explained that. 
Photo of Greg - N8GD

Greg - N8GD

  • 213 Posts
  • 79 Reply Likes
Also check out this link on repairing DAX messed up channel names from Neal:

https://community.flexradio.com/flexradio/topics/most-common-fix-for-dax-driver-errors-in-windows-sp...
Photo of Andrea

Andrea

  • 6 Posts
  • 0 Reply Likes
Thanks Greg, I think that covered it.