Crashed SmartLink Session

  • 1
  • Problem
  • Updated 6 months ago
  • Acknowledged
I have upgraded to v2 of the SmartSDR software with no issues.  One thing i found is that if the radio software crashes during a remote connection, I can't disconnect the radio to make a new connection nor can i disconnect the crashed session.

I can reboot the computer, and still it won't allow me to disconnect the failed session.  Perhaps i have overlooked something, but the only way to clear this problem is to reboot the radio.

Anyone run into this issue?
Photo of Osiel Rodriguez

Osiel Rodriguez

  • 18 Posts
  • 1 Reply Like

Posted 12 months ago

  • 1
Photo of NX6D Dave

NX6D Dave

  • 290 Posts
  • 79 Reply Likes
When you say the "radio software", do you mean the SmartSDR app you are running at the remote location, or the radio itself?
Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 195 Reply Likes
Osiel ... I think I remember this happen to an Alpha member and the answer was the ports will clear up after some period time.  I just don't remember if it was 30 seconds or 5 minutes.  
Photo of Osiel Rodriguez

Osiel Rodriguez

  • 18 Posts
  • 1 Reply Like
Dave,  This happened to the SmartSDR app, it crashed.  When i went back and restarted SmartSDR, it still showed the radio connected, but no matter how much i pressed the Disconnect button, i couldn't get it to disconnect.  The actual full screen version of SmartSDR never came up after that.

If i remember, i left it about 5 minutes and still it did not disconnect on its own.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9130 Posts
  • 3453 Reply Likes
Are you running the iPad app?
Photo of Osiel Rodriguez

Osiel Rodriguez

  • 18 Posts
  • 1 Reply Like
Tim, while i do have the IOS version, i was not using it during this time, i was using my Windows 10 laptop via a different IP on a hotspot.  The desktop which is were it normally run is also on Windows 10 and also a different IP via hardwire.

As a side note, this issue appears to be random.  I've noticed that if SmartSDR crashed, it would sometimes take like 10 seconds then allow me back in and other times it would take 5 minutes...
Photo of N4TTY

N4TTY

  • 48 Posts
  • 4 Reply Likes
I had the same or almost the same experience.  I was using the Maestro though.  The Maestro screen seemed to freeze.  Couldn't change freq with the VFO knob or with the touch screen.  Powered off the Maestro and then back on.  At first it said no radios were available but then came back with the radio is in use.  I returned home and tried connecting with my desktop computer but still got the no radios available.  It never did change to radio is in use like it did on the Maestro.  Had to power down the radio and power it back up before I could connect.
Photo of Osiel Rodriguez

Osiel Rodriguez

  • 18 Posts
  • 1 Reply Like
Steve, then i should take comfort in knowing i'm not alone in this.
Photo of NX6D Dave

NX6D Dave

  • 290 Posts
  • 79 Reply Likes
Just to be certain, you have shut down SmartSDR at the remote location and restarted it, right?  The radio should time out the broken TCP control connection and should reset itself and wait for a new connection.  I'm not sure if SmartSDR would track that situation well if it was just left running.
(Edited)
Photo of Osiel Rodriguez

Osiel Rodriguez

  • 18 Posts
  • 1 Reply Like
Correct.. so, i have to paths to the internet at my QTH... When this occurs, i shut down the smartSDR on the side which was controlling.
Photo of Norm - W7CK

Norm - W7CK

  • 745 Posts
  • 151 Reply Likes
I believe one of the FCC stipulations of running remote is that the operator have the ability to shut down the transmitter in the event it hangs.   A simple WeMo or similar device is all it takes to shut the power off to the Flex radio, wait a few minutes and turn it back on.  You'll also have to enable the remote on/off on the Flex 6000 and have a jumper on the Remote on/off RCA connector on the back of the rig.  I believe it is port 14 on the 6700.  The jumper is required to be able to turn the rig back on after it's lost 12v power.

Norm - W7CK
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9130 Posts
  • 3454 Reply Likes
I have entered this problem report into our bug tracker as issue #5115 for additional investigation. Thank you for the defect report.
Photo of Phil - WG5D

Phil - WG5D

  • 39 Posts
  • 3 Reply Likes
I just experienced the same issue with a remote session. SmartSDR crashed and when I restart the application the radio indicates that it is connected and the "Disconnect  User" button does not seem to do anything. I am running the remote session on a Windows 10 laptop on a less-than-optimal hotel wireless network. As an added note, I remoted back into a computer that is on the local network with the radio and tried to connect locally and could not disconnect the session from that computer either. 

Update - after I waited for a while - about 20 minutes, SmartSDR now tells me that no radios are available. Interestingly enough, I do get a ping reply from the IP of the radio. I guess I will have to reboot the radio when I return home.  
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9130 Posts
  • 3453 Reply Likes
I have updated the defect detain for issue #5115 with this information.  Thank you.
Photo of Jay Spaulding

Jay Spaulding

  • 65 Posts
  • 3 Reply Likes
I'm having the same problem with the iOS and also on the SmartSDR software on the PC on the same network. Just shuts down. Happen to me a couple times while I was doing a net today. Didnt work out to good. 

Jay