Corrupt COM ports Elecraft Flex conflict? I'm not sure.

  • 1
  • Question
  • Updated 2 years ago
I'm not positive but I believe I have traced this down to a possible incompatibility between the FTDI COM drivers for the Elecraft KPA500/KAT500 and Flex SmartSDR CAT/VSP drivers.

I have a fresh install of Windows 10.  The only other software on this install is MS Office.
I add the FTDI Com drivers for the Elecraft tuner and amp then reboot.  Next I install SmartSDR, add COM5, COM6 and COM7 via SmartSDR CAT and then reboot.

Now if I go into Device Manager select one of the FTDI ports and try to change the COM port to a different number, COM3 through COM18 are labeled as (in use).

Each time I reboot the system, 8 more ports are labeled as (in use). I'm not sure what is going on here. 

Can someone with an Elecraft KAT/KPA along with SmartSDR Beta take a look at their Device Manager for me.  Select a USB Serial Port and try to change the port number to something else. Do you have a bunch show up as (in use) that shouldn't be?

Norm - W7CK
Photo of Norm - W7CK

Norm - W7CK

  • 747 Posts
  • 154 Reply Likes

Posted 2 years ago

  • 1
Photo of Chris Tate  - N6WM

Chris Tate - N6WM, Elmer

  • 819 Posts
  • 219 Reply Likes
I have seen this.  I will bring this up with the alpha group as well, I meant to do so anyway.+  What I have discovered however that the "in use" piece is not actually factual, and if you go by whats in your device manager, of course reveal hidden ports as well, avoid actual in use stuff,  you can choose one of the in use ports for your needs and it should work.
Photo of Rick - W5FCX

Rick - W5FCX

  • 224 Posts
  • 56 Reply Likes
I have also noticed that SmartCAT seems to dominate COM port handling once it has loaded, even ports that aren't assigned to it.  I have to actually kill the CAT process sometimes in order for my other COM port redirection software (VSPE) to load properly.  If I load CAT first, it seems to interfere with other COM port software somehow.

I am using both SmartSDR and Elecraft KAT/KPA at the same time.  I also use VSPE to remotely access the Elecraft KAT/KPA and rotor COM ports.  When I used them all locally, they work fine but only if SmartCAT is not running first.

Since I operate remote, I don't actually use SmartCAT and instead use VSPE for remote redirection, so I only notice this conflict when I've been running locally.
Photo of Norm - W7CK

Norm - W7CK

  • 747 Posts
  • 154 Reply Likes
Have either of you noticed if this is isolated to SmartCAT Beta 1.10.8 or is it also a problem with the older v1.9.13.173?

Is this a conflict between SmartCAT and the Elecraft FTDI COM drivers only?   Has anyone narrowed this behavior down to any exact combination yet?

This has been driving me crazy.  I've asked all over if anyone has been having trouble and got nothing.  I wiped my machine and started over - not a simple task.... 
Photo of Jay / NO5J

Jay / NO5J

  • 1630 Posts
  • 243 Reply Likes
Norm

You definitely weren't the only one. Many are off doing the holiday thing, It may not have happened to them yet. You weren't the first to report it. Stay tuned for further developments. We now return to our regular programming.

  SDRgadgets

#FlexRadio IRC chat

  73, Jay - NO5J

Photo of Jay / NO5J

Jay / NO5J

  • 1630 Posts
  • 243 Reply Likes
Norm 

Could you join me in the #FlexRadio IRC channel to discuss this.
Just click the link in my post signature to get there.
I think I just ran into this issue myself.  
Maybe together, we can come up with a fix or workaround.

  SDRgadgets

#FlexRadio IRC chat

  73, Jay - NO5J

Photo of WX7Y

WX7Y

  • 658 Posts
  • 123 Reply Likes
There is no need to wipe your machine and start over, as Chris said before just because Device manager says the ports are in use doesn't mean it actually is, this may be more of a windows thing but what you may want to do is MAP your hardware COM ports but FIRST do this.
   Disabling the Virtual COM ports by stopping the CAT program then unplug your USB COM ports, then in Device manager in view show "Hidden Devices"  and delete the COM ports that aren't really there or are "grey",  BUT DON'T delete the Drivers.

Now plug in each USB COM device one at a time and if you want to change it NOW is the time to move it to what ever COM port you wish just use a HIGHer numbered COM port (above about 8 and less the 100) to stay out of the way of the Virtual COM ports, write down what COM port is assigned to that device  then do the same with the next USB COM port device and so on until all the USB / Hardware COM ports Devices are added and moved to the desired COM Port and are working. 

You may want to reboot at this point which will also start the FLEX SMARTSDR CAT and by default put the virtual COM ports on the lower COM ports (4 - 7) and above COM104. 

The MAP you made show all your COM ports and could be added to the TEXT window in DDUTIL for quick reference if you use DDUTIL or just a Text file. 

Using the REAL FTDI chipset devices should remember the COM port you put them on.
The FLEX Control is ALSO a USB COM port so make sure you move it up WAY out the the way, I think FLEX recommends in the COM50's area.

Hope this helps 

73's
Bret WX7Y
Photo of Al K0VM

Al K0VM, Elmer

  • 595 Posts
  • 100 Reply Likes
I think a part of the Com port confusion may be related to the how the Flex Knob attempts to find its comport when the PC boots up.  And at the same time SSDR CAT is trying to initilize.  Yes, you can move the comport number for the FLex Knob out of the way to  high number. Which generally works,  Until it doesn't.  I stopped having problems with my comports when I assigend the Flex Knob to a low numbered comport  ( COM 4) and assigned the SSDRCAT ports above that ( COM5, COM6, etc.) 

FWIW.. My Com1 is a HW MB port,  COM2-3 are USB serial ports, COM4 is FLex Knob, COM 5-7 are SSDR CAT ports, Com 8-9 are VSPE ports, COM 10-12 are USB serial ports, and COM 13-17 are more SSDR CAT ports..  This has all been stable through several SSDR and Windows updates.

Caveats-- DDUtil load is defered for about 60 seconds after PC boot, all USB serial ports are FTDI, and moving a USB-serial device to a different USB port may result in its comport number being reassigned.

YMMV

AL, K0VM
Photo of David

David

  • 300 Posts
  • 49 Reply Likes
Here is a screen shot to help understand issue. You need to select any device that is not virtual, properties, Port Settings, Advance, and then the COM Port Number drop down. I believe Norm has Flex working on the issue.

Photo of David Warnberg

David Warnberg

  • 538 Posts
  • 56 Reply Likes
How are you setting the Elecraft Amp and Tuner ports?  I had to assign the ports I wanted in the Elecraft software to get them to stay (KAT500 utility and the KPA utility) then after removing all SDR software and removing ghosted ports, a reboot, then install, everything was happy and working and have not had an issue sense.

Good Luck

David 
(Edited)
Photo of Alex - DH2ID

Alex - DH2ID, Elmer

  • 956 Posts
  • 177 Reply Likes
I've got my COM ports -all virtual - sorted out, but when I try to change COM ort numbers,
they all show up as already occupied. I haven't seen this with the other versions before.
I have had no virtual port conflicts under Win764bitHE - yet, although I run 3 TRX and 2 RX
with my VAIO I7 notebook.

 

I hope Flex will resolve this problem, although I must say that MS is to blame,
as Windows never has had a good port maintenance. With 10 it's still possible
to assign 2 same numbers to a com port. I try to keep them in order manually ....

Good luck and HNY 2017,

Alex - DH2ID
Photo of Ronald / W4RJF

Ronald / W4RJF

  • 33 Posts
  • 2 Reply Likes
I have opened a ticket on this issue several days ago...I was informed that "Engineering is working on finding the root cause of port replication of the  "In Use" flag on ports"...

I decided to revert back to SmartSDR v1.9.13...so far this  has corrected my port replication issue...I hope this helps...

Ronald