Can't enable split. TX set on B, in N1MM+ when I TX, TX moves back to VFO A

  • 1
  • Problem
  • Updated 1 month ago
  • (Edited)
I am using SSDR 2.3.9 and N1MM+ 1.0.7290 on my 6300. I'm using SmartLink.

I have 2 VFOs up on say 17m, and listening on VFO A.
I have TX set on VFO B so I can TX on the split frequencty.
When I am listening to a frequency on A in CW, and I click the F4 (mycall) macro, the TX set on B moves back to A.
I can't click on SPLIT on either A or B. It seems to be disabled. This is concerning and i can't figure out why. It's the same behaviour with and without N1MM+ running.

In N1MM, it's same with all macros, but there is nothign special about, say, F4 or any other CW macro.
F4 macro = F4 {MYCALL},G7~TWC (and yes the ~ is intentional).

Hopefully these screenshots can help someone diagnose the issue. I'm lost.

CAT is fine in N1MM+.

I can use CWX but I'd rather not.







Any help appreciated

Thanks
Mike
G7TWC


Photo of Michael Ruttenberg

Michael Ruttenberg

  • 20 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 months ago

  • 1
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4025 Posts
  • 1248 Reply Likes
You have “auto switch tx” set. This makes it automatically set tx to A whenever you sent with the automated program. If the “auto switch” is not set, then it will transmit wherever the tx is manually set to transmit.

Alternately, you can set up SO2R or SO2V with the proper additional COMports and the rig will take care of additional switching tasks for you.
(Edited)
Photo of W5AP

W5AP

  • 62 Posts
  • 2 Reply Likes
Ken - what does the setup look like for SO2R so that N1MM+ switches the TX from A to B as it should. Mine always jumps back to slice A for TX, even though I have a com port set up for each slice with auto Switch disabled
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4025 Posts
  • 1248 Reply Likes
For SO2R... Have you created a port in CAT for OTRSP? You need to do they, then define it in N1MM in the Config>Hardware com ports tab. You tell it which serial port is for radio 1 and which for radio 2. That lets it know how to switch.

Then, you need to use the shortcut key in N1MM to switch between the two “radios” (cTRL + LT/RT arrow) to shift between the two. OR when running with two pans, you also have two input windows open in N1MM. One is for radio 1 and the other for radio 2. The software will select the correct slice depending upon which input window you are sending from.

The other question. Are you using the split function, or just setting up two independent pans and slices?

That’s all I can say at the moment...I’m at the mall with my family, and break time is over!
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4025 Posts
  • 1248 Reply Likes
What does your Winkeytab in your N1MM+ Config screen look like? If you have PTT set up using CAT or COM4 that may be messing you up, too.
Photo of Michael Ruttenberg

Michael Ruttenberg

  • 20 Posts
  • 0 Reply Likes
Hi Ken

Thanks. Do I turn it off on both CAT entries?
UPDATE: I turned both off and now TX stays on B. Great, many thanks.

SPLIT still doesn't illuminate when clicked. Still a mystery there, though now that I can RX on A and TX on B, split is mostly cosmetic, but it's still odd and I'd t=like that to work as expected (not sure if that does anything different to what I am doing).

For your 2nd question here's a screenshot. Think the PTT is fine. It transmits okay.

 



Thanks
Mike
G7TWC
(Edited)
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4025 Posts
  • 1248 Reply Likes
Yes, The only time you need to use “auto switch” is on com ports on digital programs that are assigned to specific slices, so that the rig automatically transmits on the correct slice when you hit “send” on the digital program.
(Edited)
Photo of W5AP

W5AP

  • 62 Posts
  • 2 Reply Likes
I need help setting up N1MM+ for SO2V.

I have N1MM config set to SO2V  and two com ports set to DTR & RTS=always off
In Smart SDR CAT, I have both those com ports to slice A and the other to slice B with both having Auto Switch OFF.  
The band map window for Slice 2 only displays slice 1 freq. And hitting a function button on slice 2 (or B) only keys slice A.  I also have two PTT ports configured  one for slice A and other slice B with auto switch OFF and SO2V selected. In the DAX panel, I have "blue" on RX streams slice A and B. And the IQ streams for 1 & 2 are also "blue" .   The Slice 1 bandmap follows the Slice a freq, but the  slice 2 bandmap shows only the slice 1 freq.

Help....tnx in advance, Jim
Photo of Michael Ruttenberg

Michael Ruttenberg

  • 20 Posts
  • 0 Reply Likes
Jim, please raise a separate ticket for this unrelated thread else my issue may never get addressed and the 2 tickets get mixed up. Sorry I can’t help you on your specific issue.

Mike
G7TWC
Photo of W5AP

W5AP

  • 62 Posts
  • 2 Reply Likes
will do
Photo of Michael Ruttenberg

Michael Ruttenberg

  • 20 Posts
  • 0 Reply Likes
I found something odd but workable.

If I have only got VFO A up, and click Split then VFO B opens.
If I have VFO A and B open then clicking Split doesn't work at all.

To be honest I don't know what the difference is between having A and B open with the TX set on B, or having A open and clicking Split to open B. It seems a bit of a gimmick unless there is an actual difference in functionality.
(Edited)
Photo of Andy - KU7T

Andy - KU7T

  • 193 Posts
  • 17 Reply Likes
Do a search here for the setup doc for N1MM. You need 2 COM and 1 OTRSP port. Use 2 Entrywindows in N1MM in SO2R mode and switch Tx focus where you need it before transmitting. Use tilde to toggle stereo.

73,
Andy
KU7T