Can't Connect via CAT After Updating 6500 to 1.11.12

  • 1
  • Problem
  • Updated 5 months ago
  • (Edited)
Updated Flex-6500 from 1.9.13 to 1.10.16 and then to 1.11.12 and now cannot connect to rig using HRD or WSJT-X via CAT. CAT console shows COM6 is set to Slice A, port type: Serial, Serial Port: FlexVSP, Client COM: COM6, VFO A Slice: A.

When attempting connect with HRD, the Process field of the CAT console changes from (None) to HamRadioDeluxe for a few seconds and then back to (None). HRD reports it's unable to read the frequency from the rig. Tried all baud rates between 9600 and 115,200, but none seem to work (is there even a way to set the baud rate of com ports in SmartSDR CAT?)

Same with WSJT-X. Both HRD and WSJT-X worked fine before updating the rig to SmartSDR 1.11.12.
Photo of Jerry Gardner

Jerry Gardner

  • 54 Posts
  • 12 Reply Likes

Posted 5 months ago

  • 1
Photo of Jim Gilliam

Jim Gilliam

  • 786 Posts
  • 155 Reply Likes
Does your CAT window say "Radio Connected?" 
Photo of Jerry Gardner

Jerry Gardner

  • 54 Posts
  • 12 Reply Likes
Yes, it does.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 8486 Posts
  • 3170 Reply Likes
I suspect that the FlexVSP driver may have encountered an issue when installing.

Do this
  1. Shut down CAT and SmartSDR (for that matter, close app open programs)
  2. Using Windows Explorer, navigate to where the installer is located
  3. The path is \Program Files\FlexRadio Systems\FlexVSP
  4. In that folder is the file: FlexVSPInstaller_xx.msi
  5. Where "xx" is 32 or 64 depending if your operating systems is a 32 or 64 bit.
  6. Right click on it to get the context menu
  7. Select the Repair option
  8. Answer YES to any prompt and then wait while the repair executes.  It may take a little while.
  9. When prompted to reboot your PC, select YES and reboot.