A couple of new user 6500 questions

  • 1
  • Question
  • Updated 3 years ago
  • Answered
  • (Edited)
As a new user I am enjoying the 6500 but have need of advice. 
1: Am I supposed to see or hear anything when I activated the WBN button?
2: I am attempting to use DDUTIL to link to my SPE 1.3K amp.  I am running Win10, and using a USB cable between CPU and amp.  When I start DDUTIL it displays data from the amp but no band data is sent to the amp.  The amp is showing as com25 and have entered this into the amp settings.
The fact that the amp settings are shown in the DDUTIL display tells me that there is comms.
How do I turn on the band data from the rig to the amp?
Running SmartSDR 1.10.8.

Thanks for any help.
John VK3XM
Photo of John VK3XM

John VK3XM

  • 42 Posts
  • 5 Reply Likes

Posted 3 years ago

  • 1
Photo of Phil m0vse

Phil m0vse

  • 208 Posts
  • 38 Reply Likes
Hi John. What CAT mode have you set the SPE to? For this setup to work (with DDUtil) it must be set to RS/232 (not FlexRadio or Kenwood) I believe. 

73 Phil
Photo of Wayne VK4ACN

Wayne VK4ACN

  • 150 Posts
  • 22 Reply Likes
Did you make a 15 pin - 9 pin cable as in ddutil instructions
Serial port in pc to cat on spe and set spe to kenwood.
Photo of Phil m0vse

Phil m0vse

  • 208 Posts
  • 38 Reply Likes
I think this is where much of the confusion with DDUtil<->SPE amps comes in as there are numerous different instructions around (all different!).

I am using a single cable to the RS-232 port on the SPE (not the 15-way CAT ports) and by using the special RS-232 CAT mode on the SPE, I can get full control of the SPE (power on/off and operate/standby) from within DDUtil as well as band switching.
Photo of John VK3XM

John VK3XM

  • 42 Posts
  • 5 Reply Likes
Thanks for responding Phil,  as you say there are many different possible solutions and one does not know which to try.  The RS232 cable you are using is a nul modem or straight through and does it connect to a RS232 port on the computer or to a FTDI USB cable?

Thanks John
Photo of John VK3XM

John VK3XM

  • 42 Posts
  • 5 Reply Likes
Hi Wayne,  at this time I only have a USB from the SPE to the PC.  DDUtill sees the amps status ie standby or operated but no band data.  i.e.  if the Flex is on 40 and the amp is on 40 and I chenge the Flex to 20 the amp stays on 40.

Thanks John
Photo of Wayne VK4ACN

Wayne VK4ACN

  • 150 Posts
  • 22 Reply Likes
Hi john
The usb only does remote commands. You need a second cable for bandswitching. I was going from serial on pc to cat port on spe for band switching as per these instructions

http://k5fr.com/DDUtilV3wiki/index.ph...

But im now using a usb to rs232. (Gearmo) converter on the flex usb port as per new smart sdr. I think this is a better way but you need the ftdi usb- serial converter.
Its fairly easy to figure
Cherrs
Wayne
Let us know how you go. And when you have it sorted if you use 20 or 40 i would like to try freeedv with a vk with a strong signal one day. Havent found anyone yet
(Edited)
Photo of Wayne VK4ACN

Wayne VK4ACN

  • 150 Posts
  • 22 Reply Likes
I nearly forgot. Dont forget to configure auto drive in ddutil. You dont want flex purring 100w into spe. 4 watts drive gives around 400 watts
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2314 Posts
  • 955 Reply Likes
Hi John,


As mentioned the USB cable is only for the control interface and not for band data. The band data is on CAT A and CAT B ports. SPE has this strange arrangement.


You need a serial cable for CAT A and optionally CAT B (only if you're doing SO2R)..


I've done a comprehensive blog post here about it using the USB cable feature. It doesn't use DDUtil and the amp controls drive power.


http://www.n2rj.com/2016/12/flex-radi...

CAT mode on the amp should be set to "FLEX" as this allows use of the drive power control.

AFTER it's set up you need to set the drive power PER BAND and per power level. You do this by pressing the arrow keys on the amp while it's on the band and power level and in the "operate" mode. Set up a dummy load and set drive power for appropriate power level.
(Edited)
Photo of Wayne VK4ACN

Wayne VK4ACN

  • 150 Posts
  • 22 Reply Likes
Ria. I am using the usb to serial converter for band data to my spe 1.3. It works well except randomly the spe beeps. The message is so fast so i put iphone on record. When it beeped i checked video recording and the spe is saying. 'Band not permitted'. It only is on receive hadnt noticed it when i tx. It is random but regular , fast and only since i am using flex band data. Didnt have it when using ddutil
Are you or anyone else seeing this?
Wayne
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2314 Posts
  • 955 Reply Likes
I've not seen this. What band? It will beep if you're tuned outside of amateur bands. You may want to lower the baud rate if you haven't done so already. I found that 9600 works well. Barring any RFI issues or issue with your USB adapter (genuine FTDI works best) or cable that's the other thing I would suspect.
(Edited)
Photo of Wayne VK4ACN

Wayne VK4ACN

  • 150 Posts
  • 22 Reply Likes
It seems to happen on any amateur band im on .  Been on 14076 a lot lately and it happens there.  If no one else is having the problem, im suspecting the gearmo converter.  Its not rfi cause it is happening on receive.  I will get the flex cable when the oz distributor has them in and see how that goes
Thanks
Photo of David

David

  • 304 Posts
  • 51 Reply Likes
The WNB is challenging one. It depends on the environment you're in. Some people experience a reduction in noise others have no change. It works on correlated noise across the band. You can find several discussions and comments on the Flex Community.
Photo of Tom K3TF

Tom K3TF

  • 71 Posts
  • 4 Reply Likes
I have had good luck with the WNB. With my particular noise on 80 meters I see about an 8 db improvement when I switch it on.

Tom.....
Photo of Lee - N2LEE

Lee - N2LEE

  • 320 Posts
  • 165 Reply Likes
John make your life easy and just let the Flex and the SPE do all the work.

If you create a COM port using Flex CAT and just connect the flex and the spe and set the spe to Flex protocol. It works GREAT !

You do need to set the Expert input power on amp. See page 39 on the Expert 1.3k manual.
Photo of John VK3XM

John VK3XM

  • 42 Posts
  • 5 Reply Likes
I would like to thank all who responded to my questions,  you have given me a lot of information with respect my lack of knowledge of my new radio.
This Flex community is one of the pluses for flex owners
Photo of Wayne VK4ACN

Wayne VK4ACN

  • 150 Posts
  • 22 Reply Likes
So, Im guessing you got the spe working with the flex on bandswitching
Photo of John VK3XM

John VK3XM

  • 42 Posts
  • 5 Reply Likes
I tried to call on the twisted pair a couple of times.  I would like to ask a few questions rather than posting them all here.

Thanks John
Photo of Wayne VK4ACN

Wayne VK4ACN

  • 150 Posts
  • 22 Reply Likes
My twisted pair? Cordless was taken out in last storm. Ill plug an old phone to socket. I mostly use mobile phone these days Tomorrow Sunday ive got a few things on but i think im free in afternoon. . Let me know around what time and if you want mobile or landline number
(Edited)
Photo of John VK3XM

John VK3XM

  • 42 Posts
  • 5 Reply Likes
Thanks Wayne,  sent you an email.