6400M Mode Step Problem

  • 1
  • Problem
  • Updated 6 months ago
1 Hz digit displays number other than zero when tuning with any step chosen (5, 10, etc) varies seemingly random.  6400M still tunes in approximately step chosen but slightly more than chosen value.  At very slow tuning speed, no problem, but when you speed up the tuning, the 1 hz varies all over the place.   Can reboot radio and cures problem for a few hours, then happens again. Reboot only way to restore correct step tuning (only lasts a few hours or less). 
Has anyone else noticed this?  
Photo of Jim K4JAF

Jim K4JAF

  • 333 Posts
  • 83 Reply Likes

Posted 6 months ago

  • 1
Photo of Gayle Lawson

Gayle Lawson

  • 28 Posts
  • 14 Reply Likes
Bring up the "Radio Setup" panel in SSDR.  Click on the "RX" tab.  Enable the "Snap to Tune step" button.  This fixed the same behavior on my 6500.

Gayle K0FLY
Photo of Gayle Lawson

Gayle Lawson

  • 28 Posts
  • 14 Reply Likes
Second reply:

I do not see the behavior with the Flex Control, but I do with the Maestro.  The "Snap to tune step causes the Maestro to behave like the flex Control. The one Hz digits stays at 0.

Gayle  K0FLY
Photo of Elliot Skultin

Elliot Skultin

  • 34 Posts
  • 13 Reply Likes
Same issue.  Snap to Tune button was the fix.  I'm guessing all of the knobs are actually encoders and one challenge is when an encoder is on the edge of a count or noise is induced on the line.  Most encoders have some hysteresis and electronic filtering is used to keep counts from drifting but I surmise from a few of the earlier posts about drift, this may need a bit of software filtering as well.  
Photo of Jim K4JAF

Jim K4JAF

  • 333 Posts
  • 83 Reply Likes
Snap tuning is enabled, always have used that through the years.  This seems almost like a hardware problem with the 6400M.  I can reboot the 6400M --- all is fine for a while, then doesnt tune in the steps you have chosen, such as 5, 10, 50 HZ etc.  Close to the chosen step but not right on the money so to speak.  Perhaps the snap to tune step may be flaky on this radio.  I sure dont know.  Just rebooted the 6400M and all is fine at this time but problem shows up after using the radio for a while...  
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3467 Reply Likes
Jim, please open a HelpDesk ticket on this issue.  If I do not pick up the ticket, tell whoever has your ticket to assign it to me.
Photo of Jim K4JAF

Jim K4JAF

  • 333 Posts
  • 83 Reply Likes
Hello Tim, hope all going ok with the rehab. 
I did open a ticket on the problem, it is 22570.  I reverted back to 2.1.32 about 3 days ago and have not had any of the previous problems with the 6400M as outlined in my posts.  I am puzzled that others have not seen this problem.  Seems strange it has only affected me.  But you may have additional information that I have not read. 
Photo of Jim K4JAF

Jim K4JAF

  • 333 Posts
  • 83 Reply Likes
Another note to my last post....  If I disable the snap tuning, tuning is like I see when my problem occurs.  But snap tuning has always been enabled when the problem has occured.  Next time it happens will disable snap tuning and then enable it again, see what happens when I try that.....
Photo of Wayne

Wayne

  • 614 Posts
  • 84 Reply Likes
Have you checked to see if the 10 Mhz Reference TCXO box has a green check beside the locked word on the Menu/Radio Tab?
(Edited)
Photo of Jim K4JAF

Jim K4JAF

  • 333 Posts
  • 83 Reply Likes
Sure does..  Not sure why that would cause my problem?  
Photo of Wayne

Wayne

  • 614 Posts
  • 84 Reply Likes
Was just thinking .5 ppm at 10 Mhz is 2hz
(Edited)
Photo of Geoff AB6BT

Geoff AB6BT

  • 36 Posts
  • 6 Reply Likes
Actually, I believe this is  correct:
1 ppm of 1 MHz is 1 Hz
1 ppm of 10 MHz is 10 Hz
0.5 ppm of 10 MHz is 5 Hz
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 678 Posts
  • 205 Reply Likes
There is acceleration built into the knob rotation handling code.  It looks to me like the acceleration can end up on non step boundaries.  This is certainly something that we could change.  (#6153)

I would expect that the snap tune setting would fix this, but you are saying that sometimes it happens even when snap tune is enabled, correct?  The next time this happens, can you take some detailed notes of the exact frequency?  I'd like to try to reproduce the issue.
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 678 Posts
  • 205 Reply Likes
Another thought -- keep in mind that the step size varies per mode.  So if you jump to another band which is running a different mode (or just change the mode), this might explain unexpected steps.
Photo of Jim K4JAF

Jim K4JAF

  • 332 Posts
  • 83 Reply Likes
Yes, snap tune is enabled here.  I have gone back to version 2.1.32 and thus far after several days on this version, I have not had any of the previous problem.  I will upgrade again to .33 and see if the problem manifests itself again.  
It was like the step size was say 10 hz, the step size would vary between 10 and 19 hz.  Slow tuning would always result in 10 hz steps but of course the 1 hz digit would remain at whatever it was when you stopped tuning, not zero like it should remain all the time whether your tuning slow or fast.