Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartSDR 3.1.8 loses signal sharpness, then cannot copy FT8



  • Al K0VM
    Al K0VM Retired Member ✭✭✭
    edited April 2020
    Close and restart the SSDR DAX GUI..
    AL, K0VM
  • AB4EJ
    AB4EJ Research Engineer, University of Alabama Member ✭✭
    edited April 2020
    There is a discovery on this:  I installed the SmartSDR software on an old laptop (still, it is running Windows 10 with all latest patches) - and so far I have not seen the problem with the phase jitter getting into DAX. So it seems to be a problem with the big Dell desktop. To the best of my ability, software is the same  on both the desktop and laptop - so the mystery continues. I have tried running the desktop with most of my normal software disabled, but it still has the problem; will check for malware. Could be an incipient hardware failure coming on,..
  • John KB4DU
    John KB4DU Member ✭✭✭
    edited April 2020
    Actually, in my sleep last night, I was wondering if this could be a sound card issue, frequency or something?
  • Larry Benoit
    Larry Benoit Member ✭✭
    edited April 2020

    You may want to try running LatencyMon to determine if a background service, driver or app is causing long deferred procedure calls (DPC), which can corrupt digital audio streams (underruns). 
    Note that anti-virus scanners can cause longer DPC's, so disable your scanner when running LatencyMon diagnostics. 

    Also, check the properties for the DAX channel (Windows Sound panel) and make sure there are no audio enhancements enabled, such as Spatial Sound or some Dell Audio feature. 

    Good luck and 73,
    Larry KB1VFU

  • Bill W2PKY
    Bill W2PKY Member ✭✭
    edited April 2020
    One more experiment to try is using an audio jumper cable take audio from radio headphone jack into mic connector on the laptop. Configure WSJT-X on laptop to receive input from mic input. Run WSJT-X on both computers when you see the issue on the tower computer see if laptop displays the same issue.
  • AB4EJ
    AB4EJ Research Engineer, University of Alabama Member ✭✭
    edited April 2020
    John - there is no "sound card" per se.   In the Flex, everything is done in software, after the A/D converters in the Flex, and I have not seen any issues that suggest a problem with those.
  • AB4EJ
    AB4EJ Research Engineer, University of Alabama Member ✭✭
    edited April 2020
    I spoke too soon – the problem reoccurred on my laptop overnight. However, in looking at the data this morning I had another idea – the sometimes one-sided nature of the frequency plots (generated with both Spectrum Lab and fldigi) made me think of something hitting a limit due to overdriving, flat-topping.  In looking at the gain settings in the active DAX channels – they were both over 50% - so maybe strong signals are maxing out a “circuit” somewhere (in software)…

    So now I have reduced the gain in the DAX settings so that the signals go no higher than 30% to 40%, and will watch it during the day….   (MAYBE THE WHOLE THING IS OPERATOR ERROR - that would be great!!) - will post results...

  • Jay N1AV
    Jay N1AV Member ✭✭

    AB4EJ - did the adjustment of the DAX gain setting fix the issue?

    I am at the point of having to restart DAX multiple times an hour.

  • Larry _ NY8T
    Larry _ NY8T Member ✭✭✭
    edited May 5

    SmartSDR 3.2.34 Fixed this DAX issue for me.

  • AB4EJ
    AB4EJ Research Engineer, University of Alabama Member ✭✭

    I developed a Python application that runs every 15 minutes, which kills and restarts DAX. That was my only solution I found that would reliably get the Flex to run overnight without the loss of signal problem. Actually it looks like something is introducing a large amount of jitter into the clock, thus causing it. I see that NY8T reports that an update to 3.2.34 fixed it; will try that...

  • Larry _ NY8T
    Larry _ NY8T Member ✭✭✭

    I have had this problem happen again running 3.2.34 so I spoke to soon.

  • Mark_WS7M
    Mark_WS7M Member ✭✭✭

    I saw this issue on Win10 on one computer, switched to a different computer and it went away. I reformatted the original computer, did a very clean install of Win10 and it worked well.

    In my long experience as a developer under Windows the old term "DLL ****" applies to more than just DLLs... Things get out of whack at times in Windows and the more software you load the worse things can get. Sadly, sometimes it is your favorite program that causes the muck.

    I switched over to a Mac which is a BIG change. I mean new software everywhere and this particular problem does not exist there. Running SmartSDR Mac using the built in FT8 tool it is possible to carry on FT8 QSOs all day long with no need to restart anything.

    Anyway, I get that switching to Mac is not for all, but for me since I work in Windows as a developer I've learned to keep it simple. Install only the bare minimum.

  • davenelson
    davenelson Member ✭✭
    I'm also having this problem, restarting SmartSDR and WSJT-X brings everything back. It happens to me after about 1.5 hours. Latest version of Windows 10 with a clean install that is only a couple of days old.
  • Larry _ NY8T
    Larry _ NY8T Member ✭✭✭
    edited October 8

    You should be able to close DAX and restart it to clear the problem, I understand it will come back and I experienced the same thing in the past. To me It seems like DAX is not playing well with windows.

    I used to get the dax corruption untill I did a fresh install on the same PC with windows 10 pro (was windows 10 home) and I am not saying it was the differance between home and pro but a fresh install solved it 100%, I never get the DAX corruption any more. I believe the current state/condition/health of your PC operating system is a big factor.

    I am doing something differant this go around after reinstalling windows 10 Pro on my two main dell pc's, the radio pc has only the software on it I use with the flex to operate and my other pc is for everything else, trying new software, learning, basic interneting and so on. For all I know the DAX issue could return but since June its been 100%. This is my personal experience and this may not be true for others.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.