Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

FLDIGI decoding jibberish.

Bob G   W1GLV
Bob G W1GLV Member ✭✭
edited June 2020 in SmartSDR for Windows
I cannot get FLDigi to decode properly. I'm enclosing snapshots of the setup dialog boxes. imageimageimageimage

Comments

  • Lawrence Gray
    Lawrence Gray Member
    edited September 2016
    I use the DIGU mode for PSK and JT? 
  • George KF2T
    George KF2T Member ✭✭✭
    edited February 2019
    Check your DAX levels - should be close to full-scale with signal present. Turn AGC to OFF or FAST and adjust the slider to the noise knee. Perform a timing/sound card alignment per the FLDIGI manual (uses WWV). That's a good start - see what that gets you.
  • Jay Nation
    Jay Nation Member ✭✭
    edited May 2019
    I've recently seen the Fldigi browser pane decoding gibberish frequently, To fix it, I Click on the Clear button in the browser pane, which restarts the Multi-channel detector. I see more gibberish if the squelch is set too low, weaker signals, below some level, probably can't be decoded correctly. Usually the gibberish decodes only appear in the browser pane, and once they begin, they get worse. But clicking Clear always seems to solve the problem. My guess is, it's not a SmartSDR or DAX problem, It's probably an Fldigi multi-channel decode issue. Or an Fldigi input level issue.

     SDRgadgets

    73, Jay - NO5J

  • Bob G   W1GLV
    Bob G W1GLV Member ✭✭
    edited June 2020
    I've read the manual completely to try and figure out how to calibrate the soundcard and it's not cooperating. I tuned to WWV, set the mode to WWv, Dax channel to 1. I don't see anything on the fldigi waterfall. I'm enclosing a snapshot of fldigi.image Any help willbe greatly appreciated. Thanks
  • Michael Coslo
    Michael Coslo Member ✭✭
    edited September 2016
    Calibrating a sound card isn't the issue - that's generally for frequency Drift, not basic decode. I've never done it on SmartSDR, and don't even know if there is a way to alter the correction. 

    As for your gibberish, I'm looking at the signal you are looking at, and reading University of Florida, so it's attempting to decode something. Make certain you aren't altering the signal in any fashion, no processing or anything like that.

    But!

    That PSK signal you are looking at and centered on is strangely distorted, with little spurs off each side. Very odd, and possibly coming from whoever is transmitting. 


    But if you look at the other signals on your waterfall, they are a little weaker, but look proper. A good clean PSK signal should be a steady line on each side, with little lacy lines between the two, as the phase is shifted. 

    Try your setup on a station that has a good looking signal - it could be that. 

  • Jay Nation
    Jay Nation Member ✭✭
    edited September 2016
    Bob

    Are you following the Soundcard Correction directions given here?

    http://www.w1hkj.com/FldigiHelp-3.21/html/digiscope_display_wwv_mode.html

    When correctly configured you should see a vertical line thats perfectly parallel with the colored center line in the digiscope display. I've never seen any visible slant when running this test. I run it at 48000 sample rate, because that's what I have set for all my DAX channels. I noticed the directions suggested "native" and FLdigi's settings dialog also indicate's 44100 (Native) but none of my Sound devices are set for 41000, they are all set to 48000. Try entering 1000 into the RX ppm correction field under Audio Configuration  / Settings to see what the digiscope looks like when the soundcard sampling rate isn't accurate. 1000 should be really obvious. Then set it back to 0. It should then be vertical.  I think WWV turns the ticks off sometimes, It's the 1 sec ticks that are creating the line. might have to retry when it's ticking, if thats the case. My guess is you won't need any adjustment, and can leave RX ppm set to 0.

     SDRgadgets

    73, Jay - NO5J

  • Jay Nation
    Jay Nation Member ✭✭
    edited September 2016
    Mike

    A lot of folks overdrive the Fldigi inputs, which will fuzz out even some of the decent psk signals.
    For Fldigi I usually run the DAX channel set about 75% and AGC off or fast at about AGC-T 24% but I adjust it in a range between 15% - 27% I set FLdigi's Waterfall level controls in an odd but functional way too. I set the Signal level control somewhere between -27 and -40 and set the Signal Range control to match whats set in the Signal Level control and keep them matched. the Level control is always a negative number and the Signal Range Control is always positive. -33/33 usually seems to work but I vary the adjustment up and down to just barely keep the band noise from showing up in the waterfall. I know that sounds totally wrong but it works for me. I prefer seeing Clear detailed PSK signals on a nice clean dark black background, Besides the Waterfall controls and appearance are only cosmetic they have no effect on the decoding.

    I forgot to mention that on 20m 14.070 PSK, I usually leave the Preamp set for 0 gain. unless the bands quiet and it's the middle of the night. All knobs to the right, I'm just not! image

     SDRgadgets

    73, Jay - NO5J

  • Lawrence Gray
    Lawrence Gray Member
    edited September 2016
    In order to operate digital modes with the Flex, I believe that you need to have the Flex in DIGU (digital upper sideband) mode.  This disables the Flex signal processing.  DSP or equalization settings will distort the PSK or JT signals and interfere with decoding.

    There is a good video tutorial on YouTube--https://www.youtube.com/watch?v=GSRIefEWjcc


  • Kevin
    Kevin Member
    edited July 2019
    First thought - USB keeps the equalizer active. If your Rx equalizer is on the could distort the received signal. DIGU disables the equalizer and also provides the advantage of centering filters around 1500 Hz.

    I just migrated to a new computer and was having the same problem. Good looking signals that just would not fully decode. I really had to crank up the DAX Rx stream much more than I did on my old computer and things started falling into place.

    Calibrating the sound card probably won't help and probably is not necessary. I've never had to do it ever since moving to the Flex.

    73,
    Kevin K4VD
  • Andrew O'Brien
    Andrew O'Brien Member ✭✭
    edited April 2019
    Signal distortion caused by an over driven signal will not cause substantial gibberish when decoding.  Back in the early days of soundcard digital modes I tried to create the nastiest transmitted tones possible.  Most of the dire predictions were proven to be exaggerated.   Also, USB versus LSB is NOT really an issue with most digital modes (QPSK being a notable exception) .  RTTY in LSB/USB also requires a few adjustments. .  DSP on digital modes does not impair the signals as much as people think.  ARQ modes suffer, but modes like PSK will still decode unless extreme DSP. 

    I have seen some gibberish experienced in applications like Fldigi that has been related to VAC, I'm not sure if DAX can get similarly  'scrambled" but a reboot usually solved the VAC issues. 
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited June 2020
    In older versions of Fldigi, when this type of issue occurred, deleting the configuration file (ini) and setting up the app from scratch resolved the issues.
  • Bob G   W1GLV
    Bob G W1GLV Member ✭✭
    edited December 2016
    could not find the ini file. Looked in parent, user and appdata directories.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    The location is in the Fldigi doc. I am away from my PC so I can't confirm the location right now.
  • Jay Nation
    Jay Nation Member ✭✭
    edited September 2016
    Bob
     
    In Fldigi, menubar / File / Folders. Select Fldigi config. and the folder that holds the Configuration files will open. In that folder, fldigi.prefs, might be the file your interested in. fldigi.prefs, fldigi_def.xml, frequencies2.txt, lang.txt, stacktrace.txt, and status_log.txt, will all be created with default values included if they don't already exist, the next time Fldigi is opened. Removing them will cause you to have to re-configure everything, so instead of deleting them move them all to a another folder, as a backup of your current configuration. Or do none of that, if your at all concerned, about what the consequences might be.  All of those files are text files so you can inspect them.

     SDRgadgets

    73, Jay - NO5J

  • Kevin
    Kevin Member
    edited July 2019
    How did this finally turn out Bob? I'm running into issues where fldigi won't decode until I restart the application. Not sure if your issue was similar but if so, hoping you found a solution.

    Looking at the waterfall on SSDR it looks good but fldigi looks fuzzy. After restarting fldigi the waterfall clears up nicely and decoding goes OK. But after time it seems to go back to fuzzy.

    Two screenshot. First shows the waterfalls with fldigi fuzzy and decoding poor. Second shows fldigi after restarting it with fldigi clean and decoding fine. Both are from the same side of a QSO though the other side of the QSO (and any other QSO I found) performs the same way.

    image

    image
  • Jay Nation
    Jay Nation Member ✭✭
    edited July 2019
    Kevin

    Have you tried, restarting DAX only before restarting FLdigi? In the past, there have been reports of the audio being sent over a DAX channel becoming corrupted. There is something glitching somewhere in your audio chain. Most of which is software, and digital. Really just a memory buffer running on your PC. So it's likely down to the Rig, DAX, SmartSDR, Fldigi, your PC, or your PC's OS. Divide and Conquer, By breaking the audio chain at every point along the chain, by restarting whatever element you're testing. It might be DAX flaking out, it might be portaudio in Fldigi, since it recovers after restarting Fldigi. it seems to point to Fldigi and portaudio. But, it might still be in DAX and what it's sending to Fldigi. To complicate the troubleshooting further, sometimes resetting/restarting a buffer clears the corruption for a while, before it returns. something is causing some of the 0s and 1s in the audio data stream to flip bits. Figure out which hunk of code is at fault.

    I'm sure you're used to doing this sort of thing. It's just standard troubleshooting technique.

    One last thought, be sure all of the sample rates Fldigi and DAX channel are set to 48000, so that nothing is converting the sample rates.

    I have seen both DAX and Fldigi SEMI-crash in the past. IOW they quit working, but they don't die.

    In my former telco career this was sometimes referred to as reseating the card, or re-terminating the jumper. Which worked so often that, it usually got tried first, before any serious fixing began.

    It's almost always that thing you did right before the trouble cleared, that really helped the most. So try doing that first.image

    Sorry if I added to the noise floor with this post!image

     SDRgadgets

    73, Jay - NO5J

  • Kevin
    Kevin Member
    edited December 2016
    Yep. Tried quitting DAX and restarting but the signal remained distorted looking on the waterfall and decode failed. Then I restarted fldigi. I assumed SSDR would not be directly involved but a radio reboot would have been next with a computer reboot as a final try.

    I've been copying PSK-31 much of the afternoon without issue. If it happens again I'll retry restarting DAX and other things before fldigi just to see if there's something else involved.

    Kev
  • MattD
    MattD Member
    edited September 2021
    [{"insert":"I know this is an old post, but glad I found it: After a few hours of operating RTTY, I had the same problem as the OP, decode just went to gibberish. Saw the suggestion above to only restart DAX, so I shut it down and ran it again, and decode is great again! Not sure how/why, but the fix is easy now (much better than restarting everything). At least that worked for me, ymmv. 73!\n\n"}]

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.