Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

TG-XL not powering on correctly

K4QXX
K4QXX Member ✭✭

I received my TG-XL a couple of weeks ago. It works great and I am very happy with it. But it does something strange on boot up. If I turn on my power supply and then turn on the TG-XL, the fans come on full speed and the front display doesn't come on. If I have the power switch on the TG-XL tunned on but the power supply off, I can turn on the power supply and the TG-XL will power on correctly. I read on one of the Google groups that someone was having a similar issue. Has anyone else experienced this? I just leave the TG-XL power switch turned on and then just power on and off my power supply to toggle the TG-XL power but this behavior is not right.


Burch

K4QXX

Comments

  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    Butch, open a Help Desk ticket with Flex.


    73

    Dave wo2x

  • dan flynn
    dan flynn Member ✭✭

    I have a similar problem with the fan coming on high. I turn the unit on and it sounds like the thing is going to do a short runway take off. So far, the only way I have figured out how to get TG-XL fan to turn off is to do a hard reset. So far life is good for a few days before it happens again.

    Dan ww3n

  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    Dan, please open a Help Desk ticket also. We need to track this issue as not everyone is experiencing the problem.

    73

    Dave wo2x

  • dan flynn
    dan flynn Member ✭✭

    David,

    Will put in a help desk ticket. I have not been documenting my settings.

    All the best. Dan ww3n

  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator
    edited August 2

    Ok, thanks Dan. Since several people have seen the fast fans it is best to open the ticket so support can track the issue and look into it. Posting on here is pretty much peer to peer support. So, always best to open a ticket for new issues. Doesn’t hurt to post here also but in order for support to be involved. The ticket process is fastest route.


    73

    Dave wo2x

  • KF4HR
    KF4HR Member ✭✭

    Burch - Exact same situation here. When using the rear mounted power switch, my TG-XL turns on normally but when leaving the TG-XL power switch on and switching power from a remote source, the fans on my TG-XL fans go to full and also my TG-XL display doesn't turn on.

    I found that I can make and break the TG-XL's remote power source and my TG-XL turns on normally if I use a 12vdc surge protector (switching power to the TG-XL using the output connection of the surge protector): https://www.amazon.com/gp/product/B08BRN3R5Y/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1

    Butch KF4HR

  • KD0RC
    KD0RC Broomfield, COMember, Super Elmer Moderator

    Hi Butch, is this an indication that your power supply is not providing at least 12 VDC? The "Car Voltage Stabilizer" you reference from Amazon sounds like it is a boost/buck converter to get low or high voltage (10 - 36 VDC) to 12V.

    If you can measure your input voltage (without the voltage converter), it would be interesting to see what it is while the tuner is running normally vs. what it is when the tuner is starting up. You will probably need an oscilloscope to see any under/over shoot of the supply (or a voltage sag, if that is the problem).

  • K4QXX
    K4QXX Member ✭✭

    Butch, my issue is a little different. If I use the rear mounted switch with my power supply on, that's when the screen stays black and the fans go crazy. If I leave the rear power switch on the "on" position and then turn on the power supply, the tuner boots up as normal. I tried to do a reset but when I power on with the bypass/operate button pushed, it does the same thing (fans on and no display) so I can't seem to get the tuner to reset.

    I will also put in a ticket.

  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator

    If it boots correctly when turning on supply, try shutting off supply, hold operate/standby button on front panel while turning on power supply. Continue to hold button until display say Config Reset.


    Dave wo2x

  • K4QXX
    K4QXX Member ✭✭

    Dave

    I will try what you suggested (turning on power supply while holding the operate/standby button). I have also submitted a helpdesk ticket.

    Burch

    K4QXX

  • WX7Y
    WX7Y Member ✭✭✭
    edited August 3


  • K4QXX
    K4QXX Member ✭✭

    I would encourage anyone who is having this problem to contact the Flex helpdesk. I spoke with them about my issue today.


    Burch

    K4QXX

  • KF4HR
    KF4HR Member ✭✭

    Ref: ... is this an indication that your power supply is not providing at least 12 VDC? The "Car Voltage Stabilizer" you reference from Amazon sounds like it is a boost/buck converter to get low or high voltage (10 - 36 VDC) to 12V.

    Len - I'm using an Astron VS-50M power supply adjusted to 14.0 vdc. The device I mentioned was not inserted for further voltage regulation but rather because of its surge suppression circuity. And as I mentioned, making and breaking the 14vdc connection to my TG-XL at the "output" of this device yielded excellent results. My TG-XL remotely turned on and off perfectly.

    Inserting this device was just an experiment. As Burch recommended, if you are having problems concerning remotely powering your TG-XL, contact Flex Help Desk.

    Butch

    KF4HR

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.