Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartLink quit

Smartlink was working last night. Local connections aren't an issue. 6400M running v3.1.12. Nothing has changed in my network. Fixed IP manual port forwarding. uPnp is shut off. All IP addresses look fine. I have unregistered and re-registered several times. Nothing in the firewall is blocking it. Anti-virus isn't blocking it either.

The only thing I saw change was SmartSDR for iOS updated. The iPad works fine as long as I am connecting locally, but smartlink is toast.

What am I missing?

73,

Ed KA9EES

The voice of Fithian IL

Comments

  • John KB4DU
    John KB4DU Member ✭✭✭

    What version of SmartSDR are you using? On IOS after14, some apps require being given to the network.

  • ka9ees
    ka9ees Member ✭✭

    @John KB4DU

    v3.1.12 it's been working fine under iOS14.1 till now. I don't understand what you mean by "being given to the network". iOS didn't update. SSDR for iOS updated. Hmm... Maybe I should ask Markus about it. The thing is when I try the test button on the front of the rig, I get a red light. I don't think it's an SSDR for iOS problem.

    Ed

  • John KB4DU
    John KB4DU Member ✭✭✭

    Auto corrupt caught me again. Should be given access to the network. I’m on IOS 14.0.1 and app version 3.9.8

    which is working.

  • ka9ees
    ka9ees Member ✭✭

    The app works fine. SmartLink doesn’t

  • Can you check remote access from a pc running SmartSDR for Windows? That will determine if it is an IOS or radio issue.

    Try rebooting the radio and check if SmartLink is set up correctly. When in SmartLink setup expand the Network setting and click the test button. If it does no go green then you have an issue with port forwarding.

    Dave wo2x

  • ka9ees
    ka9ees Member ✭✭

    @David Decoons, wo2x

    I'll go do that now. I can't find any settings wrong.

    Ed

  • ka9ees
    ka9ees Member ✭✭

    @David Decoons, wo2x

    I setup my Windows 10 laptop using my cellphone as an hotspot. No joy via smartlink. Then via the local wireless network. Works just fine.

    Ed KA9EES

  • ka9ees
    ka9ees Member ✭✭

    All is right with the world now. Mika VA3MW Ken NM9P helped me solve the problem.

    Ed KA9EES

  • Mike and Ken are great!

    (as well as the whole Flex team)

  • Gary W9GD
    Gary W9GD Member ✭✭

    All,

    Just a observation. I have the same problem today connecting from work .. This morning was working remotely before clocking in, worked just fine. Then logged off till lunch time. Noon came tried to log in with windows 10, latest version SDR software and 6600M. So i took to the community to find a answer and here it is but the answer truly is not published to see the solution. the answer posted is "Mike VA3MW Ken NM9P helped me solve the problem"

    Checked my home router remotely and radio via teamviewer all is good . No remoter connectivity via Smartlink. Tried IPhone, Ipad and windows 10 machine.

    So folks now what.... HI Hi

  • ka9ees
    ka9ees Member ✭✭

    @Gary W9GD

    I ended up having to enable UPnP. As I had been using a fixed IP. It just stopped working. I hadn’t made any changes. Honestly I don’t know what happened.

    73,

    Ed KA9EES

  • Gary W9GD
    Gary W9GD Member ✭✭

    Ed,

    Thanks for the reply.

    I am really baffled for sure on my end. In the last 24 hours i got it working but did find the IP of the radio changed some how and i don't understand that. Its above my pay grade. I have a a ATT router and live in the boonies so i have not a lot of choices. It wont even let me use it as a bridge. Another ham who is very much a guru when when it comes to this stuff was baffelled as well. We changed the port forwarding to the new radio Ip and still didnt pass the green light test. But here is the kicker, I believe we chased our tails for 2 hours figuring it wasnt working because we could not get the green light, this morning i tried from work and all is good but no green pass test light still red. So i hope somebody from FR can answer that one. Been on 3 different bands this morning from work and my 2 meter transverterand it working. I dont like these mysteries but right now i am happy. One could waste hours trying to get the green light when in fact you set everything up right.

    73 W9GD

  • Gary,

    Do a Google search on the model of your AT&T router and how to do a DHCP reservation and add a reservation for the radio. What that does is the router will see the MAC address of the radio and always assign the same IP address to the radio.

    This is better than using a static IP address. If you use a static IP and you ever move the radio to a different network which has a different subnet , you will not be able to see the radio on the network. Also if you ever want to connect the PC direct to the radio it also would not work.

    I have DHCP reservations for my radio, amp, 4O3A antenna switch, PC, and Node Red Raspberry Pi. That way I know the equipment always gets assigned the same IP.

    73 Dave wo2x

  • Gary W9GD
    Gary W9GD Member ✭✭

    Dave,

    Thats a great tip i will look into that. Thank you very much. It is appreciated.

    73 W9GD

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.