Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Flex's on Wrong Network IP - DHCP not working

KM0T
KM0T Member ✭✭
edited October 2020 in Networking

Hi all,

 Been struggling here trying to get my Flex Radios back on the network. I have done considerable research, read the manuals, done what I can do to sluth things. I just think windows has messed with me and I’m not sure the right way to get back. Bear with me, the info is extensive, and I think I know what needs to be done - but wanted to throw it all out there….

Three Flex 6600s. All on a typical normal private network, with gateway Asus router of 192.168.0.1, set to be the DHCP server. Each flex - SmartSDR typical runs on its own computer….

All running version 3.1.12 the latest…

Computer #1 (typically runs Flex#1) was updated to Win 10 pro – version 2004 a few weeks ago, fresh install, SmartSDR was installed and configured for transverters, HF and WSJTX, all working fine. (device dedicated to HF, 222 and 432 MHz)

Computer #2 (typically runs Flex#2) is Windows 10 pro - version 1909. SmartSDR was installed long ago and has worked flawlessly for quite some time. (device dedicated for 6M and 2M)

Computer #3 (typically runs Flex#3) is Windows 10 pro - version 1909. SmartSDR was installed long ago and has worked flawlessly for quite some time. Device dedicated for (902 Mhz thru 24 Ghz - 7 band transverter driver)

All had been fine since the last Flex 3.1.12 update, which was quite some time ago now, and was fine before that as well…

So a few weeks ago I started to lose my network shares, kind of random, etc. frustrating. So I worked on Computer #1 to resolve and I just could not seem to get it to work for two shares… so after exhausting everything I could find out to fix, I reinstalled - a fresh install Windows 10 – Version 2004 and all seemed fine. SmartSDR was working too…

Then I started to lose network drives again… and other computers on my lan could not find the internet and I was losing streaming to a TV out in the workshop.

Checking out there in the workshop, I finally got to the bottom of the stream issue, it was a bad network jack on an end of a cable. I cut that off and re-terminated and all was well, the whole network seemed to come back and all computers and drives seemed to work.

Took a few weeks off, and recently booted the computers and flex radios, and could not find any radios in the chooser for Computers #1 and #2.

I rebooted the Flexs, disconnected power, etc. Checked the LAN connections (green only light on the back of the radios, strange I thought as I thought I read that yellow showed “connected”) but the network switches showed activity. I’m thinking I lost the network card in the radios? So I booted up computer #3.

The first thing I noticed computer #3 was not connected to the internet. Strange I thought. Rebooted, etc. no change, it was exhibiting the similar symptoms when I was tracking down the bad network cable…

However, I started SmartSDR and wow, all three Flex-6600s showed up in the chooser, I’m thinking Whaat??

I remember reading that if the flex was connected directly to a computer without a gateway or DHCP source, it would connect to the computer on a default internal IP address, I could not find the post, but sure enough, the computer was found to be on 169.254.78.153 (255.255.0.0 subnet) So that made sense that it was not on the internet through my 192.168.0.2 thru 254 network.

Checking the IP addresses of the three Flex6600 by hovering the mouse over them revealed that they too were on a 169.254.x.y IP address. Getting into the radios, they were all set to DHCP as they were before. The subnet for all was 255.255.0.0.  Im not sure why but the “x” in the IP addresses were different, but were all showing up in the chooser. (Perhaps all is needed is 169.254 ?)

So, I though I guess that makes sense, all on their own same little internal network and so the chooser on that particular computer was the only one that could see the radios.

So, with that I decided to change one of the radios IP addresses so I could see it on the real network, basically thinking to get them all changed over, then fix computer #3 IP addressing problem.

So, I changed one of the radios to static IP, 192.168.0.101 and the proper subnet 255.255.255.0 (which best I could tell that IP address was free on my network.)

The radio rebooted and I checked the other computers on the proper lan IP and the chooser still did not show the flex…

So I shut everything down, radios and computers, disconnected power and waited, etc, and brought it all back online.

Nothing, the Flex radio with the changed IP address would not show up in the chooser of the other computers. It would not even show up in my router map which shows all the clients.

Strange I thought, so I went back to computer #3 and started the chooser, all three Flexes still showed up there! Even the one with the changed IP address of 192.168.0.101. I even hovered the mouse over it and it reported the IP address I had set.

However, when I tried to connect to it, it would say the radio could not be found. But dang it, it wont show up in the other computers with the proper lan address.

I checked those other computers also, windows defender and firewall, SmartSDR is allowed TCP and UDP, I don’t run any third party stuff. I have run Trace Route, no double NAT here..

So, I think I know what to do, power button hold down to white flashing to reset, but what the heck, is there something else I can try before I do that and have to reload my transverter settings, etc.?

This one has me baffled, again I think its windows……

Any help appreciated.

 

73 – Mike – KM0T

Best Answer

Answers

  • Alan
    Alan Member ✭✭✭

    Mike

    You did not mention anything about checking your router for clues to what is going on. Most routers have a list of connected clients" and DHCP IP numbers assigned to each. Perhaps looking at this list for your Flex Servers will provide a clue as to he problem. I would put my money on your problem being a router issue.

    Instead of using static IP addresses for each Flex Server, I have seen it recommended that you return them back to DHCP and then within the router, assign each Flex Server a "Reserved" IP address, typically just reserving the current DHCP address assigned by the router.

    Alan WA9WUD

  • KM0T
    KM0T Member ✭✭

    Alan, I hear you. I checked my router client list many times, rebooted, etc. I looked for obvious "flex names" but saw nothing and also then checked for matching MAC addresses, they were not in the routers client list.

    I then concluded since the Flex radios were on a different IP range, they would not show up in the client list. In fact, when I changed the one Flex 6600 to the correct IP range, it still did not show up in the routers client list, so that has me baffled.

    I did read that they recommended to change back to DHCP, that was the plan once I got them back in the right network range, but I haven't been able to get that far. Thanks for the reminder.

    One thing I thought of was to "reset" the router to factory condition, that I believe will start the DHCP process over again, but even if I did that, the Flex Radios on the 169.254.x.y IP range seem to be stuck there even though they are on DHCP....

    Hmmmm, I guess that's a clue maybe? Since the 6600s are on wrong IP range, they may never get a "ping" for DHCP from a 192.168.0.1 gateway? The router does not even see them to give them an address? However, that doesn't explain the first time it was ever powered on, where my router found it and gave it an address.

    I had everything turned on here overnight, but forgot to check before I left for work. I will check it on it when I get home midday, maybe it will sort itself all out... I doubt it though.

    Need more help :) Thanks Much!

  • John Orjias
    John Orjias Member ✭✭

    dhcp does not rely on an ip address, the dchp client on your computer and your radio sends out a broadcast request to any listening dhcp server. the fact that your desktop computer ended up on the same network as the 3 radios means it also failed to get a response from the dhcp server.

    start with this, disconnect everything from your network but just 1 computer. make sure its getting its ip from the dhcp service correctly every time. then add 1 radio, slowly bring things back onto the network 1 at a time see if anything causes it to fail. also if you have access to another router i would just try that first.

  • KM0T
    KM0T Member ✭✭

    John, thats a great explanation on how a DHCP service works from the client prespective, sending out broadcasts asking for an address. So if the router does not respond, bingo goto the default address of 169.254.x.y.

    I'm thinking of doing a complete reset of the router I have... see what that does, otherwise I will try another router, I have a spare.

    I will report back here. Thanks!

  • KM0T
    KM0T Member ✭✭

    Ok,

    Took a while but here is how it ended up. Took all connections off the router, factory reset the router and added only one computer to the switch - DHCP, got the network set for 192.168.0.1 for the router. The one flex radio set with a static IP showed up right where I had set it, the other two flex radios showed up via DHCP.

    I slowly added computers, and devices, not really any hiccups until I tried to add my NVR for security cams and NAS boxes. They would not come into the network under DHCP. The NAS boxes eventually showed up as 169.254.x.y. So I grabbed a laptop and set the network for that, and got to the box and changed the IP to 192.168.0.xx. Well it still would not show up after reboots, etc.

    Frustrated that it was not making any sense, I changed out the router completly, and brought everything online, all DHCP stuff changed to the right network, everything set to static with the proper IP range showed up, etc. Everything was good....

    Crazy, but it seems it was a router problem that apparently was not giving out DHCP stuff correctly, or something to that effect.

    Thanks for the info pointing me this way, as I was not believing it would have been hardware based on most of the stuff working, thinking windows networking quirks with their updates was messing things up.

    Question to all and Flex staff. I know its recommended that the 6600s be left on DHCP, but what is the downside other than if you sell it and dont tell them the IP address? One should reset the radio anyways which puts it in factory state before sale...getting it to DHCP state. On my particular router, if I set a device IP within the device's interface, it shows up static in the router network map, so its really not an issue for the router. I do my NAS boxes that way as they replicate to one another via IP, so I cant have them changing ever, that has always worked well.

    Thanks again, 73 de Mike - KM0T

  • John Orjias
    John Orjias Member ✭✭

    I thought about doing static on the radio, but decided to just assign It to a fixed ip using the dhcp in the router.

    The reason I did that was because I tend to forget how I configured things over time. if some day I wanted to pull my radio and take it to field day or something, I would probably find myself wasting 30 minutes trying to remember why it will not connect to my computer when I put the network cable directly into it from the radio. beings now i'm no longer on a network, having static set on the radio would break that.

    For me it just one less thing I have to remember if I take my radio somewhere

  • WX7Y
    WX7Y Member ✭✭✭

    So glad you got it figured out!

    Just remember that if your 6600, 6400 are M versions the M Head AND the radio both require a IP or 2 IP per M6600 or M6400 radios.

    The best thing to do is leave it on DHCP and set the router up so that the MAC address of both the Head and radio are both assigned a proper address from the DHCP router.


    Kind of makes me wonder about the OLD router, Could you have a limit set for the total number of available DHCP IP addresses but that total addresses has already been handed out so the last device connected had no resources left. A few home routers I have seen default to limit the total DHCP IP addresses that are available to hand out.

    73's

    Bret

    WX7Y

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.