Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartLink Not Working with SmartSDR for iOS

Carl N8VZ
Carl N8VZ Member ✭✭
edited June 2020 in SmartSDR for iOS
I’m on the road with my iPad.  SSDR for iOS sees my rig at home but for some reason will not let me connect.  It says “Listening to SmartLink” and shows my rig, but when I click on the rig, it just goes back to the screen that says tap here to connect.  Anyone have any idea what might be going wrong?  Thanks for any help or suggestions that you can give.  73 de Carl N8VZ

Comments

  • Carl N8VZ
    Carl N8VZ Member ✭✭
    edited June 2020
    Just tried with my iPhone.  Same thing happens.

  • Doug
    Doug Member ✭✭
    edited June 2020
    I would email Markus the author of the software for IOS I have had good support from him in a timely manor
    Doug K9CRT
  • Carl N8VZ
    Carl N8VZ Member ✭✭
    edited June 2020
    Thanks, Doug.  I will do that.  73 de Carl N8VZ
  • Carl N8VZ
    Carl N8VZ Member ✭✭
    edited June 2020
    Preliminary diagnosis after consultation with Marcus:  I should not have set my SmartLink up at home using UPnP but instead have used regular port forwarding.  I will do that when I get home tomorrow and see if that solves the issue.  73 de Carl N8VZ
  • Carl N8VZ
    Carl N8VZ Member ✭✭
    edited June 2020
    Final report: Got home.  Unregistered SmartLink.  Registered again, this time manually using Port Forwarding in my router rather than UPnP, which is the default.  Went to a friend's house.  Logged into his WiFi.  Was then able to connect FB to my Flex in my QTH a few miles away. So, the key is to not register automatically for SmartLink but use the manual method and to enter the proper port and IP address information in your router.  That information is conveniently supplied by the SSDR software when you click Manual Registration.  I hope that this information is helpful to someone else in the future. 

    P.S. I think that with some routers the automatic registration would not cause the problem that I experienced, but to be safe it's a good idea to do the Manual Registration mode in any event.  Turning off UPnP also helps the security of your LAN.
  • NA0B
    NA0B Member ✭✭
    edited June 2020
    I would turn off UPnP in your router. 

  • Ted  VE3TRQ
    Ted VE3TRQ Member ✭✭✭
    edited June 2020
    Yes, indeed. Turn off UPnP - there is a serious security flaw in many implementations. If you have a recent miniupnp, you are good to go - it does not suffer from the flaw.

    [Edit to add the following]
    I run a Tomato-based router, and it is fine - I expect some of the other better routers (the IQRouter comes to mind) will also be OK.
  • Ian C
    Ian C Member ✭✭
    :) Thanks for adding this it helped me out, been trying to sort this for a while, thanks for taking the time

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.