Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SSDR PGXL high SWR issue during RX

Sergey KN7K
Sergey KN7K Member ✭✭
edited June 2020 in FLEX-6000 Signature Series
Second day in the row I paid attention I have high SWR in SSDR PGXL window during receiving and it is going low during TX.
Yesterday I power cycle radio and PC, today I see the same issue again, sounds like a bug.

https://drive.google.com/file/d/1B3i4eVqm4DjSDyd7E3B_3-_LZ0kV3BpZ/view?usp=sharing

Sergey, KN7K

Comments

  • Dan-N7HQ
    Dan-N7HQ FlexRadio Employee, Community Manager admin
    edited May 2020
    Sergey, what version of the PGXL firmware are you running? 

    73,
    Dan
  • Sergey KN7K
    Sergey KN7K Member ✭✭
    edited May 2020
    Hi Dan,

    PGXL ver 3.4.10
    SSDR ver 3.1.12

    Sergey, KN7K
  • NX6D Dave
    NX6D Dave Member ✭✭
    edited May 2020
    I can't reproduce this problem, and I can't see anything in the code that would likely produce such a problem.  Would you please try running just the SSDR and Amp alone without any of the other programs?  I'm thinking that having multiple clients open on the radio may be scrambling something in the radio.  That's all I've got.

  • Sergey KN7K
    Sergey KN7K Member ✭✭
    edited May 2020
    Hi Dave,
    I closed Stacks 3 and Slice Master and it did not help until I restarted SSDR. I did not do power cycle today.
    I will keep eye on it, 
    Thanks, Sergey
  • NX6D Dave
    NX6D Dave Member ✭✭
    edited May 2020
    OK, we may be onto something.  Let's be very clear and careful.  Are you saying that when you restarted SmartSDR for Windows, leaving the PGXL untouched, the problem cleared?

    If so, then please do the following:  The next time you see this, shut down SSDR and restart it.  Leave everything else unchanged.  Please let us know what happens.

  • Sergey KN7K
    Sergey KN7K Member ✭✭
    edited May 2020
    "Are you saying that when you restarted SmartSDR for Windows, leaving the PGXL untouched, the problem cleared?"

    Yes
  • Bill -VA3WTB
    Bill -VA3WTB Member ✭✭✭
    edited May 2020
    Serg, I wonder if you may have a corrupted data base. that could be cleared easy and start a new data base.
  • Sergey KN7K
    Sergey KN7K Member ✭✭
    edited May 2020
    Dave,
    Just found it happen again right after finishing FT8 QSO on 17m.
    This time it seems associated with PGXL status:
    - PGXL in Standby SWR does not show anything in RX mode
    - PGXL in Operate mode, SWR going to a full scale even i am still listening.

    Restart SSDR - same behavior.
    Restart PGXL Utility - same  behavior.
    I did not power cycle anything today, but will do overnight shutdown as I want to work in WPX tomorrow and need a clean start.
    Video demonstration
    https://drive.google.com/file/d/18oj3rpeahllu0Ub4YfDVxTYefMzgbx5p/view?usp=sharing

    Sergey, KN7K
  • KA9CFD
    KA9CFD Member ✭✭
    edited May 2020
    What happens if you close the PGXL utility and toggle the amp from stand by to operate using the button on the amp?

    I have not seen this on mine. Very strange. Looks like a help ticket to Flex is going to be needed. 

    GL Jay KA9CFD
  • Sergey KN7K
    Sergey KN7K Member ✭✭
    edited May 2020
    Jay, I did not try it, my Amp located behind the desk in additional enclosure to minimize the noise, so it is not easy to get to.
    Sergey, KN7K
  • Sergey KN7K
    Sergey KN7K Member ✭✭
    edited May 2020
    All cleared this morning after PC and 6600/Maestro power cycle.
    I turn on other programs one by one and checked PGXL in Standby/Operate mode.
    Cannot reproduce it now.
    So, it is happened to me 2nd time this week, may be it was there before and I did not pay attention.
    Not sure what trigger these events, but will keep an eye to see if I can pinpoint it to any activities.
    Sergey, KN7K
  • NX6D Dave
    NX6D Dave Member ✭✭
    edited May 2020
    Going from standby to operate doesn't have any effect on the logic that sends Return Loss data to the radio.

    I've checked the data flowing to the radio for range/sign errors.  I can't find any.  In addition, whatever is causing this problem is rare, otherwise it would have been spotted and fixed long ago.
  • NX6D Dave
    NX6D Dave Member ✭✭
    edited May 2020
    SmartSDR is a radio client.  The radio program is in the radio box and runs all of the time the radio is powered on.  It would be useful to try to isolate this problem to the radio program itself, or to the program when it is serving radio clients (SmartSDR, PGXL, others).

    When the problem occurs, let's try restarting one element of the system to see if the problem tracks that element.  As I see it, the elements are PGXL (the hardware, not the Utility), the radio itself (the box, not SmartSDR or Maestro), SmartSDR and Maestro. A lot to test, but it's a pretty good bet that the problem will go away when one of these elements is cycled.

    To keep the number of variables down, I would leave everything else running while cycling one component.  Let the various software entities get errors and recover.


  • Sergey KN7K
    Sergey KN7K Member ✭✭
    edited June 2020
    Another glitch, but different this time - Flex6600 shows Hi SWR when drive PGXL.
    Initially I did not catch whats happening and fixed it with bands switch back and force, but later saw that 6600 somehow shows Hi SWR, that's probably why I could not get full power on PGXL.
    Found this issue after station was in idle for about 5 hours.
    Fixed by restarting SSDR.
    Weird... Loosing a lot of time for  troubleshooting during contest.
    https://drive.google.com/file/d/115FTbR7zOEnuk4-KqJ4fyY1UWJ-EmsAL/view?usp=sharing

    Sergey, KN7K

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.