Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartSDR CAT losing connection with WSJT-X instance

2

Comments

  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited April 2020
    Not sure what it is doing but it could be a good clue to hopefully lead to updated DAX drivers which are more resilient to Windoze updates.

    Dan is a very smart guy. Hopefully he nailed it with what is causing your issues. I'll add this to my list of things to have people try.

    Dave wo2x

  • Dan-N7HQDan-N7HQ FlexRadio Employee, Community Manager admin
    edited April 2020
    Thanks, Dave. 

    Pat, when the timers expire for things like sleep or the screensaver, Windows sends an event/message to each running application and service that describes what is about to occur. This gives the application the information it needs to react to what is about to happen, and in some cases respond to the event with a request to abort the action. 

    Or, the app can tell Windows that it can't start the screensaver via an API call.  This, for example, is why the Windows screen saver never starts when you are watching a movie, unless it is paused.

    The behavior does seem to be something new as I've only recently encountered the problem. I'm also not precisely sure why this disconnect is occurring, but I doubt it is the CAT/DAX drivers. The more likely case is Microsoft fixed something they thought was broken and WSJT-X or SSDR were blissfully ignorant of it and the Microsoft fix broke something in them.

    I've made a note to talk this over with the engineers. 

    73,
    Dan

  • PatrickPatrick WH6HI KauaiMember ✭✭✭
    edited April 2020
    Dan, thanks for the explanation of the inter reactions of Windows and the apps under screen saver.  I am going to list my observed events as related to the screen saver situation.

    1)  CAT stops communicating with third part apps.
    2)  DAX stops communicating with SmartSDR on transmit.  PTT works, SmartSDR switches to transmit, no audio stream to transmitter. 
    3)  Flex 6500 Becomes frozen and requires a forced shutdown and restart. 

    That is a roundup of what happens when screensaver activates.  Please not that the CAT and DAX appear normal when screens come up.  But when operation is attempted, the problem will result in malfunction.  If the Flex freezes there will be error messages and SmartSDR will be not running.  

    So a temporary solution for me is just don’t use the screen saver in Windows.  

    Dan thanks for your input on this problem, hope there is a solution.  Now I can go on a little happier with everything now running pretty smooth.  Hopefully I am not speaking to soon.  

    Pat





  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited April 2020
    Pat, Do you know what video cars your PC is using? Wondering if some of these weird problems can be tied to a specific manufacturer? I had the background Slide Show causing screen pausing with an Nvidia GTX 1080 card with latest Nvidia driver. Dave wo2x
  • PatrickPatrick WH6HI KauaiMember ✭✭✭
    edited April 2020
    I use the  GeForce GTX 1650 4GB.  This card is part of a new computer that I put on line in January.  Computer is a Digital Storm with i9 9900 processor 8 cores 16 logical processors.  It is overkill but future proofs my system.  I use Windows 10, and consider this piece of **** software the worst OS ever done by Microsoft.  It is nothing but a new front end for a core that has never been improved.  Rant, Rant, Rant........



  • PatrickPatrick WH6HI KauaiMember ✭✭✭
    edited April 2020
    Moving on to 48 hrs of operation,  continues with no problems.  Log4OM hiccuped but that was unrelated to screensaver problem.
  • RogerRoger Member
    edited April 2020
    Hi Al,

    It's all setup correctly and I've even checked to make sure nothing has changed when the failure occurs.  Yesterday it failed and I only exited SmartSDR, DAX and CAT and restarted.  With the restart everything worked just fine.  Once the restart of SmartSDR and it's associated components completed and I answered "retry" to the WSJT-X instances everything began working without me having to restart the four WSJT-X instances.

    I have read the complete thread and will try disabling my screen saver as Dan suggested although I've seen this happen when I was actively interacting with SmartSDR, GridTracker and WSJT-X working QSOs.

    I have noted that CAT-PTT continue to work and DAX doesn't seem to have any issues at least at the same time.  I have noted however other times that DAX seems to lose its connections with WSJT-X.  This has been less concerning since it doesn't leave me transmitting on the incorrect frequency.

    73,

    Roger, NK1I
  • John KB4DUJohn KB4DU Member ✭✭
    edited April 2020
    Why I'm still on Win 7!
  • PatrickPatrick WH6HI KauaiMember ✭✭✭
    edited April 2020
    I coulda, I shoulda, I be screwda......... No going back at this point.   Some apps I use not supporting 7 any more.... so, here I am.

  • PatrickPatrick WH6HI KauaiMember ✭✭✭
    edited April 2020
    Now at 72 hours of operation, no problem for normal operation.  Log4OM acted up again. And my updated TQsL don’t function for uploads now.  2 steps forward 1 step back....
  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited April 2020
    If you use the Stream Deck with the Flex you cannot run the Stream Deck on Windows 7.

    Dave wo2x

  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited April 2020
    Are you running TQSL 2.5.2? It was just released two days ago. They changed a couple of things to allow better uploads from non-compliant logbooks.

    If you are running 2.5.2 you can back up your location and certificates (File/Backup Station Locations, Certificates and Preferences) then uninstall 2.5.2

    Download TQSL 2.5.1, restore settings and test again.

    Dave wo2x

  • PatrickPatrick WH6HI KauaiMember ✭✭✭
    edited April 2020
    2.5.2 installed I have e-mailed the LoTW team, about the issue, I may do a version regression if this continues.  I work a lot of stations who need confirmation for, of all things, LoTW awards.  So don’t know who has the error in the software, LoTW or Log4OM.  I just hope they cooperate with each other and fix it up.
  • PatrickPatrick WH6HI KauaiMember ✭✭✭
    edited April 2020
    Friday update:  
    Still not running screen saver, all apps, SmartSDR (+CAT/DAX) and the 6500 running properly after 96+ hrs.  So screen saver operation is definitely a problem.  Eliminating this issue has cleared the way to see some underlying software issues with Log4OM v2.  I loose CAT communications.  I don’t know if this is do to the associated tool OmniRig or its interface drivers of Log4OM.  I need it to happen so that I can look at the CAT log for the programmed com port.  I did have some Registry errors, which I cleared.  Depending on what happens with the Log4OM problem, this is my last update.  Will update if some thing changes in relation to the Screen Saver problem. I may open a separate Log4OM post depending on what I find. If not a CAT problem I will report to Log4OM groups.  
  • Dan-N7HQDan-N7HQ FlexRadio Employee, Community Manager admin
    edited April 2020
    Thanks for the update, Pat.  Glad you are weeding out your system! :) 
  • PatrickPatrick WH6HI KauaiMember ✭✭✭
    edited April 2020
    Hi Dan, thanks for your help.  In January I switched my previous computer from an i5 2 core to a new computer with 8 cores 16 logical i9 9900.  All this happened because I upgraded my old computer to Windows 10.  Caused old computer to run at 75% to 100% with all ran slow and had decoding problems.  So lots of things had to move to the new computer.  So this caused lots of trouble shooting of apps and in some cases purchasing of new licenses.  On top of this are the normal OS updates, software updates, driver updates as well as outright new versions of older apps.  Pile all that together and I have been constantly trouble shooting SW for last 3 months.  I feel I am close to the end, most of the operational SW is running stable now, except for two service apps for logging.  That is only delaying some people trying to get Hawaii for various WAS and DXCC awards.  So again thanks and stay healthy.... Pat
  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited April 2020
    Pat,

    I have been usinh Hamlib with the 6700 and Log4OM. No disconnects but there is a defect in Log4 OM when you click on a cluster spot it tunes the radio to the frequency but sets the rx filter to the narrowest for that mode. Very annoying.

    reported the bug to developers of Log4OM but Danielle is in northern Italy in an area heavily hit by COVID-19 so development of Log4OM has slowed down.

    Not sure why you are having issues with OmniRig. You should be using version 1.19 as other versions are not stable.

    Dave wo2x
  • PatrickPatrick WH6HI KauaiMember ✭✭✭
    edited April 2020
    Hi Dave,  tried the version 2 of OmniRig and it was definitely a no go situation.  I am running v1.19 and for the most part and it seems to be working well.  Now that I have the screen saver issue out of the way.  I can concentrate on some of the minor issues.  My feeling is that the Log4OM/OmniRig com port issue is more related to Windows operations then the apps them selves.  The connectivity problem encounter was most likely due to old config info in the Registry.  I have a nice program that looks for old and out of date registry info and notes it for correction.  I did that and Log4OM and OmniRig seem to be much happier.  So far so good. I had other issues months ago related to com ports that went away after fixing the registry and I should say resetting and clearing unused ports in SmartCAT.  So very so often now I check the registry and fix if needed.  Now, the only time I need to check the registry is when I see or do an event like install or reinstall an app or play around with new com ports.  That’s it in a nut shell.  

    Hopefully the folks at Log4OM are safe, they took a **** of a hit and still are in Europe.  

    Stay safe Dave,  so far we have been very lucky here on Kauai....

    Pat
  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited April 2020
    I talked to Tom K4XV in Kauai via phone yesterday. He was saying you had 13 confirmed cases and anybody visiting is being asked to self quarantine for 14 days. At least they are helping to keep the spread on the island under control.

    Here in NJ there are a lot of people still not doing social distancing. They are now fining people $1000 each per offense.

    73
    Dave wo2x
  • PatrickPatrick WH6HI KauaiMember ✭✭✭
    edited April 2020
    Hi Dave,  yes, Kauai is holding the barricades.  Today I was listening to the police bands and they had an officer noting who was arriving. Then noting if they were going to the car rentals.  There another officer noted the car and registration and number of people then that info is sent to a check point we’re they pull the vehicle over and issue a notification and a check of destination.  We had to nuts show up without any accommodations, they arrested them then sent them back to there point of origin.  Our Mayor is now guaranteed re-election.  
  • PatrickPatrick WH6HI KauaiMember ✭✭✭
    edited April 2020
    They got back to me and requested the Log4OM .adi files.  It’s in their hands now.
  • Dan-N7HQDan-N7HQ FlexRadio Employee, Community Manager admin
    edited April 2020
    Happy to help, Pat.  My I9 is exposed to tons of different software so I can identify with the need for compu-weeding - it can be no fun.  Take care!
  • PatrickPatrick WH6HI KauaiMember ✭✭✭
    edited April 2020
    You take care to...Mahalo and Aloha for now!
  • Dan-N7HQDan-N7HQ FlexRadio Employee, Community Manager admin
    edited April 2020
    Noʻu ka hauʻoli
  • PatrickPatrick WH6HI KauaiMember ✭✭✭
    edited April 2020
    Nothing from the LoTW team.   So a I did a version regression with config update from backups.  Now it works....!
  • PatrickPatrick WH6HI KauaiMember ✭✭✭
    edited April 2020
    Do you know of a good **** killer? HI!!
  • Michael BlackMichael Black Member
    edited June 2020
    Seems the timeout values in hamlib are a bit too small 
    Take the following file and place it in the AppDataLocalWSJT-X* folders for your different slices.  Each different config of WSJT-X will need this file.  It increases the # of timeouts and one other delay value.  The # of timeouts that was in there was borderline and explains the infrequent timeouts being experienced.

    https://www.dropbox.com/s/jfvxs9qkf3nhzxk/hamlib_settings.json?dl=0

    This change will be in the next version of WSJT-X beyond 2.1.2

    de Mike W9MDB

  • Bill W2PKYBill W2PKY Member ✭✭
    edited April 2020
    Your AppDatalocal directory should look like this:image
  • Michael BlackMichael Black Member
    edited April 2020
    That would be the WSJT-X directory under AppDataLocal
    So  all the AppDataLocalWSJT-X* directories

    de Mike W9MDB

  • PatrickPatrick WH6HI KauaiMember ✭✭✭
    edited April 2020
    So what are the suggested settings to correct timeout issue?

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.