Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Stuck on "Please Wait..." Radio won't boot and three red flashes on power button

Rick  WN2CRick WN2C Member
On my 6400M running 2.3.9, went to open the entire slice on 40 meters and then went to go back to the normal screen setting. It wouldn't go back and I had no control on the touch screen. Shut it down and rebooted and got three red flashes. Tried several times and got the same thing. Shut down again and removed power. Rebooted and was able to get to the software down load screen. Downloaded 2.61 bu it locked up after step 1 of 4. Not sure what the three flashes mean.
Any suggestions? Radio has been on for months no problems till now.
Running radio stand alone.

Open for Comments · Last Updated


  • Harold RoseeHarold Rosee Member ✭✭
    edited November 2019
    • One red flash: Fan malfunction
    • Two red flashes: Software crash
    • Three red flashes: Boot failure
    • Four red flashes: Input power over voltage
    • Five red flashes: CPU overcurrent
    • Six red flashes: Input power under voltage

    Have you tried a reset by holding the power button down while it turns on.  Release when it turns white.  Hopefully that should get you up and running.

  • Rick  WN2CRick WN2C Member
    edited November 2019
    Yes did a reset - No Go
  • Rick  WN2CRick WN2C Member
    edited November 2019
    It is getting stuck @ 'choose radio', hit ok but there is no radio to choose. Just goes to please wait...
  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited November 2019
    You may need to start a help desk. That sounds like an SD card failure.

  • Rick  WN2CRick WN2C Member
    edited November 2019
    That is what I was thinking too Bill. I opened a help desk ticket. Just a shame it happened on a weekend. I got to wait til Monday at least before I hear from Flex.
    I guess I got to go to a superhet back up radio :(
  • Rick  WN2CRick WN2C Member
    edited November 2019
    Thank you Tim for getting up and running. It was 6 days ago and I really shouldn't count the week end but the SD card did the trick. Installing it was easy peasy and I am now up and running. If any one has had their Flex go down and had to go back to an analog dial radio like me for a week then you will know what I am talking about. I had to use a pair of Kenwood 599D twins for the past 4 days.
  • DougDoug Member ✭✭
    edited March 25
    Just curious Rick could you explain what is involved in the fix for this condition.
  • Rick  WN2CRick WN2C Member
    edited November 2019
    Replacing a micro SD card in the radio. Connecting power and internet so it can call home to load up software.
  • GeraldGerald Member
    edited November 2019
    SD card fixed it? Can one have a backup SD card ? I assume the radio hardware is fine .
  • VP9NIVP9NI Member
    edited March 25
    Just a blank SD card?  Any specific format?  I have the same issue on my 6400 (non M) and I live in Bermuda.  So sending back the radio isn't an inexpensive option for me.
  • K3SFK3SF Member ✭✭
    edited March 27
    first you will need to initiate a help desk ticket


    then the staff will work with you to get the proper SD card ...
    i believe the SD card has the boot s/w


    they will send instructions on how to change out the cards

    Paul K3SF

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.