Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

how do i turn off dexp

Doug
Doug Member ✭✭
edited June 2020 in New Ideas
SmartSDR 3 - My DEFX is stuck on and greyed out (blue button, grey type), in all profiles. What is preventing me from being able to control it? Microphone is USB and is selected but the DEFX keeps turning down the gain to the point that i have no power out. (everything was working fine until I was forced to window 10.sux) Anyone have a suggestion/? I 've been through every menu I can find and have searched the manual to no avail.
Tagged:

Open for Comments · Last Updated

Answers

  • WX7Y
    WX7Y Member ✭✭✭
    edited June 2020
    I hope you mean DEXP and PC Microphone Never seen a USB Mic setting in SmartSDR. 
    If this is the case DEXP is disabled when the PC MIC is selected which is a real pain because back when I ran the radio locally I really like running it to get rid of back ground Shack noise.

    you have 2 options
    Not sure method 1 will work to disable your DEXP but maybe give it a try. 
    method 1: change the MIC to Balanced, or MIC  and see if it will let you get rid of DEXP issue and then switch back to PC and see if that fixed it.  
    method 2: AFTER EXPORTING your Profiles! then do a hard reset then see if DEXP works normal if all is OK then Import your Exported files EXCEPT have "Preferences" unchecked this may bring things back as close as possible with hopefully the weird DEXP problem fixed.

    hope this helps 
    73
    Bret
    WX7Y

  • Doug
    Doug Member ✭✭
    edited December 2019
    Thanks Bret,
    It is indeed the PC mic on the USB and after about 3 hours of playing, including a export, factory reset, test and import I came to the conclusion you state. It is disabled on the PC mic.

    BUT... the problem of the mic gain being turned down remains.

    Here's what I have discovered....and have yet to figure out why, how or a fix.

    When SmartSDR is started it modifies the PC mic setting to whatever the mic gain control is set for at startup time. The mic gain control after that ....slides, but changes nothing. If I set the gain control to 100%, shut down SmartSRD and restart, I have mic audio and full RF output. If I turn the gain down it changes nothing.
    If I set then set the gain at some other value, say 50%, shut down SmartSDR and restart it, the mic gain on the PC get set to 50% (actually 49%...and 100% gain in SmartSDR results in 99% on the PC). And, again, changing the mic gain after SDR is running has no effect on the mic audio.

    So, now my question is.... why does the mic gain control not work?
    (I have a work around but it is a....pain)
  • WX7Y
    WX7Y Member ✭✭✭
    edited June 2020
    That is VERY strange, I have used many different USB and bluetooth Microphones for over 4 years of running remote in 1 form or another, a lot of Headsets are very directional and if your not talking direct and close to them it bounces all over the place.
    REMEMBER that you are using a WINDOWS sound device and the problem may be the Windows sound drivers.

    Some things to try
    open up your your windows sound settings and check ALL your Mic settings and make sure the Audio is not dropping if they are then check the "enhanced" settings and if enabled disabled them and visa versa, some sound drivers give you the option to listen to your self and a sound bar showing the Mic audio levels test this for quite a while and compare your results.

    Try a different computer, try a different  Mic ect.
    I don't think this is going to be a SmartSDR issue but a Windows issue.

    hope this helps

    Bret
    WX7Y

  • Doug
    Doug Member ✭✭
    edited December 2019
    Bret, I'm almost positive it is a windows issue since the problem did not exist on windows 7 but started when i I was forced to "upgrade'" to windows 10 (it sux!) 
    I'm just looking for a solution and hoping that maybe someone has had this happen and save me a lot of time tracing it.
    Thanks
    73
    Doug
  • Doug
    Doug Member ✭✭
    edited December 2019
    I LOATH WINDOWS!!!!

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.