Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

How do I Configure RTTY with N1MM+ ver 1.0.7841.0 July 2019 ??

Neal Pollack, N6YFMNeal Pollack, N6YFM Member ✭✭
edited June 23 in SmartSDR for Windows
I had RTTY and N1MM+ / MMTTY working in the past using Tim's document here:
https://helpdesk.flexradio.com/hc/en-us/articles/204188169-Configuring-N1MM-to-use-MMTTY-with-a-FLEX...

Recently, after six months, I started N1MM+ and it updated to the July 2019 version 1.0.7841.0.

I can't seem to get it to work now (MMTTY).   If I start N1MM+ and open the digital window, or if I start directly MMTTY, I get an error dialog pop-up that says specifically:

Cannot open 'COM9' at '45' baud; if the selected serial port
can't handle this baud rate, use EXTFSK.   OK

I looked into Windows Device Manager to make sure that COM is there.
I then looked at SmartSDR CAT to make sure my COM9 was still there;
It says;
Slice_A FlexVSP PTT
Serial: COM9
Slice: A
Auto Switch TX
Process:  N1MMlogger
RTS
Polarity: Active Low

I tried searching the forums, but most of the RTTY setup articles are three year old
dead links, since the FLEX website changed.
OK, Ignore that approach;
----------

Is there anyone on this forum that is currently using (July 2019) the latest version of N1MM+ with a RTTY setup with MMTTY, that would be willing to share their MMTTY config/setting for the Port?   A RTTY contest is coming up this Saturday, and it would be fun to get this working, if someone can share their setup or indicate where Tim's article, linked at the top, needs to change for 2019?

Sincere Thanks in advance,

Neal   N6YFM

Answers

  • Army CurtisArmy Curtis Member ✭✭
    edited July 2019
    Neal, I just tried my setup and it works fine, even after the obligatory weekly update for N1MM ;o)) My CAT is configured a little different from yours though. Rather than the PTT port being set for FlexVSP, try setting it for Existing. You will need to open a RTTY type of contest in N1MM ( I used the NAQP RTTY contest coming up this weekend ) and have your radio up and running (first, then open N1MM second). The linking to MMTTY works as it should, the radio keys and sends RTTY when I hit any of the predefined F keys.
    Give that a try and see if works for you.
    73, Army AE5P
  • Ken - NM9PKen - NM9P Member ✭✭
    edited June 23
    Also, are you using RTTY mode on your flex instead of DigU? RTTY is the preferred mode setting now...
  • Ken - NM9PKen - NM9P Member ✭✭
    edited June 23
    It sounds like your setup in N1MM or MMTTY is trying to use direct FSK rather than AFSK. Be sure that you are set up as AFSK.


    I would also recommend using CAT commands on the radio control port for PTT rather than using a separate dedicated PTT serial port. It makes for one less port to mess with.
  • edited August 2019
    I am getting that message when I close out of MMTTY setup. I can't find anything wrong so I just ignore it. 

    Everything is working.

    -Robby
    HP3SS
  • Ken - NM9PKen - NM9P Member ✭✭
    edited June 23
    In order to use CAT commands In MMTTY, make sure that your serial port (a normal cat port, not a PTT port) is set in SETUP>TX>RADIO COMMAND. And not in the SETUP>TX>PTT & FSK slot. Leave the PTT & FSK slot blank.
  • Pat KØPCPat KØPC Member ✭✭
    edited July 2019
    I can't get PTT to work with CAT commands. I try using the radio port (COM12) that N1MM already has open but I get a message saying "Can't open COM12 for radio commands". In the MMTTY TX tab I have PTT & FSK port as NONE, under Radio Command I use COM12 @ 38400 8N1 with Kenwood/Elecraft model and group.
    Can somebody post their settings for CAT PTT?
    Thanks,
    Pat KØPC
  • Chris Tate  - N6WMChris Tate - N6WM Member ✭✭
    edited July 2019
    I just upgraded latest N1MM while setting up for NAQP RTTY.. no problems.  I think your issue is somewhere else in your setup...  remember there is a rtty setup doc on the flex website
    https://www.flexradio.com/downloads/flex-6000-rtty-configuration-n1mm/



    check the PTT via radio command for digital modes box and ensure SSDR CAT is setup correctly

  • Ken - NM9PKen - NM9P Member ✭✭
    edited June 23
    Pat, check to see if your COM12 is already in use by another program, or if it is incorrectly configured as a PTT port in the CAT Control Panel. If N1MM is using COM12 for rig control, you need to use an additional port for MMTTY rig control.
  • Pat KØPCPat KØPC Member ✭✭
    edited June 23
    Thanks Ken, I thought MMTTY may be able to work through N1MM with the same port but it seems not. 
  • Ken - NM9PKen - NM9P Member ✭✭
    edited July 2019
    One port does all The N1MM band, frequency, and rig control and data functions. The other port takes rtty data and PTT from mmtty to and from the rig.
  • Neal Pollack, N6YFMNeal Pollack, N6YFM Member ✭✭
    edited July 2019
    Any example config screenshots for the m1mm+ and MMTTY and SmartCAT settings panel would be super educational for this newbie and others.
  • Neal Pollack, N6YFMNeal Pollack, N6YFM Member ✭✭
    edited July 2019
    Nice screens but; Any example config screenshots for the m1mm+ and MMTTY and SmartCAT settings panel would be super educational for this newbie and others.
  • Neal Pollack, N6YFMNeal Pollack, N6YFM Member ✭✭
    edited July 2019
    What size and resolution display monitors are those?
  • Tom    N5MOA Tom N5MOA Member ✭✭
    edited September 2019
    See if this helps any




  • Neal Pollack, N6YFMNeal Pollack, N6YFM Member ✭✭
    edited July 2019
    Dear Tom N5MOA:

    Thanks for sharing config.   Can I ask, if I see it correctly, that you use COM4 for all functions;  Band, frequency, rig control, PTT via radio CAT command sent via COM port?

    I also see in your N1MM+ Hardware Settings Panel, that you have a COM5 defined.  Was this for another software program, or part of MMTTY?

    Is it possible to see the MMTTY setting TAB that deals with the COM port selection?
    I do understand that MMTTY will use the DAX RX and DAX TX as soundcard channels for the
    AFSK data in and out.

    Thanks to your screen shots above, I think I am getting close, maybe 90% of the way there.

    Cheers,

    Neal
  • Tom    N5MOA Tom N5MOA Member ✭✭
    edited July 2019
    Neal,

    "Can I ask, if I see it correctly, that you use COM4 for all functions;  Band, frequency, rig control, PTT via radio CAT command sent via COM port?"

    Other than setting your DAX audio in N1MM's  CONFIG>CONFIG PORTS, etc>AUDIO tab, yes.

    COM5 is for my WinKeyer.

    "Is it possible to see the MMTTY setting TAB that deals with the COM port selection?
    I do understand that MMTTY will use the DAX RX and DAX TX as soundcard channels for the
    AFSK data in and out."

    The COM port is "none". You tell N1MM where to look for MMTTY in the 3rd pic above.

    MMTTY works via N1MM which works via COM4.





    I'm a computer idiot, so this is probably all the help I can offer. :-)

    Off to work, hope you get it going.

    73, Tom
    N5MOA


  • Pat KØPCPat KØPC Member ✭✭
    edited July 2019
    Tom,
    Your screenshots were very helpful. I now have it running with N1MM without the need for a separate COM ports just for PTT.
    73, Pat KØPC
  • Tom    N5MOA Tom N5MOA Member ✭✭
    edited July 2019
    Thanks, Pat, glad you got it going.

    73, Tom N5MOA

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.