Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Why does SSDR show radio available?

Rich McCabeRich McCabe Member ✭✭
I assume this has something to do with multi-client but makes no sense to me.  On the same PC it does not seem like should have radio available?  If course I cant start it. This started with V 3.image

Answers

  • bahillenbahillen Member ✭✭
    edited June 2019
    I believe it is for selecting a different Flex radio if you have a second radio.
  • Rich McCabeRich McCabe Member ✭✭
    edited June 2019
    Still should not show that radio as available because its not.
  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited June 2019

    SSDR sees all radios as clients now, thats all. If you only have one radio it is also found.
    I beleive it is simply keeping all the software consistant. On version 2.5.1 when I start FRstacks that panel comes up and asked me, I simply sellected my only radio client and all done.
  • Rich McCabeRich McCabe Member ✭✭
    edited June 2019
    Radio is not available. Should not say available to SSDR  It could be available to another client, but not SSDR.

  • Jay NationJay Nation Member
    edited June 2019
    To auto-connect to a single radio, when you only have the one radio to connect to, you can add the serial number of that radio as a command argument in the shortcut you start SmartSDR with. Yeah I know this won't change things for the M models. It only works with SmartSDR.

    The command argument is …

     --serial=####-####-####-####

    Your own serial number will be displayed on the SmartSDR / Radio Setup / Radio tab.

    The full Target command should look similar to …

    "C:Program FilesFlexRadio SystemsSmartSDR v2.4.9SmartSDR.exe" --serial=####-####-####-####

    It will let you skip thru the SmartSDR Radio Chooser popup window.

    #FlexRadio IRC Chat

       73, Jay - NO5J

  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited June 2019
    SSDR treats all radios as a client now, each radio is a client. The radio found is available untill you sellect it. It will not say in use, because it has not been sellected yet.
  • Rich McCabeRich McCabe Member ✭✭
    edited June 2019
    It certainly has been selected.  And if I try to select it, I get this.


  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited June 2019
    Must be two instances running together. Can you disconnect one?
  • Rich McCabeRich McCabe Member ✭✭
    edited June 2019
    Bill there is an instance running.  Back to my original point. It should not say "available".

    If you start SSDR on your PC and open the above panel does it say available or not?

    I would like to know if its something wrong with my setup or a bug in the software. 

    Here is another image. Note SSDR is running. The panel says radio is available. Radio is NOT available because its already has SSDR connected to it on this PC.

    It used to say IN USE or something to that effect.


  • John - K3MAJohn - K3MA Member ✭✭
    edited June 2019
    Do you happen to have a wireless network and wired network card installed in the computer?
  • Rich McCabeRich McCabe Member ✭✭
    edited June 2019
    No, hard wired only.
  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited June 2019
    Umm how do you open that box?
  • Rich McCabeRich McCabe Member ✭✭
    edited June 2019
    Well in my case it was staying open after starting the radio. I unchecked the auto-start last radio and that went away. Now that I have rechecked that box it is not coming up, but you can open it buy clicking the SSDR icon again.

    In the old days it showed radio in use.


  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited June 2019
    Ok when I do that it says IN USE
  • Rich McCabeRich McCabe Member ✭✭
    edited June 2019
    OK that is how I would expect it to work. In my case its not.
  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited June 2019
    like this
    image
  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited June 2019
    Maybe try another reset to factory?
  • Rich McCabeRich McCabe Member ✭✭
    edited June 2019
    Well as you can see in my screenshot that is not the case for me.  You can see SSDR running (the only radio I have) and shows available. 

    And I just did a factory reset again as I read your last post. No change.
  • Eric-KE5DTOEric-KE5DTO Administrator, FlexRadio Employee admin
    edited June 2019
    Rich,

    I think the real question here is what is meant by Available?  Available means that the radio has a GUI Client slot open that could accept another client connection.

    You make an excellent point that if you already have a client open on the same PC that we don't allow you to make a second connection.  This doesn't mean that the radio doesn't have an open slot (and this is why it shows Available).

    We may be able to look at the information available and present something different, but this becomes a problem of who knows what.  When you start a second instance of SmartSDR, the 2nd instance only knows about the 1st instance presence via the OS (another smartsdr.exe is running) and whatever the radio will tell it via the API.  When you combine this view of information with the fact that when you connect via SmartLink, the client IP shown is the external IP, this means that a change to this interface could cause 2 Computers behind the same external IP from being able to connect to the same radio.

    I hope that helps shed some light on why this is the way it is.  We'll take another look to see what we can do to improve the messaging without restricting someone from connecting that should be able to.  Thanks for the opportunity to explain.
  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited June 2019
    I am on a 6500 with on version 2.5.1  that must be why it tells me in use?
  • Rich McCabeRich McCabe Member ✭✭
    edited June 2019
    Thanks for explanation Eric.

    I just find it confusing. Seems that it should know SSDR already has a client connection and display not available.

    I would not have caught it except I have been randomly getting the error message on startup about not connecting to the same radio from PC.

    Things seemed to have settled down after I unchecked the Autostart last radio option and rechecked it.  As I said above when starting the radio this box was staying open.

    And Bill thanks for your version info.  Non multi client version.


  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited June 2019
    This is complicated stuff...lol
  • edited June 2019
    Yes, I believe Rich's issue is only going to show in v3 and up. It's to allow multi-client operation with a gui app like mine( that's having issues separate from this....developer errors!) To work alongside SSDR at the same time. Or even two instances of SSDR, on the same pc. James WD5GWY
  • edited June 2019
    Rich, I would think it shouldn't show that message from the same instance of SSDR. Much less allow you to try to connect from a running instance of SSDR. James WD5GWY
  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited June 2019
    If you are using multi client, and I am not. Then your radio may have an open slot. That was a good reason given from Eric, but as he said they may visit this sometime.  Complicated indeed.
  • Abed - AB5EDAbed - AB5ED Inactive Employee
    edited June 2019
    Rich,

    I see how this can be confusing!  We've had a request that for situations like this, we show the single station that is already connected next to the "Available", even when another PC/Maestro could connect to the radio with multiFLEX.

    We think that makes sense and will easily show who is currently connected, so our engineering team has implemented this for the next release.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited June 2019
    But the radio IS available.  Just not from the same PC that it is already running on. I suspect you have auto connect enabled.
  • Rich McCabeRich McCabe Member ✭✭
    edited June 2019
    Actually, I had auto connect last radio off for a while and it still did it.

    Oddly enough Tim, I cant shut the auto connect off at the moment. I uncheck auto connect and radio still starts when clicking the SSDR icon.

    I see Auto connect under settings on SmartSDR, CAT and DAX. Are those all independent auto connects?  Regardless I cant see to get it to stop auto connecting.

    EDIT: Is auto connect smartlink what I need to be unchecking?
  • Rich McCabeRich McCabe Member ✭✭
    edited June 2019
    Appears it is :)

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.