Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Echo while doing TX audio setup

Al ReevesAl Reeves Member ✭✭
While doing the TX audio setup for another microphone the audio I'm hearing is delayed creating an echo effect.  The method I'm using is to open 2 slices on the same freq with the TX slice set to VTR and the RX slice to ant 1.  Set for Duplex FDX. The RX audio has a severe echo.  Is this normal or is my setup wrong?  I have watched a video on the internet by NM9P and there is no audio delay in his demo setup.  All comments appreciated. My radio is the 6300 running SmartSDR 2.4.9

Answers

  • Mike_VE3CKOMike_VE3CKO Member ✭✭
    edited April 2019
    You are likely hearing both slices, mute or adjust the volume on slice A to zero.
  • Ken - NM9PKen - NM9P Member ✭✭
    edited June 23
    If you are listening to your second slice and ALSO have MON turned on you will hear both audio sources. The one on your second slice will be delayed due to normal latency delay from the digital processing. Don’t use MON with the FDX technique. Also if you have trouble adjusting to the delay, you can simply use a single slice into XVTR and use the quick record and playback feature to record and listen to your audio.
  • Al ReevesAl Reeves Member ✭✭
    edited March 2019
    TNX for the reply.  I have the volume on the TX slice muted.  Only use the volume on the RX slice.

    Al
  • Al ReevesAl Reeves Member ✭✭
    edited March 2019
    Ken..TNX for your reply.  The MON function is  set to OFF during FDX operation.  I understand I can use the quick record function but that is quiet cumbersome when trying to make incremental adjustments and having to switch back and forth between record and playback.

    In you video there is no delay.  How did you accomplish that?
    Al
  • Ken - NM9PKen - NM9P Member ✭✭
    edited March 2019
    In the video, I am only recording the 2nd slice audio.  It is delayed from my actual mic, but since I am not also recording the mic, you don't hear the delay in my recording.

    In the Tutorial on using the Full Duplex Method, I address the "idiot box" delay problem.  The audio It feeds back to your headphones is delayed just enough to scramble your brain while you talk, making you sound like an idiot until you get used to the delay in your ears!  ha.

    I learned to adapt just by doing it enough that I learned to ignore the delay in my headphones and only pay attention to the SOUND of the audio, not the WORDS.  
    It CAN be done, but it takes a little bit of time and experience to get good at it.
    That is what 45 years in the hobby and just a little bit of broadcast radio experience gets you.

    Another hint... While doing this testing, adjust your RX FIlter sharpness control in the Radio Setup>RX tabs.  There are four settings, each with a different amount of delay (because the sharper the filter skirts, the more delay you will have).  Pick one that reduces the "Brain Scramble" and it will be easier to deal with the delay.  There are certain delay window timings that tend to scramble your head more than others...  

    Just remember to set the filter skirts back to where you want them after testing.

    Good Luck!

    Ken - NM9P
  • Al ReevesAl Reeves Member ✭✭
    edited April 2019
    TNX Ken I'll try setting the RX filters tomorrow.
  • Al ReevesAl Reeves Member ✭✭
    edited April 2019
    Ken.. set the RX filter to low latency and that was much better.  TNX for your assistance

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.