Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

flex control wont work

N3WWLN3WWL Member ✭✭
Windows 10, SmartSDR 2.4.9
Unable to find solution with search function.
Found USB serial device in device manager.
Was COM 3 and changed to 133.
Still unable to get it to work.
Was used on my Windows 7 machine for years.
Had to buy a new PC and can't seem to figure out the problem.
Thanks....

Comments

  • K0FLYK0FLY Gayle-K0FLY Member ✭✭
    edited March 2019
    Hi:

    Maybe your computer is not recognizing the Control Knob.

    On my Win 10 machine, Control Panel/Device manager/ Com Ports, my Flex Control is listed as  " FlexControl USB Control Knob (Com #)" where # is the com port number. 

    Also under Control Panel "Devices and Printers"  section the Flex Control is shown under the unspecified section with the com number underneath (Com 15 in my case). 

    If you cant find the control listed in those two control panel section I think your PC isn't finding the knob.  Try a different USB port on the PC

    Gayle K0FLY 
  • N2TUN2TU Solutions Marketing Specialist Company Adviser ✭✭
    edited March 2019
    Just a thought...is FlexControl enables in SSDR , Radio Set-Up> Radio> FlexControl Enabled.

    73

    Lou N2TU


  • Ken - NM9PKen - NM9P Member ✭✭
    edited June 23
    Check what Lou suggested first. 

    But, you may have had another device conflicting with the FlexControl on COM3 which kept it from making the change to 133. 

    Try unplugging the FlexControl, rebooting the computer, and then plugging it back in while watching Device Manager in Windows to see what number it is assigned.  Make sure it is working before you reassign it to another port.  (I would suggest something in the 98-102 range.)  Then you might need to reboot again.

    If it doesn't show up, you may need to uninstall and reinstall the FlexControl Driver.
  • N3WWLN3WWL Member ✭✭
    edited June 23
    It is not listed under device manager as  FlexControl USB Control Knob (Com #).
    It simply says USB serial device and defaults to COM3.
    All I did was change that to COM 133.
    I just tried changing USB ports to no avail.
  • Ken - NM9PKen - NM9P Member ✭✭
    edited March 2019
    Try this with your FlexControl Unplugged...in your file manager....

    Open the folder    "This PC > Local Disk (C:) > Program Files > FlexRadio Systems > SmartSDR(whatever release version you are running) > 64-bit Drivers > Flex Control"

    Then run "FlexControlUninstall.bat"

    and then run "FlexControlInstall.bat" 

    Then reboot the computer and try to connect the FlexControl again.

    make sure it is activated in the SSDR radio setup tab.

    If this doesn't help, I would suggest opening a support ticket.

    Ken - NM9P
  • N3WWLN3WWL Member ✭✭
    edited March 2019
    Thanks to all.  I had to completely remove all of SmartSDR, DAX, etc..  A reinstall did the trick. 

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.