Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Missing DAX Audi Channel 1 in WinWarbler - If I use Channel 2 it reverts to 1 on TX

jerry sternjerry stern Member
edited October 2019 in SmartSDR for Windows
Flex 6700, I have installed DXLabs and configured as per Dave's instructions for the Signature series.  In Winwarbler,  config under Soundcard Tab - I do not see DAX Audio Channel 1 only Channels 2-8, IQ channels 1-4 and the TX Audio.  I changed Slice A to DAX channel 2 and set this as the Winwarbler RX receive and it decodes fine and it transmits fine but after transmit finishes, Slice A DAX channel always reverts to Channel 1.  There is no band change occurring so persistence should not be the issue.  I don't have any other apps running other than Commander and Winwarbler and I do see DAX Audio RX Channel 1 under my PC audio device manager and the level meter shows it is active when Slice A DAX is set for Channel 1.  If I change Slice A to DAX channel 2 then under PC Audio devices I see the level meter for DAX Audio RX 2 moving and no longer on Channel 1 so I believe its not a PC audio device setting issue.    So the 2 problems are - 1) Why is DAX RX CH 1 not showing on Winwarbler Soundcard and ;2) why can't i use DAX RX CH 2 for Winwarbler without it reverting back to CH1 after each Transmit.

Any help appreciated

Jerry NY2KW

Answers

  • Bob K8RCBob K8RC Old Guy Member ✭✭
    edited February 2019
    I had this exact problem with DAX Ch1 "disappearing". It was ultimately solved by uninstalling EVERYTHING Flex Radio, rebooting & reinstalling SmartSDR. 

    I suspect it was, in my case, the infamous Windows 10 audio system corruption associated with an update.
  • jerry sternjerry stern Member
    edited October 2019
    My Channel 1 is there and working in SSDR it only is missing in WinWarbler.
  • Bob K8RCBob K8RC Old Guy Member ✭✭
    edited February 2019
    DAX exists to connect the radio to other things. If it's not doing that it's " missing". 

    I had exactly that situation,. All indications from SSDR & DAX were peachy keen but Channel 1 was missing from Winwarbler and WSJT-X. 

  • Craig_KØCFCraig_KØCF Member ✭✭
    edited February 2019
    This most likely indicates that the DAX names have been mangled by a Windows update. See this link for the symptoms and the fix: http://tinyurl.com/yagbo8zk

  • jerry sternjerry stern Member
    edited October 2019
    I checked and all the SSDR DAX virtual soundcards are correct ---nothing mangled.  More importantly, MMTY, WSJT-X, etc have no problem seeing DAX RX CH1 and work 100% fine.  Appears only to be WW but I just got a reply from Dave at the DXLabs group.io and his reply was surprisingly sarcastic... basically said to talk to FLEX.  It makes me think this is some unpleasant conflict between him and the SSDR crew.  I will use the opportunity to try something other than DXLabs.  

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.