Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Can't transmit FT8 Using Smartlink

N5CQN5CQ Member
Installed SmartSDR 2.4.9 with no problems, SSB and CW work fine, now trying FT8. Transmit works fine in CW and SSB, as does TUNE in SSDR. TUNE in WSKT 1.9.1 switches the PTT but no power out. Receiving FT8 sigs fine, with TX ENABLE PTT switches and messages appear to be sent, but no power out at any TX Gain setting. DAX control panel says "DAX TX off" no matter how I try to set things up. Previous forum hints of using COM# with TS2000 as radio or localhost:port with TCP and Flex6xxx as radio for the TX stream do not work. Should I be using the IP of the remote 6700? Has anyone made this work? 73 John N5CQ

Answers

  • W7KHZW7KHZ Member ✭✭
    edited October 2018
    Was this working under a previous version? Or is this the first attempt to set this up? Also, how remote is the radio? Is it on the local network your using or are you trying to use it off the network the radio is connected to? If your not on the same network connection, then I would STRONGLY recommend using a remote session into a computer that is tied to the same network the radio is on. Mostly due to the timing sync requirements for reliable operation of FT8.
  • N5CQN5CQ Member
    edited October 2018
    This is first attempt to do FT8. Radio is about 14 miles away as the crow files, but on same ISP as home location, network diagnostics range from good to excellent  75 ms average latency - max 200 - no issues using CW or SSB. As I understand it, remote FT8 should work in SSDR 2.4.9 without a local PC at the transmitter site, so that's what I am trying first.  73 John N5CQ

  • Jim GilliamJim Gilliam Member
    edited October 2018
    Is you DAX button enabled? Is the TX gain on your DAX set properly? Do you see a red line on the DAX TX Gain?
  • W7KHZW7KHZ Member ✭✭
    edited October 2018
    OK, then there is a lot to go through. First, it is POSSIBLE to make FT8 "work" as you describe. but, i would not recommend it. Even computers that are on the same hub as a radio (of any type) have issues when the timing is not as precisely tracked as it should be. Running a remote audio session like this is trouble with a big T. Reliable FT8 operation depends on very reliable clock synch to get good results in most current band conditions.
    Being on the same ISP really does not do anything for you. Its being located on the same physical network as the radio that helps maintain the timing better. With that said, as with most systems, the speed and bandwidths will improve over time, so this will not likely be as much of a factor as it is today. But, then again, there will be a new mode that will exploit speed......Maybe FT1024 or something like that......
    Second, with your connection to your radio, are you using a VPN connection to your network? And, I am referring to one that is a real VPN with a key vs a service offered by a provider that masks your network and devices from the internet. Or is your remote location IP and port mapped to the local area network that your radio is on?
    I would suspect that your only trying to connect to the radio via the Smartlink server and not "minding" the addressing and ports being used by the WSJTX application. The application (if it works on a local connection to the radio) does not know how to talk to the radio if it is on another network, using a digital connection. From what I can tell, Smartlink only supports the SmartSDR connection and not the way that WSJTX works (maybe FLEX can look at a better interface with "Joe" to allow his cool apps to work better).
    WSJTX remote works great, when you are using a local computer near the radio and a remote session. A good used cheap laptop of fairly recent vintage is a good source. TeamViewer works very well until the day they decide that you may be a commercial or school user and they **** your account (based on the MAC of the device in the machine and not the user name or computer name).
    Sorry if this is TMI. There is a lot of stuff wrapped up in resolving this and getting good reliable remotes to work like you want. We have two 6300's remotely running 24 x 7 and provide access to a few people that support our efforts, or are just nice to work with...........Hope any of this rambling may be helpful.
  • N4VLKN4VLK Member
    edited October 2018
    I have the same problem as N5CO.  It has nothing to do with clock sync, there is absolutely no output when you key FT-8.  Not even if you do a tune.  As John said, works fine with tune and mox (done on SDR Smart) and with other modes, just not WSJT-X, even though it shows it is transmitting.  It is the same whether you are on the local network or otherwise.  I setup a hotspot on my phone to test off local network.  It even shows the Flex is keyed but there is no output.  WSJT-X cat and ppt test show good.
  • roger na4rrroger na4rr Member
    edited October 2018
    And of course just closing the dax panel and re-opening will fix a lot of the flaky quirks of dax.
  • Ed N5DGEd N5DG Member
    edited October 2018
    I had this same issue , I don't do remote so local . I found 3 ways to make the power out ! As I say my problem was the  same WSJT-X would key but no output power . My Fix in WSJT was while in the 15 sec RX sequence, I ticked File / settings , clicked OK and the next TX seq I had power out ... Another way was to change from DIGU to CW and back to DIGU . the third was to change ANT1 to RX A  and back .. I would like to know if any of these work for you , Please let me know
    Ed
  • Ed N5DGEd N5DG Member
    edited October 2018
    I forgot to mention this started with 2.4.9 , I'm back to 2.3.9 , now all is good for me .
     
  • Peter WB6POTPeter WB6POT Member ✭✭
    edited June 11
    I have also had this problem.  Seems to pop up after some windows updates.  What has always worked for me is to do a complete uninstall of SmartSDR followed by a fresh install.

    Peter - WB6POT
  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited October 2018
    In addition to the scrambled DAX IQ devices there is usually a DAX TX that is incorrect as well. This isn’t just a DAX issue with Windoze 10. It happens with VAC which is used for the older model radios. Dave wo2x

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.