Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

GPSDO On 6700 Erratic

K1FRK1FR Member ✭✭
Just recently my 6700 started having occasional problems with the GPSDO not locking up. It would stay in "holdover" mode. The number of satellites visible seemed to vary rapidly, jumping from 15 to 6 and back in just seconds. Satellites tracked stuck at 99 which is obviously not a good sign.

Running SSDR v2.3.9.

Tonight, it appears to be a permanent situation.  Repeated power downs, removal of power and restarts and executing the "uninstall" then "reinstall" commands for the GPSDO have not changed the holdover status.

Searching the community site indicates this could be a bad antenna (has always been indoors), a bad GPSDO board, or an issue with the GPSDO board connections.

I intend to open up the radio tomorrow and try removing and reinstalling the GPSDO. Just wondering if there are any other suggestions?

Maybe it is time for trouble ticket and trip back to Texas?

Thanks for any suggestions.

73, Tom


  • George KF2TGeorge KF2T Member ✭✭✭
    edited February 2019
    Have you done a complete “factory” reset? That will usually nail any weird software states. If you can pick up a replacement antenna (they’re pretty generic), I would try that before comsidering shipping it to the mothership. Opening a ticket is probably a good idea, too.
  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited August 2018
    Don't gett too far ahead talking about sending the radio in. When they contact you to trouble shoot this, they may ask you to re seat the board. And try another antenna, yes even if it's been in doors.

    There will be a number of test they will do with you to determin what is going on. And if they do find the problem is the GPSO board then they can send you one and you can install it yourself,,I think.
  • edited August 2018
    Get a new antenna for the gps. I had the same problem the that fixed it for me. Never had a problem again.
  • Jay NationJay Nation Member
    edited May 2019
    I've got the GPSDO option in my 6500, I have had several instances of what seemed to be permanent holdover status. 

    They have all, so far, been "not" so permanent.

    I'm using both the stock indoor antenna, and another "outdoor" rated stock antenna. One mounted on the inside of a shack window with about half the sky visible.. The other mounted outdoors attached to the roof facia board outside, and just above the window.  The outdoor antenna has a better 360 degree view of the sky, but both seem to work well enough. Sometimes just switching to the other antenna solves the holdover problem, it's in effect doing the same thing I'll describe below.

    Try this crazy technique, next time. It doesn't always fix it. but each time I've successfully fixed the permanent holdover problem, it's been one of the steps in the fix.

    Disconnect the GPSDO antenna, for about 30 secs then reconnect it.

    The antenna is powered and has an internal preamp, disconnecting it will power cycle the preamp.

    I'm not sure why power cycling the antenna preamp helps, but it seems to.

    The GPSDO is always powered right? So it's always powering the antenna preamp, right? Perhaps the preamp glitches and stops amplifying the GPS signals correctly, and gets stuck. Then power cycling it, get's it unstuck. I don't think just resetting/rebooting the radio, ever resets the GPSDO board or power cycles the antenna preamp, they are always running whenever the radio is powered.

     Quite often I've seen that this caused the GPSDO to begin to acquire, and track, the satellites again, and then lock.

    At times, that this hasn't helped, removing power from the radio, or doing a factory reset, afterwards finishes the job.

    Sounds kind of crazy doesn't it.    

        #FlexRadio IRC chat

    For real-time discussions


    User created documentation.

             73, Jay - NO5J

  • Steve K9ZWSteve K9ZW Member ✭✭✭
    edited August 2018

    In troubleshooting I'm always looking for what might have changed. 

    I also experienced GPS lock-up becoming variable - twice.

    In my particular case the solution that worked was repositioning the GPS antenna.  I cannot say with any absoluteness what the detailed issue(s) were - whether foliage growth, some other blanking, a change in the GPS constellation configuration, or the antenna just wanted to feel appreciated. 

    Nonetheless simple relocation  sorted it out. 

    (I'm thinking it was attenuation due to tree growth.)

    Now for confession time - the first time I had GPS lock changes, very early with my radio, I found the antenna was upside-down.  No idea if it worked upside-down until it just didn't, or if it got flipped by someone else.  

    There are also plenty of enhanced performance antenna options to try.

    GL & 73

  • K1FRK1FR Member ✭✭
    edited August 2018
    Thanks to all for the helpful replies! 

    As suggested, the GPSDO holdover condition was not permanent. In the process of troubleshooting, I moved a lot of cabling behind the radio. Got a lock.  I <think> the culprit is the GPS cable or connector. Wiggling the cable seems to affect whether the unit will lock or immediately go into a holdover state following powering up the radio.

    So, off to find a replacement antenna.

    Thanks again to the group. The community is a super resource.

    73, Tom
  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited August 2018
    I was fairly sure that was the problem,,good to hear Tom...
  • W9WLX_ChuckW9WLX_Chuck Member ✭✭
    edited December 2018
    All great suggestions! Another variable is a software problem found its way into the mix at 2.3.7. Try backing up to 2.1.33 and see if symptoms change. Typically what I’ve seen is the color of the power button does not indicate the true GPSDO status, yet it’s working correctly.
  • Carl N8VZCarl N8VZ Member ✭✭
    edited April 15
    I know that this thread is 2 years old, but I just had an experience that I think might help someone else.  I kept getting at first no GPS detected.  Clicking Install did not help at all. Then after several normal shutdowns and startups of the 6600M, I got the "holdover" status, which was persistent through several on/off cycles of the rig.  Then I decided to pull the power cord while the rig was still on -- simulating a power outage.  When I turned the rig back on, I got a new status message: "Warming up."   After about five minutes it reverted to "Holdover" status.  After a little while, it reported 9 visible satellites and 4 being tracked.  It still said status was "Holdover."  So, I next took the cover off and took out the GPS module, cleaned off the connectors that connect with the bottom of the module, replaced the module, put the cover back on and turned on the rig.  It took three restarts, but at that point it finally got past the warming up stage, and this time it advanced to the "locking stage" and then finally after about 20 minutes it announced that it was "locked."  It's now tracking 7 satellites and has 11 visible.  There seems something rather unstable about this module, but for now it appears to be working.  73 de Carl N8VZ

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.