Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

RequiredVersion in API

rfoustrfoust Member ✭✭
edited February 2018 in SmartSDR API
In FlexRequiredVersion.cs, looks like Jenkins is using an old version number?

private static ulong required_version = FlexVersion.Parse("1.4.16.63");

This results in UpdateConnectedState() setting ConnectedState to "Update" when Status = Available.

ConnectedState     : Update
Connected          : False
WanServerConnected : False
Status             : Available

Not a big deal for me, just came across it and thought I should report it.

73,

-Robbie



Comments

  • Mark_W3IIMark_W3II Mark W3II Member ✭✭
    edited February 2018

    Robbie I had the same question. For an app using the FlexAPI as is the short answer is Radio.ConnectedState should be ignored and you should use Radio.Status. The reason for this is ConnectedState compares the radio version to a single value and if it does not match ConnectedState is set to update. So this means if your app only works with a specific version like SmartSDR then you have to update the version value to the version you require then rebuild the API DLL. If your app is coded to work with any version then just ignore the ConnectedState. You could also update the value and change the ConnectedState logic to look for same or newer versions.

    I hope this helps.

    73, Mark AA3RK

  • Eric-KE5DTOEric-KE5DTO Administrator, FlexRadio Employee admin
    edited February 2018
    Correct.  We don't update this file in version control as it is constantly changing internally and would result in a mess.  You're welcome to change that value to the latest version if that helps with your application.
  • Stan VA7NFStan VA7NF President Surrey Amateur Radio Communications Member ✭✭
    edited February 2018
    Does not the API inspect the version number presented and respond in that version's protocol?  Supported levels may be withdrawn after say 1 year or a major release.
    This permits 3rd party users time to upgrade and avoid update urgency on each release that may or may not disable 3rd party execution. 

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.