Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Morse code timing issue during CQWW CW

IW7DMH, Enzo
IW7DMH, Enzo Member ✭✭
edited July 2019 in SmartSDR for Windows
Hello,

during the last CQWW-CW contest I had a frustrating issue with my 6300. It happened a lot of times that the radio sent bad timed cw code. For a reason I can not explain the letters in the same word were sent with long silence intervals in betweens. To be clearer it was like the word PARIS was sent with two letters spaced by 7 dots instead of 3.

 image

It happened randomly like in the past "missing dots issue" but this time the problem is non in the tone generation only because people, on the other side, asked me to repeat the answer.
My configuration was very basic: I was using N1MM and a SSDR-Winkeyer port (SSDR v2 on windows). It seems also, other people, with other logs and other rigs (6500), have had the same issue.

73' Enzo
iw7dmh


Comments

  • Duane_AC5AA
    Duane_AC5AA Member ✭✭
    edited May 2018
    Yes, I have had a similar problem, except I use CWX.  Chasing DX I send my call very often, and sometimes it is sent as A  C5AA .  The problem is less frequent in 1.11 release than the 2 earlier releases.  It did not occur in 1.6 and earlier versions, but showed up after that and appears to still be with us.
  • W9ILY
    W9ILY Member ✭✭
    edited July 2018
    Check your CWX. IF QSK is chosen this caused the problem for me. Uncheck QSK there.
  • Duane_AC5AA
    Duane_AC5AA Member ✭✭
    edited May 2018
    Unless you prefer QSK, which is my preferred option.  
  • James Eastham Jr
    James Eastham Jr Member ✭✭
    edited November 2017
    I had the same problem with Winkeyer Flex 6700 N1MM+. CQWW CONTEST
  • W9ILY
    W9ILY Member ✭✭
    edited July 2018
    I have COM 5 set up on the 6500 for Winkey and N1MM+ has COM 5 set up for CW/Other and Winkey. Operated fine. Previously I had long pauses when I had the QSK checked in CWX.
  • Duane_AC5AA
    Duane_AC5AA Member ✭✭
    edited May 2018
    OK, my comments above were related only to CWX, not to use by a contest logger.  Sorry for any confusion, but since the symptom sounds the same, maybe the cause is the same.  I do run QSK all the time with CWX because I don't want to be calling while the DX is talking.
  • PA2TA
    PA2TA Member ✭✭
    edited November 2017
    Same set-up here as Enzo and the same problem. On top of that, i noticed that part of the first character in a transmission is skipped along with the hickups. Very often my call was taken as EA2TA instead of PA2TA. 

    Switching off QSK is no option for me, one of the main reasons i didn't buy a SDR was that none of them had full QSK capabilities, that is until the 6000 series came up. Flex promises full QSK capabilties up to and exceeding 50 wpm. When i bought my 6300 i had it running with SmartSDR 1.3 and all worked very well! No hickups and real QSK.

    This issue has been around for a very long time now and i was hoping that Flex would have finally fixed it in SSDR v 2.  One would think it can't be too difficult to get this working again. Until they do i am very frustrated with my otherwise fantastic Flex 6300.
  • Kevin
    Kevin Member
    edited July 2019
    Previous contests using CWX and/or the embedded WinKey emulator was problematic. Not only did I have element timing problems in the past but N1MM+ would lock up on me. QSK/delay settings kind of helped but then what's a CW contest without QSK?

    This time I used my new WinKeyer USB and had no problems at all. None. I love to complain but can't find fault here at all. Even my paddles seem to be smoother when run through the WinKeyer USB rather than directly connected to the radio.

    The CW contest last weekend was a real pleasure on the 6500. The WinKeyer USB is now a permanent fixture on my desk.

    Kev
  • PA2TA
    PA2TA Member ✭✭
    edited November 2017
    The old home-build serial interface, with a separate wire running from the PC to the Flex, also worked fine for me. I guess i have to go back to a setup with wires all over the place, like in the old days.  But i always thought that having no wires and interfaces all over the place was one of the strong selling points of the Flexradio and SSDR.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited July 2019
    This is one thing to check.  The WinKeyer emulation port is implemented in software.  Sending CW is a very timing-specific mode and can experience the behavior you described if there is excessive and variable system latency caused by Deferred Procedure Calls (DPCs).  If you are not familiar with DPCs, they also affect streaming of real-time audio.  This HelPDesk article describes DPCs in greater detail: https://helpdesk.flexradio.com/hc/en-us/articles/202118398-What-are-DPCs-and-why-do-they-matter-

    I'd rule out DPCs as a possible culprit as the first step to take in troubleshooting the issue.
  • Kevin
    Kevin Member
    edited November 2017
    The last paragraph of the document provides only two possible solutions. If neither of those solutions work then a new computer is in order I suppose? When buying a new computer, what kind of specs should I look for that would guarantee success?

    Am I sending a "dit-dah" over the Ethernet to the radio that requires such stringent timing or am I sending an "a" over the network to the radio and the radio generates the code? Seems if the radio is generating the code then the timing is in the radio. (Side thought: it also seems that if I'm sending an "a" instead of the individual elements to the radio that maybe the future would allow other modems to be installed such as PSK-31 or RTTY which could eliminate some external software - especially during contests.)

    Is there nothing that can be done with the development of the WinKey emulator or CWX that could reduce the impact of long duration DPCs? 

    73,
    Kev K4VD

  • Duane_AC5AA
    Duane_AC5AA Member ✭✭
    edited November 2017
    While that may contribute, the problem I've heard started after one of the earlier releases (1.6?) and has stuck around since.  1.11 does it but at a much lower frequency than the earlier version.  I'm running a fast desktop with solid network connection.  
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited November 2017
    Fast desktops are not immune to DPCs.  You have to measure them to be certain you do not have them.  And you should test under load for a significant sampling period while running all software to get an accurate assessment.
  • Duane_AC5AA
    Duane_AC5AA Member ✭✭
    edited November 2017
    Thanks, Tim - I'll check it out.  Still doesn't explain why it would start happening after a particular version of SSDR.
  • IW7DMH, Enzo
    IW7DMH, Enzo Member ✭✭
    edited November 2017
    Well,

    LatencyMon states that each time I start a IQ Stream, performances go dramaticaly down. Things go even worse when Firefox is running.
    During the contest, as usually, I was going with two IQ streams (96K sample rate) for two bands skimming purpose.
    So far the story has a bad ending: if I want to have good performance during a contest I have to use a HW keyer or I have to go with a more powerful pc.
    In the first case fall down the myth of the software defined components, while in the second fall down the myth of the tiny client and related tiny resources to run it.

    I can accept all this, but I only have a doubt: is it possible that all of the computers suddenly have become poorly performing?

    73' Enzo
    iw7dmh



  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited November 2017
    I have written up this report as defect #5398 for SmartSDR v1 and v2.
  • WK2Y
    WK2Y Member ✭✭
    edited November 2017
    I am wondering at what code speed these types of problems become evident.  Is it only with high speed code or is this something that could occur say below 20 WPM?
    Thanks.
    73, Bob

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.