Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

wsjt-x 1.8.0 Transmission Timing Problem?

I'm using wsjt-x 1.8.0 on a Flex-6500 in FT8 mode. I've noticed that the rig doesn't start actually transmitting until several seconds into a transmit sequence. This is not a PC time synchronization issue--I'm using NTP to sync my PC's clock and have confirmed it's accurate to well within a second by listening to WWV.

When a 15-second time slot starts, I see other stations transmit for several seconds before my 6500 starts transmitting. Sometimes the rig goes into transmit, but I don't see any output for several seconds.

I didn't have this issue using JT65. Is this just how the FT8 protocol works, or perhaps it's a quirk between the 6500 and wsjt-x?

Comments

  • EA4GLIEA4GLI Salvador Member ✭✭
    edited November 2017
    This might be obvious but.... have you checked that you do not have any delay in the TX chain?
    You can define a delay in milliseconds in the TX tab of the SETUP window.

    Settings > Radio Setup ... > TX (tab)


    image

    This also allows you to set a sequence of the different RCA TX ports. 
     
  • TomTom Member
    edited April 11
    I note  a similar delay. PTT closes on time but RF shown on external power meter appears some 2 seconds later. TX delay is set to zero. It is still possible to make a QSO.

    Tom, SP7WT
  • Dave -- W7IWWDave -- W7IWW Member
    edited June 2018
    Also have noted that a delay occurs in RF output after using wsjt-x over a few hours. Ultimately, program connection will disconnect completely. Have checked all things already noted including time sync. Work-around has been to close both SmartCAT AND wsjt-x, and then restart both programs again and it works perfectly for 4-6 hours. No changes in behavior with latest wsjt-x update. Running 6700.
  • K1UO - LarryK1UO - Larry Member ✭✭
    edited December 2017
    I believe there is also a TX timing delay in the WSJT-X Ver 1.8    File>Settings>Advanced tab also.
  • Cal  N3CALCal N3CAL Member ✭✭
    edited November 2017
    Larry is correct,  what is your your WSJT-X TX Delay? 

    image

    Cal/N3CAL
  • K3DCWK3DCW Member ✭✭
    edited April 2019
    I don't believe this is a 6500 problem. I've seen similar issues with WSJT-X on my Mac driving both my 6500 and a TS-590SG, and have not seen anything like this with the same rigs on a Win10 machine.  It seems to be specific to individual computers, although I have no idea why. 
  • Jerry GardnerJerry Gardner Member
    edited November 2017
    On my 6500, all of the settings in "Settings > Radio Setup ... > TX (tab)" are set to 0.

    On the wsjt-x Settings->Advanced tab Tx delay is set to the default, 0.2s. I don't think this is the issue--the delay I'm seeing is much more than 0.2 second.

  • Mark K5XHMark K5XH Member
    edited November 2017

    I have noticed the same thing when using PSDR. During a RTTY contest I notice that I get a delay between PTT and RF that gets longer and longer as time goes on. If I simply stop PSDR and restart it then the delay goes away. Same thing if I leave everything running without any transmissions for an hour or so.

    I recently tried FT8 and I see the same behavior.

    Flex 5000 + Win 10 (also W7) + Latest PSDR + N1MM+ 

    de K5XH

  • Gary GrantGary Grant Member
    edited December 2017
    Just an idea, if your running an anti-virus program that also manages your ports, like Symantec does, then this can also cause a delay while the program opens it's firewall for the traffic.  I have disabled my anti-virus and Windows firewall and have no issues running FT8 on my 6500. There is no noticeable delay when starting my transmit sequence.  I have seen delays from other hams that match up with what you have been seeing so it is a fairly common problem. Also, don't use WWV to sync your clock, use the nntp program recommended by wsjt and have it sync often, like every hour. Also be sure to turn off the one built into Windows, it is quite bad. Note the time difference between yourself and the other hams in the FT8 program. They should be + or - 1 second or less.  If they are all on the positive or negative side only, and are greater than 1 second then you definitely need to sync your computers clock with nntp.  I'm running Windows 10 on a gigabit network. 
  • Cal  N3CALCal N3CAL Member ✭✭
    edited November 2017
    FWIW,  I'm running Windows 10 and found re-setting the CPU priority for windows programs like SSDR, DAX, and WSJT-X programs from "Normal" to "High" helps and reduces any CPU lags.     Resetting the priority of processes helps the program execute at a faster rate.  Especially when running more than one program at the same time. 

    Go to Task Manager, right click on the program you want to change priority on (SSDR, WSJT-X, DAX, ),  then select "GO to Details" then select "Set Priority" and select "High".  I've found SSDR and WSJT-X runs much smoother that way.  

    Cal/N3CAL 
  • Bob Gerzoff, WK2YBob Gerzoff, WK2Y Member ✭✭
    edited November 2017
    Good idea.  Is there anyway to make it always run as High priority that you know of?
  • John WA7UARJohn WA7UAR Member ✭✭
    edited February 19
    Try using the /HIGH option on the Windows START command. Put it in a batch file. https://ss64.com/nt/start.html
  • Bob Gerzoff, WK2YBob Gerzoff, WK2Y Member ✭✭
    edited November 2017
    Learn something new every day.  Thank you and 73

  • John WA7UARJohn WA7UAR Member ✭✭
    edited February 19
    I just learned that myself today as well from Rob/K6RJI on a Facebook post. Happy to share the knowledge.
  • Jerry GardnerJerry Gardner Member
    edited December 2017
    I don't run any antivirus or firewall software on the rig computer, The only things typically running are SmartSDR, wsjt-x, JT-Alert, and Chrome.I use NTPD to sync my clock with network time servers (I only mentioned WWV in my original post because I used it to verify my clock is accurately set).

    This transmit delay issue only happens with FT8--I don't see it with JT65 or JT9 on the exact same hardware/software setup.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.