Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Can't get 2.0.19 started anymore

Bob Gerzoff, WK2YBob Gerzoff, WK2Y Member ✭✭
edited June 2018 in SmartSDR for Windows
I am running a 6500 with Smart SDR 2.0.19.   I don't know what I did or why it happened but now when I go to start SmartSDR the only thing I get is :
image

I have powered everything down, tried different sequences of booting, waited long periods between boots, reinstalled 2.0.19 and no luck.  

The most bizarre thing is that when I boot my computer, I get the above message without even having started SmartSDR.  Like some kind of virus, whatever gives that message,  runs with no intervention even after a hard boot.  I had a similar issue with 2.0.17 and thought it was fixed but I guess not. 

If you have any suggestions, I would be very appreciative.

73 and thanks.
Bob
WK2Y





Completed · Last Updated

Comments

  • Jim GilliamJim Gilliam Member
    edited October 2017
    You might try restoring your computer to an earlier date, perhaps (probably) something got corrupted on your hard drive.
  • Mike va3mwMike va3mw Member ✭✭
    edited February 2018
    Can you ping the radio?  This sounds like the LAN cable is band, the port on the switch is bad or something similar.  Yes, LAN cables do fail (not very often, but it does happen).

    Can you share any more information?  
  • Bob Gerzoff, WK2YBob Gerzoff, WK2Y Member ✭✭
    edited October 2017
    Yes, I can ping it. No problem.  When I start SmartSDR it says the radio is available.  It's just when I hit connect that I get the message.  Interesting SmartSDR CAT would show  the radio connected even after I close and reopen it, even after I shut down SmartSDR.  If I turn the radio off and restart CAT then it shows radio not connected. Then when I start SmartSDR again, I still get the same message.

  • Ken HansenKen Hansen Member ✭✭
    edited June 2018
    Attempt to connect to radio directly, specifying the IP address?
  • Bob Gerzoff, WK2YBob Gerzoff, WK2Y Member ✭✭
    edited June 2018
    I have a static IP address already assigned.
  • Ken HansenKen Hansen Member ✭✭
    edited October 2017
    My thought was to avoid radio look-up and try direct access...
  • Bob Gerzoff, WK2YBob Gerzoff, WK2Y Member ✭✭
    edited October 2017
    Well, I found a solution.  It was not sufficient to just reinstall the software.  I had to first, do an uninstall of 2.0.19 including the DAX drivers.  After then doing the reinstall, everything seems to be working fine.  Strange, but if that's all it takes, not such a big deal.  Just have to remember for the next time so I don't drive myself nuts (though the XYL would argue that it's too late for that.)

    Thanks everyone for chiming in.

    73
    Bob
    WK2Y
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited October 2017
    Bob, you were getting the message failing to connect to a radio at boot time because you had CAT configured to reconnect to the last radio used.  If that radio was a SmartLink radio and it is not available, then you get the message.  If the radio was on your local LAN and it is not accessible, then you get the message.  

    The setting of these options is covered in the latest version of the SmartSDR CAT Users Guide
  • Bob Gerzoff, WK2YBob Gerzoff, WK2Y Member ✭✭
    edited October 2017
    Oh no.  Guilty of RTFM again!!!  ;-)  I never even realized there were any options to set in CAT.  Thank for your help.
    73, Bob WK2Y
  • Bob Gerzoff, WK2YBob Gerzoff, WK2Y Member ✭✭
    edited October 2017
    Well my troubles have continued and seem to have gotten worse.  At least now, however, since, SMARTCat is not connecting automatically to the last radio used, I can identify that it's not even SmartSDR that is failing to connect, but the message I saw above was coming from SmartSDR CAT. 
    My approach for curing the problem, of reinstalling everything from scratch, no longer works, and I haven't been able to get to the rig despite a day of trying. 

    One thing I notice is that once SmartSDR CAT gives me that error message, it can not be restarted. After I dismiss the error message, CAT disappears from the tray, and when I click on the CAT icon on the desktop to restart it nothing happens.  I've checked in Task Manager and it's not there.  The only way I can restart CAT is to  restart the PC.  

    I should mention that I am Wifi only, no Maestro or remote access,  and when Flex helped me get set up in the beginning, they did some kind of bridging(?) for me.  I get the feeling I have some kind of conflict on my network that is prohibiting CAT from seeing the rig but I haven't a clue on how to diagnose or resolve.

    I'll probably put in a help ticket but if in the meantime, anyone has any suggestions, I am all ears.

    Thanks in advance.

    73,
    Bob
    WK2Y




  • Bob Gerzoff, WK2YBob Gerzoff, WK2Y Member ✭✭
    edited October 2017
    Of course, I had to try one more thing after I posted my message.  After rebooting and having the rig running, I disconnected and then reconnected the ethernet cable at the back of the rig.  This time, although it took a while, CAT did see my rig and then I was able to connect SmartSDR no problem. So does this tell anyone anythng ?  It's only worked once, so I am not sure if it was luck or a fix.  
    Thanks again.
    Bob

  • Bob Gerzoff, WK2YBob Gerzoff, WK2Y Member ✭✭
    edited October 2017
    The saga continues.  After finally getting connected to the rig this morning, I left things up and running and went to do a couple of chores.  When I came back,  there was a message on my screen that said "Session timed out" and CAT was no longer connected and the trick I tried above now doesn't seem to be working.  Where did the time out message come from? 
    Bob  
  • Bob Gerzoff, WK2YBob Gerzoff, WK2Y Member ✭✭
    edited October 2017
    And now I am back in.  I remembered someone saying that CAT needed to connect twice. So, after I couldn't get in, I rebooted the computer, but this time without rebooting the rig or disconnecting the flex.  When I started CAT, it quickly connected to the rig without delay and no problem with SDR.  This is very odd.

  • Bob Gerzoff, WK2YBob Gerzoff, WK2Y Member ✭✭
    edited October 2017
    Just to put a ribbon on this thread, I can not get SMARTCat to reliably connect.  I keep trying different combos and sequences and sometimes wait long periods.  Sometimes it will work, more often than not it won't. After it won't connect, I have to reboot to even get to CAT. 
      I am going to put in a support ticket and see if someone can look at my configuration and figure out what is going on.  I'm sure it has to do with my wifi and bridging. 
    73
    Bob
    WK2Y 
  • Bob Gerzoff, WK2YBob Gerzoff, WK2Y Member ✭✭
    edited October 2017
    I wanted to post a final resolution to this issue.  First, however, I want to say a HUGE THANK YOU to Tim who with a whole lot of patience helped me finally figure out where the issue was.  

    On my network, I  have two ASUS RT-AC1750 routers daisy chained. For whatever reason, whenever I cannot connect SmartSDR  or CAT, if I go and power down the second router, SMARTSDR and CAT will quickly connect.  I can then power up the second router with no issues.  After the power up, all the other devices (there are several) connected to the second router  work fine.   I get the feeling I have something set wrong in the second router, but I will need to go in and take a look. Strange that everything else works fine all the time and the issue is just with SmartSDR and CAT.  

    Again, my appreciation to Tim for all the time he spent with me on this bizarre issue. 

    73
    Bob
    WK2Y

  • Bob Gerzoff, WK2YBob Gerzoff, WK2Y Member ✭✭
    edited November 2017
    A week ago, I thought I was putting this to bed, but now I think I have finally found the real issue.  My PC was bouncing between my upstairs and downstairs routers.  Why that was happening I don't know, but I could absolutely verify that when it did, SmartSDR lost connection.  At that point, I would need to reboot the Flex and then restart SmartSDR.  The silly solution was to slightly reorient the antennas on my upstairs router so that the PC would get a good strong signal and not switch to the downstairs router.  It's been a week and no dropped connections.   Thanks to all those who chimed in. 73

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.