Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Modem lag and latency - poor remote performance

Mike va3mwMike va3mw Member ✭✭
I wanted to share this.

One of the Alpha group members jumped in to help me with challenges I was having with my Cable ISP.  

I was seeing these 200ms lags about ever 1.5 to 2 seconds and it was driving me crazy while remoting to my station.  In fact, it had been happening for some time.  Likely years.

Apparently, there is a modem ChipSet called Puma 6 and there is a bug with the chipset.  
https://www.theregister.co.uk/2016/12/03/intel_puma_chipset_firmware_fix/

This does affect a number of the Aris modems so it seams.  Just to see how bad it is, start poking around the gaming forums.  From their perspective it is so bad, they have created a class action lawsuit (welcome to the US).  

Many cable modes are also possibly affected.

Further testing on my remote with Pingplotter shows a very similar signature.  

image

The above happens with almost no traffic on my net.  The spikes are long ping times to a server 1 hop away from my station.  You would expect to see a flat graph.

Next, I tested my house.  Another Aris modem and the same issue.  

You might consider looking here is you are hearing some minor breakup while operating remote.  
Mike va3mw

p.s.  Here is a list of modems with Puma 6
  • Arris SB6190
  • Arris TG1672G
  • Arris TM1602
  • Super Hub 3 (Arris TG2492LG)  (commonly, **** Media)
  • Hitron CGN3 / CDA / CGNV series modems:
  • Hitron CDA-32372
  • Hitron CDE-32372
  • Hitron CDA3-35
  • Hitron CGNV4
  • Hitron CGNM-3552 (commonly, Rogers)
  • Hitron CGN3 (eg CGN3-ACSMR)
  • Hitron CGNM-2250 (commonly, Shaw)
  • Linksys CM3024
  • Linksys CM3016
  • TP-Link CR7000
  • Netgear AC1750 C6300 AC1900
  • Netgear CM700
  • Telstra Gateway Max (Netgear AC1900 / C6300) (Australia)
  • Cisco DPC3848V
  • Cisco DPC3941B / DPC3941T  (commonly, Comcast Xfinity XB3)
  • Cisco DPC3939
  • Compal CH7465-LG / Arris TG2492LG (commonly, **** Media Hub 3)
  • Samsung Home Media Server

Comments

  • Tim VE6SHTim VE6SH Member ✭✭
    edited March 2019
    Hitron CGNM-2250 (commonly, Shaw)

    Thanks Mike. I am getting a new install at our cottage and have emailed Shaw to confirm the modem#

    Tim VE6SH




  • K5CGK5CG Danny Member ✭✭
    edited October 2018
    I'm still rockin' the Arris SB6183! YAY!
  • Scott N8UMWScott N8UMW Member
    edited September 2017
    My Netgear CM 1000 does not have that chipset, thankfully.
  • Norm - W7CKNorm - W7CK Member ✭✭
    edited September 2017
    That article was dated December 2016 and indicated that Intel was working on a software fix.  Seems they would have had something out by now.

    Norm - W7CK
  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited June 11
    No fix out yet. Dave wo2x
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited June 11
    The 6190 has a firmware update pushed out by SOME ISP’s in April. Not sure how to verify
  • Mike va3mwMike va3mw Member ✭✭
    edited October 2017
    I did a bunch of research and found that some modems had an update, but the fix was questionable.  

  • k3Timk3Tim Member ✭✭
    edited October 2017
    Translation - don't hold your breathe on a s/w fix.
  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited October 2017
    If the problem is the Atom processor on the Puma chipset is overwhelmed at higher bamdwidth I do not believe a software patch will be able to fix it.

    Firmware on my TM1602g is December 2015.

    Called my ISP today and they have no alternative if you want 200+ MB and telephone service.

    Going to call our business rep Monday since we have several cable modems @ 300. MB service at work that use Cisco combo modem/routers for multiple static IP solution.

    Dave wo2x
  • Scott N8UMWScott N8UMW Member
    edited June 11
    Best thing to do is buy your own without that chipset. I had to do some research on that when my previous modem was no longer going to be supported and I wanted to upgrade my speed. The CM 1000 I purchased has been solid and being DOCSIS 3.1 is ready when Comcrap rolls out the gig over cable.
  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited October 2017
    my ISP is skipping DOCSIS 3.1and going straight to FTTH.
    Unfortunately my ISP only supports modems with the PUMA 6 chipset with their telephone service.

    Dave wo2x

  • Scott N8UMWScott N8UMW Member
    edited October 2017
    That's already available at my qth for three bills a month after a grand installation fee and a contract. A full 2Gb though. Smokes Google.
  • Mike va3mwMike va3mw Member ✭✭
    edited February 2018
    Be aware. You can have all the bandwidth in the world and still have bad jitter and latency. Make sure you test and verify. I'll take low jitter and low latency over bandwidth on any day for what I am doing. I have one goal, remote HF operations. Mike
  • Scott N8UMWScott N8UMW Member
    edited October 2017
    Yes sir. The only time i get jitter is when there is reasonable amount of congestion on at&t. Home network and comcrap pretty quick. I get 360 down and 30 up currently with the CM 1000 modem and R8000 WiFi router. Average ping times on Internet around 12 to 14ms. Rarely ever see any dropped packets on the Flex even when it's been on for days or weeks.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.