Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartSDR CAT requires restart before programs "see" port

KC7ESKC7ES Member ✭✭
edited May 18 in SmartSDR CAT
All software starts ok, radio operation nominal. No issues with OS-Win 7. Here's the problem: Using Fldigi; it is set-up to communicate using COM 5; SmartSDR CAT indicates process=Fldigi. However, Fldigi does not successfully poll the radio until I do the following: Shut down SmartSDR CAT, and re-launch it. Then everything is absolutely 100% smooth. I should mention that I always launch the radio to have an active slice before starting Fldigi.
This issue also affect  Smart_S_meter Plus using Com 6. Everything always worked fine under previous versions of SmartSDR CAT...it's only since the upgrade to V2.0x. I have also 'repaired' the VSP driver per a post on the community as well as getting rid or reserved ports through an earlier community post. I am trying to get away from using these com ports wherever possible (using AC Log through the Flex API, for example).This is an minor inconvenience, but an inconvenience just the same. Any ideas? 

Answers

  • GonzaloGonzalo Member ✭✭
    edited October 2017
    I have the same exact problem but it’s not always consistent. I was hoping that V2 would take care of it but it didn’t.
  • KF4HRKF4HR Member ✭✭
    edited October 2017
    I have a similar problem, which has been occurring for awhile now (both with v1.x and v2.x, using Win7).  When I activate FLDigi SDRCat initially indicates Process = FLDigi, then a couple of seconds later SDRCat indicates Process = None.  Initially I thought my Antivirus s/w might be causing the problem but I uninstalled it (Vipre) and still have he same problem.  Dudley has been working with me on the problem, but no luck so far. 
  • KC7ESKC7ES Member ✭✭
    edited October 2017
    So, I first contacted Dudley via helpdesk because AC Log was doing the SAME thing as FLD and Smart meter. It wasn’t until a few weeks back that I ‘discovered ‘ the Flex API choice in AC Log. So...one down, two to go. I ran through all of Dudley’s suggestions to no avail.
  • AH0UAH0U Member
    edited June 2019
    I have the exact same issue with HRD and use the exact same solution to fix it... I thought I was the only one do have said nothing up to now
  • edited June 2019
    And I have the same problem using FLDigi and Logger 32 and have done for about the latest 4 upgrades. Sometimes if I don't open Logger for about 5 minutes after SDRCAT is running, they will work, but most times I have to shut down SDRCAT, then reopen it and everything works. It has become so "usual" that now I just do it automatically. Using Win 7.
  • KC7ESKC7ES Member ✭✭
    edited October 2017
    Brian- I took your suggestion and waited a while to launch the SmartCAT dependent programs, and they launched just fine! So, I wonder what's going on that waiting 5 or 10 minutes solves? I'll try this a few more times and keep notes. Thanks!
  • KF4HRKF4HR Member ✭✭
    edited October 2017
    I tried Brian's suggestion and unfortunately no luck.  Process = None persists.  Everything seems to be working fine except SDRCat.  I hate to consider this, but is there a way to interface a SignaLink sound card interface to a Flex?
  • KC7ESKC7ES Member ✭✭
    edited October 2017
    And this morning...waited some period of time...no luck. Just shut down and re-started CAT and everything works fine. Annoying..
  • GonzaloGonzalo Member ✭✭
    edited October 2017
    Guys, I don’t think we need to hyperventilate. Yes, it’s annoying to restart CAT but Signalink?? Don’t get me wrong I love those babies for my Icom and Yaesu radios but the Flex is nowhere close to needing a Signalink...
  • AH0UAH0U Member
    edited October 2017
    I tried the wait... 15 minutes and it did nothing... the only solution I have found is shut down CAT and restart it
  • John AK4ZJohn AK4Z Member
    edited October 2017
    I have this same problem with my logging software Logic 9...must shut down and restart it to get COM connection to work. Windows 7 and SSDR V2.
  • KF4HRKF4HR Member ✭✭
    edited October 2017
    It sounds like several people are having CAT issues.  FRS, what the heck is going on?

    I'm curious if anyone is experiencing CAT problems with Windows 10?  Short of buying a new PC, I'm at a point of trying anything to get CAT working. 
  • John PfeiferJohn Pfeifer Member
    edited October 2017
    I have had the very same issue and what I found was the when the software was installed it put these items into the msconfig under startup for the cat and dax so these auto start when the computer starts but the problem with this is it/they don't seem to auto connect when it's needed to be used by smartsdr this happened on both my base pc and my remote laptop, I ended up unchecking both in msconfig. What I did is write a batch file to start smartsdr and named it startflex.bat first with a timer for 40 seconds then start the dax wait another 40 seconds then start the cat then wait another 30 seconds then load HDR along with the logbook and digital master 780 starting the latter two with HRD this has worked great for me. I also did the same for closing all the software when done another batch file named stopflex.bat, both icons on the desktop the only thing that is needed is a good task killer, I use process.exe to do this, used to be readily available online the only program that don't like this option is the DM780 which I close manually, windows taskill don't do the job as required. There may be an easier way, but this is how I do it for now. Also my firewall Kaspersky needed approval for these to run right. Hope this helps.
  • AH0UAH0U Member
    edited June 2019
    Interesting g but I think closing CAT and then restarting is dimoner
  • AC9SAC9S Member ✭✭
    edited October 2017
    Same problem here with both CAT and DAX under Win 7.  I stop and restart both after the system boots up.

    Keith - AC9S
  • KC7ESKC7ES Member ✭✭
    edited October 2017
    John-
    I found a small program out on the web called start-up delayer from r2 studios. Very simple to install and set up. Since installing and delaying the two programs by the same times you mentioned, I have not had any more CAT issues.
    Thanks,
    Eric
  • John PfeiferJohn Pfeifer Member
    edited October 2017
    Good to hear..
  • W4TMWW4TMW Member ✭✭
    edited October 2017
    I'm seeing this thread for the first time (put in a ticket this morning) and having the same problem. Rig 6300, v1.11.12.446, Win7.  I had a SmartCAT issue with v1.10.16 and reverted to v1.9.13 to get around it while waiting for the fix (v1.11.12.446) but I assume it's not the same problem we are seeing now.

     Anyway, I just tried a SmartCAT restart and sure enough....all is ok for now. I don't know if DAX was effected or not but thanks for posting this info. 
        Tom, W4TMW
  • John - K3MAJohn - K3MA Member ✭✭
    edited April 2018
    I got to say something bad has happened with the reliability of SmartCat V2.  Prior to V2 I had zero problems with SmartCAT running on three different radios and computers.  Both LAN and VPN WAN operations.  Since upgrading to V2 I have had several random problem with SmartCAT.  Only a reboot of SmartCat seems to get it work correctly again.  No other hardware or software changes except Window 10 updates.  Rarely a couple days pass without having to to restart SmartCAT on one of the three systems.  I cannot nail down the reason it is happening but I operated close to 2 years with no SmartCat issues and now they are a PIA.

    At some point the PIA factor overides the benefits of using the Flex.  Lack of radio dependability and reliability is why I moved from Anan to Flex.  Hopefully, I do not have to face that kind of decision again in the future.

    I already have a batch file that runs automatically to shutdown DAX and restart it in order to help deal with the unreliable operation of DAX on digital modes.  I hope I do not have to use the virtual equivalent of duct tape and banding wire to fix SmartCAT.
  • WW1SS - SteveWW1SS - Steve Member
    edited April 10
    Gosh . . I have had no issues what so ever. Mine has been running flawlessly here except for an occasional dumb operator error.

    Glad I purchased another flex last week as it is a world of difference over the early 1 version which aggravated the heck out of me.


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.