Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

what's up with the 'nag screen' ?

W5XZ - danW5XZ - dan Member ✭✭
updated to v1.11.12..

boot / power up sequence here is

1. wireless extender
2. pc
3. flex 6500 ( sometimes.... ok, usually )
4. DxLab launcher, start..
5. CMDMicro...
6 wsjt-x  (sometimes.)
7 wsjt-x jtAlertX  (works GREAT with wsjt x)
8 OpenHPSDR PowerSDR mRX ps, 3.4.2 (sometimes.) for my Red Pitaya
9 old n1mm greyline ( hey, i like it..)

produces consistently good results, for quite a while...

but, the SmartSDR Cat nag screen, if the 6500 isn't booted in advance??
 the software loads, why do i need this?

like, whas up wi dat?

w5xz, dan

Completed · Last Updated

Answers

  • W5XZ - danW5XZ - dan Member ✭✭
    edited June 2019
    same thing, if i boot my 6500 before my pc...i don't need this nag screen...

    does 2.xx does this too??

    just sayin...w5xz, dan

  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited September 2017
    I have no idea what you are referring to.  There are no "nag screens" in SmartSDR.  Care to share an image?
  • Eric-KE5DTOEric-KE5DTO Administrator, FlexRadio Employee admin
    edited July 2019
    If you're talking about the radio selection screen, it sounds like you may have turned of the option to Auto Connect to the last radio used.  If this is the case, to turn this back on right click on the Radio Connected (or Radio Not Connected) text in the upper right of the SmartSDR CAT main window to bring up the option and the left click to toggle it on or off.
  • KS0CWKS0CW Member ✭✭
    edited September 2017
    I was wondering about this too... It started for me with 1.11 install, I suspect that "of" is the default as I don't recall changing it during or post installation... :)
  • Eric-KE5DTOEric-KE5DTO Administrator, FlexRadio Employee admin
    edited September 2017
    Hmm.  Strange.  It is setup to be on by default as best as I can tell.
  • Greg - KØGDIGreg - KØGDI Member
    edited September 2017
    Is there an option on the main SmartSDR to auto connect to last radio used so when I autostart my computer and have SMARTSDR open I don't have to go and select the radio for it to open.
  • Eric-KE5DTOEric-KE5DTO Administrator, FlexRadio Employee admin
    edited September 2017
    Not yet.  But this is a reasonable suggestion.  For tracking this is #5221.  Thanks.
  • Greg - KØGDIGreg - KØGDI Member
    edited September 2017
    Great!  Will make my APRS setup autonomous upon rebooting.  You guys are the best!
  • Eric-KE5DTOEric-KE5DTO Administrator, FlexRadio Employee admin
    edited September 2017
    Note that you can already use command line arguments to do this sort of thing now.  It's just not as accessible for the less technically inclined.
  • Greg - KØGDIGreg - KØGDI Member
    edited September 2017
    How can I accomplish this?
  • KevinKevin Member
    edited September 2017
    I think this is what you're looking for...
    https://community.flexradio.com/flexradio/topics/simplified-startup

    I haven't tried it with the new versions but used to use it in the icon I used to start up SSDR.
    You can actually do this with a parameter added to the shortcut that starts SmartSDR.  Just add "--serial=nnnn-nnnn-nnnn-nnnn" to the end of the Target line of your shortcut (right click -> Properties) and fill in your serial number for the nnnn's.
  • Jay NationJay Nation Member
    edited September 2017
    Greg
    This has been documented before, here in the Community.
    You do it by editing the Shortcut that you use to start SmartSDR.

    Add a commandline option to the end of that shortcuts Target value.

    My shortcut's default Target value is ...
    "C:Program FilesFlexRadio SystemsSmartSDR v2.0.19SmartSDR.exe"
    Yours should be similar.

    The Serial to use is the Serial number/value displayed in SmartSDR's Radio Setup / Radio / Radio SN: .

    The syntax for the CommandLine string is ...

    --serial=####-####-####-#### 


    "C:Program FilesFlexRadio SystemsSmartSDR v2.0.19SmartSDR.exe" --serial=####-####-####-####

    Put the above into the Target Box.
    Just substitute your Radios Serial Number for the #'s.
    Make sure to insert a single space, between the final " and the --serial=.

    The Shortcut should now autostart SmartSDR, allowing you to skip choosing which radio you want it to connect to.

    73 Jay - NO5J 
  • Greg - KØGDIGreg - KØGDI Member
    edited September 2017
    That worked wonderfully!  One less step in the boot up process for the APRS DIGI / IGATE.
  • W5XZ - danW5XZ - dan Member ✭✭
    edited June 2019
    when i now boot my shack pc, i get this:
    • image
  • W5XZ - danW5XZ - dan Member ✭✭
    edited June 2019
    before i upgraded i got this:
    image
  • W5XZ - danW5XZ - dan Member ✭✭
    edited June 2019
    i may, or may not choose to boot the 6500 on the shack pc...but i don't need this 'nag screen'..

    just sayin...

    w5xz, dan

  • W5XZ - danW5XZ - dan Member ✭✭
    edited September 2017
    thanks eric, that fixes it...

    73, w5xz

  • Phill BeistelPhill Beistel Member
    edited June 2019
    Did you try to minimize the 'Nag Screen'? I had this happen in an earlier version And once I minimized the cat screen and rebooted minimized it stayed! Just sayin!
  • W5XZ - danW5XZ - dan Member ✭✭
    edited September 2017
    thanks Phill....eric's tip, above, solved my problem..

  • Duane  N9DGDuane N9DG Member
    edited September 2017
    I saw this too. Note that it was the SmartCAT radio chooser, not the GUI client radio chooser dialog. It only occurred once after the initial install and before the SmartCAT client re-established a relationship with the radio box. Simply selected the radio in the dialog, minimized it, and haven't seen it come up since.

    Given the remove and reinstall changes done by the SmartSDR installer to the VSP code as part of the 1.11 upgrade, it makes sense why this could occur.

    Additionally I should note that I'm running Win7 Home x64. I log into the computer with a non admin level account. Then launch SmartSDR client with right click "Run as administrator".

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.