Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

No activity on spectrum or waterfall upon restart V2

13»

Comments

  • Sam LeachSam Leach Member
    edited July 2017
    Problem resolved on our circuit ... our fix may help others

    In an early post to this thread, Tim mentioned fragmentation  ... that was the answer for me and VO1IDX.  My cable modem firewall had an option to block fragmented packets.  I unchecked it and the panafall works fine in Newfoundland.  We re-enabled the blocking feature and the panafall goes away.  So, you need to be allowing fragmented packets through any firewall involved.

    73

    Sam K3KLC
    and
    Chris VO1IDX
  • Ken - NM9PKen - NM9P Member ✭✭
    edited July 2017
    WOW...Nice catch!  

    The fun starts now!

    Enjoy...

    Ken - NM9P
  • Peter K1PGVPeter K1PGV Member ✭✭
    edited July 2017
    Excellent find. Good thinking!  BRAVO!  Yay!  Congratulations!!

    This WILL help MANY people.

    >My cable modem firewall had an option to block fragmented packets

    There are third-party firewall/AV products that also block fragmented packets... so knowing that you must DISable this blocking will be very helpful to folks going forward.

    I very pleased to hear you found the solution.

    (Having SAID that, it would be nice if the MTU was discovered by SmartLink and this was not necessary... but, maybe that will happen in some future release).

    Peter
    K1PGV
  • Jim  KJ7SJim KJ7S Member ✭✭
    edited June 23
    Maybe Tim could comment on the firewall thing as well. I wondering if by chance it's the size of the packets formed, in that the size is 1518  vs the max packet size is at 1500? therefore the packet is fragmanted and the firewall is stopping it...until it is changed.
  • Peter K1PGVPeter K1PGV Member ✭✭
    edited July 2017
    (1518 is the max size with Ethernet header/checksum... 1500 is the max "message" size)

    It doesn't matter: If the radio is generating 1500 byte packets... or even 1200 byte packets... it is *extremely* likely that on the path from SSDR to the radio over the Internet there will be SOME intermediate system that can't handle a packet that large.

    You can check this out by looking at the WireShark/Ethereal trace and seeing the largest IP packet you receive.

    There's really very little risk to passing fragmented IP packets, and allowing fragmented packets to pass is extremely common. Anybody doing gaming will need to allow fragmented IP packets, for example. There *are* some very basic IP fragmentation exploits, but they are pretty mundane and easily countered by any good system or piece of network equipment.

    Peter
    K1PGV

  • Bob W4PGBob W4PG Member
    edited July 2017
    I just looked at my router and the maximum MTU I can set is 1500.  Me-thinks I need to upgrade as this router is several years old!! :-)

  • Peter K1PGVPeter K1PGV Member ✭✭
    edited July 2017
    1500 is perfectly fine. No need to upgrade because of that. Peter K1PGV
  • Bob W4PGBob W4PG Member
    edited July 2017
    Thanks, Peter.  I don't know much about packet size but figured that might be an issue.  The D-Link router I have at work does not have an option for accepting fragmented packets.  My home router (Arris) does.  So I'm guessing there is some setting in the D-Link that does something similar but not sure what that would be. As I mentioned, the D-Link router I'm using is several years old. 
      
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited July 2017
    The radio does not use jumbo frames.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited July 2017
    I suspect the "malformed" VITA-49 packet was one of the smaller fragments that got through.
  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited August 2017
    Tim, if jumbo frames were enabled in the router but the radio and PC were not set to use jumbo frames, would this cause issues? Also if the router and PC support jumbo frames but the radio doesn't would that be an issue? I never have jumbo frames enabled on any of my networking equipment but figures I'd ask so I understand if it would affect other users who may have it enabled in the router.. 73 Dave wo2x
  • Hank WolflaHank Wolfla Member
    edited August 2017
    My system was working great.  When I tried to log in I had no audio or display on the spectrum.  The rig changes freq, but no audio or spectrum.  Any suggestions.  Have tried rebooting the computer, and reinstalling the software on the client computer, still no luck.  Nothing has changed on my network and I have not done anything to the client computer.  Thanks for any input  Hank K9LZJ
  • edited April 2018
    I have Time Warner now Spectrum and do not see waterfall on local PC with my 6600 at Remote site on Charter network. MTU is set to 1500 and not blocking fragmented packets. I can see same on IPhone if on WiFi off the Canle router but looks fine if go to Verizon over the air data and turn off WI-FI. Call in tomorrow to see if blocking by waterfall traffic. Display is same as others here. 73, Russ K5OA
  • edited April 2018
    I worked the issue yesterday and found three units running Smartlink did not display the waterfall but all else worked fine. Expected the ISP blocking some packets, At first light today, all three units are ok and displaying the waterfall without a change in router setting or ISP! SmartLink issue?

    Thanks, Russ K5OA

  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited April 2018
    Count yourself lucky and be thankful.  I suspect your ISP did something overnight or something rebooted and all is well in Beantown again.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.